<!DOCTYPE html>
<html lang="en-US">
<head>
<meta name="viewport" content="width=device-width, user-scalable=no, initial-scale=1.0, minimum-scale=1.0, maximum-scale=1.0">
<meta http-equiv="Content-Type" content="text/html; charset=UTF-8" />
<link rel="profile" href="http://gmpg.org/xfn/11" />
<link rel="pingback" href="https://archiecomics.com/xmlrpc.php" />
<meta name='robots' content='index, follow, max-image-preview:large, max-snippet:-1, max-video-preview:-1' />

	<!-- This site is optimized with the Yoast SEO plugin v19.7.1 - https://yoast.com/wordpress/plugins/seo/ -->
	<title>New Archie Comics Releases for 11/9/22 - Archie Comics</title>
	<meta name="description" content="Christmas officially begins now in today&#039;s new releases! Read on for a look inside the new Archie comics on-sale November 9, 2022:" />
	<link rel="canonical" href="https://archiecomics.com/new-archie-comics-releases-for-11-9-22/" />
	<meta property="og:locale" content="en_US" />
	<meta property="og:type" content="article" />
	<meta property="og:title" content="New Archie Comics Releases for 11/9/22 - Archie Comics" />
	<meta property="og:description" content="Christmas officially begins now in today&#039;s new releases! Read on for a look inside the new Archie comics on-sale November 9, 2022:" />
	<meta property="og:url" content="https://archiecomics.com/new-archie-comics-releases-for-11-9-22/" />
	<meta property="og:site_name" content="Archie Comics" />
	<meta property="article:publisher" content="https://www.facebook.com/ArchieComicsOfficial" />
	<meta property="article:published_time" content="2022-11-09T14:00:37+00:00" />
	<meta property="article:modified_time" content="2022-11-09T21:04:42+00:00" />
	<meta property="og:image" content="https://archiecomics.com/wp-content/uploads/2022/11/WorldOfBettyAndVeronicaJumboComicsDigest_020-2.jpg" />
	<meta property="og:image:width" content="1047" />
	<meta property="og:image:height" content="574" />
	<meta property="og:image:type" content="image/jpeg" />
	<meta name="author" content="Jesse Post" />
	<meta name="twitter:card" content="summary_large_image" />
	<meta name="twitter:creator" content="@archiecomics" />
	<meta name="twitter:site" content="@archiecomics" />
	<meta name="twitter:label1" content="Written by" />
	<meta name="twitter:data1" content="Jesse Post" />
	<meta name="twitter:label2" content="Est. reading time" />
	<meta name="twitter:data2" content="3 minutes" />
	<script type="application/ld+json" class="yoast-schema-graph">{"@context":"https://schema.org","@graph":[{"@type":"Article","@id":"https://archiecomics.com/new-archie-comics-releases-for-11-9-22/#article","isPartOf":{"@id":"https://archiecomics.com/new-archie-comics-releases-for-11-9-22/"},"author":{"name":"Jesse Post","@id":"https://archiecomics.com/#/schema/person/0c9d5a47ba5d680d6d911712d7ee2042"},"headline":"New Archie Comics Releases for 11/9/22","datePublished":"2022-11-09T14:00:37+00:00","dateModified":"2022-11-09T21:04:42+00:00","mainEntityOfPage":{"@id":"https://archiecomics.com/new-archie-comics-releases-for-11-9-22/"},"wordCount":267,"publisher":{"@id":"https://archiecomics.com/#organization"},"image":{"@id":"https://archiecomics.com/new-archie-comics-releases-for-11-9-22/#primaryimage"},"thumbnailUrl":"https://archiecomics.com/wp-content/uploads/2022/11/WorldOfBettyAndVeronicaJumboComicsDigest_020-2.jpg","keywords":["betty and veronica","betty and veronica friends forever","christmas","new releases","on sale today","world of betty and veronica digest"],"articleSection":["News","On Sale Today"],"inLanguage":"en-US"},{"@type":"WebPage","@id":"https://archiecomics.com/new-archie-comics-releases-for-11-9-22/","url":"https://archiecomics.com/new-archie-comics-releases-for-11-9-22/","name":"New Archie Comics Releases for 11/9/22 - Archie Comics","isPartOf":{"@id":"https://archiecomics.com/#website"},"primaryImageOfPage":{"@id":"https://archiecomics.com/new-archie-comics-releases-for-11-9-22/#primaryimage"},"image":{"@id":"https://archiecomics.com/new-archie-comics-releases-for-11-9-22/#primaryimage"},"thumbnailUrl":"https://archiecomics.com/wp-content/uploads/2022/11/WorldOfBettyAndVeronicaJumboComicsDigest_020-2.jpg","datePublished":"2022-11-09T14:00:37+00:00","dateModified":"2022-11-09T21:04:42+00:00","description":"Christmas officially begins now in today's new releases! Read on for a look inside the new Archie comics on-sale November 9, 2022:","breadcrumb":{"@id":"https://archiecomics.com/new-archie-comics-releases-for-11-9-22/#breadcrumb"},"inLanguage":"en-US","potentialAction":[{"@type":"ReadAction","target":["https://archiecomics.com/new-archie-comics-releases-for-11-9-22/"]}]},{"@type":"ImageObject","inLanguage":"en-US","@id":"https://archiecomics.com/new-archie-comics-releases-for-11-9-22/#primaryimage","url":"https://archiecomics.com/wp-content/uploads/2022/11/WorldOfBettyAndVeronicaJumboComicsDigest_020-2.jpg","contentUrl":"https://archiecomics.com/wp-content/uploads/2022/11/WorldOfBettyAndVeronicaJumboComicsDigest_020-2.jpg","width":1047,"height":574},{"@type":"BreadcrumbList","@id":"https://archiecomics.com/new-archie-comics-releases-for-11-9-22/#breadcrumb","itemListElement":[{"@type":"ListItem","position":1,"name":"Home","item":"https://archiecomics.com/"},{"@type":"ListItem","position":2,"name":"New Archie Comics Releases for 11/9/22"}]},{"@type":"WebSite","@id":"https://archiecomics.com/#website","url":"https://archiecomics.com/","name":"Archie Comics","description":"","publisher":{"@id":"https://archiecomics.com/#organization"},"potentialAction":[{"@type":"SearchAction","target":{"@type":"EntryPoint","urlTemplate":"https://archiecomics.com/?s={search_term_string}"},"query-input":"required name=search_term_string"}],"inLanguage":"en-US"},{"@type":"Organization","@id":"https://archiecomics.com/#organization","name":"Archie Comics Publications, Inc.","url":"https://archiecomics.com/","sameAs":["https://www.instagram.com/archiecomics/","https://www.pinterest.com/archiecomics/","https://www.youtube.com/user/ArchieComicsOfficial","https://www.facebook.com/ArchieComicsOfficial","https://twitter.com/archiecomics"],"logo":{"@type":"ImageObject","inLanguage":"en-US","@id":"https://archiecomics.com/#/schema/logo/image/","url":"https://archiecomics.com/wp-content/uploads/2014/08/Archie_Logo-1.jpg","contentUrl":"https://archiecomics.com/wp-content/uploads/2014/08/Archie_Logo-1.jpg","width":750,"height":316,"caption":"Archie Comics Publications, Inc."},"image":{"@id":"https://archiecomics.com/#/schema/logo/image/"}},{"@type":"Person","@id":"https://archiecomics.com/#/schema/person/0c9d5a47ba5d680d6d911712d7ee2042","name":"Jesse Post","image":{"@type":"ImageObject","inLanguage":"en-US","@id":"https://archiecomics.com/#/schema/person/image/","url":"https://secure.gravatar.com/avatar/5998aa36d17ed36b30b20065c5006017?s=96&d=mm&r=g","contentUrl":"https://secure.gravatar.com/avatar/5998aa36d17ed36b30b20065c5006017?s=96&d=mm&r=g","caption":"Jesse Post"},"url":"https://archiecomics.com/author/jpost/"}]}</script>
	<!-- / Yoast SEO plugin. -->


<script type='application/javascript'>console.log('PixelYourSite Free version 9.2.0');</script>
<link rel='dns-prefetch' href='//s.w.org' />
<link rel="alternate" type="application/rss+xml" title="Archie Comics &raquo; Feed" href="https://archiecomics.com/feed/" />
<link rel="alternate" type="application/rss+xml" title="Archie Comics &raquo; Comments Feed" href="https://archiecomics.com/comments/feed/" />
<script type="text/javascript">
window._wpemojiSettings = {"baseUrl":"https:\/\/s.w.org\/images\/core\/emoji\/14.0.0\/72x72\/","ext":".png","svgUrl":"https:\/\/s.w.org\/images\/core\/emoji\/14.0.0\/svg\/","svgExt":".svg","source":{"concatemoji":"https:\/\/archiecomics.com\/wp-includes\/js\/wp-emoji-release.min.js?ver=6.0.2"}};
/*! This file is auto-generated */
!function(e,a,t){var n,r,o,i=a.createElement("canvas"),p=i.getContext&&i.getContext("2d");function s(e,t){var a=String.fromCharCode,e=(p.clearRect(0,0,i.width,i.height),p.fillText(a.apply(this,e),0,0),i.toDataURL());return p.clearRect(0,0,i.width,i.height),p.fillText(a.apply(this,t),0,0),e===i.toDataURL()}function c(e){var t=a.createElement("script");t.src=e,t.defer=t.type="text/javascript",a.getElementsByTagName("head")[0].appendChild(t)}for(o=Array("flag","emoji"),t.supports={everything:!0,everythingExceptFlag:!0},r=0;r<o.length;r++)t.supports[o[r]]=function(e){if(!p||!p.fillText)return!1;switch(p.textBaseline="top",p.font="600 32px Arial",e){case"flag":return s([127987,65039,8205,9895,65039],[127987,65039,8203,9895,65039])?!1:!s([55356,56826,55356,56819],[55356,56826,8203,55356,56819])&&!s([55356,57332,56128,56423,56128,56418,56128,56421,56128,56430,56128,56423,56128,56447],[55356,57332,8203,56128,56423,8203,56128,56418,8203,56128,56421,8203,56128,56430,8203,56128,56423,8203,56128,56447]);case"emoji":return!s([129777,127995,8205,129778,127999],[129777,127995,8203,129778,127999])}return!1}(o[r]),t.supports.everything=t.supports.everything&&t.supports[o[r]],"flag"!==o[r]&&(t.supports.everythingExceptFlag=t.supports.everythingExceptFlag&&t.supports[o[r]]);t.supports.everythingExceptFlag=t.supports.everythingExceptFlag&&!t.supports.flag,t.DOMReady=!1,t.readyCallback=function(){t.DOMReady=!0},t.supports.everything||(n=function(){t.readyCallback()},a.addEventListener?(a.addEventListener("DOMContentLoaded",n,!1),e.addEventListener("load",n,!1)):(e.attachEvent("onload",n),a.attachEvent("onreadystatechange",function(){"complete"===a.readyState&&t.readyCallback()})),(e=t.source||{}).concatemoji?c(e.concatemoji):e.wpemoji&&e.twemoji&&(c(e.twemoji),c(e.wpemoji)))}(window,document,window._wpemojiSettings);
</script>
<style type="text/css">
img.wp-smiley,
img.emoji {
	display: inline !important;
	border: none !important;
	box-shadow: none !important;
	height: 1em !important;
	width: 1em !important;
	margin: 0 0.07em !important;
	vertical-align: -0.1em !important;
	background: none !important;
	padding: 0 !important;
}
</style>
	<link rel='stylesheet' id='wp-block-library-css'  href='https://archiecomics.com/wp-includes/css/dist/block-library/style.min.css?ver=6.0.2' type='text/css' media='all' />
<style id='global-styles-inline-css' type='text/css'>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</style>
<link rel='stylesheet' id='wonderplugin-carousel-engine-css-css'  href='https://archiecomics.com/wp-content/plugins/wonderplugin-carousel/engine/wonderplugincarouselengine.css?ver=18.7C' type='text/css' media='all' />
<link rel='stylesheet' id='tempera-fonts-css'  href='https://archiecomics.com/wp-content/themes/tempera/fonts/fontfaces.css?ver=1.8.0' type='text/css' media='all' />
<link rel='stylesheet' id='tempera-style-css'  href='https://archiecomics.com/wp-content/themes/tempera-nocopyrt/style.css?ver=1.8.0' type='text/css' media='all' />
<style id='tempera-style-inline-css' type='text/css'>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</style>
<link rel='stylesheet' id='nirvana-mobile-css'  href='https://archiecomics.com/wp-content/themes/tempera/styles/style-mobile.css?ver=1.8.0' type='text/css' media='all' />
<script type='text/javascript' src='https://archiecomics.com/wp-includes/js/jquery/jquery.min.js?ver=3.6.0' id='jquery-core-js'></script>
<script type='text/javascript' src='https://archiecomics.com/wp-includes/js/jquery/jquery-migrate.min.js?ver=3.3.2' id='jquery-migrate-js'></script>
<script type='text/javascript' src='https://archiecomics.com/wp-content/plugins/wonderplugin-carousel/engine/wonderplugincarouselskins.js?ver=18.7C' id='wonderplugin-carousel-skins-script-js'></script>
<script type='text/javascript' src='https://archiecomics.com/wp-content/plugins/wonderplugin-carousel/engine/wonderplugincarousel.js?ver=18.7C' id='wonderplugin-carousel-script-js'></script>
<script type='text/javascript' src='https://archiecomics.com/wp-content/plugins/pixelyoursite/dist/scripts/jquery.bind-first-0.2.3.min.js?ver=6.0.2' id='jquery-bind-first-js'></script>
<script type='text/javascript' src='https://archiecomics.com/wp-content/plugins/pixelyoursite/dist/scripts/js.cookie-2.1.3.min.js?ver=2.1.3' id='js-cookie-js'></script>
<script type='text/javascript' id='pys-js-extra'>
/* <![CDATA[ */
var pysOptions = {"staticEvents":{"facebook":{"init_event":[{"delay":0,"type":"static","name":"PageView","pixelIds":["150910205450480"],"eventID":"327584ab-c296-443a-a51b-e3ade1833940","params":{"post_category":"News, On Sale Today","page_title":"New Archie Comics Releases for 11\/9\/22","post_type":"post","post_id":28934,"plugin":"PixelYourSite","user_role":"guest","event_url":"archiecomics.com\/new-archie-comics-releases-for-11-9-22\/"},"e_id":"init_event","ids":[],"hasTimeWindow":false,"timeWindow":0,"woo_order":"","edd_order":""}]}},"dynamicEvents":{"automatic_event_form":{"facebook":{"delay":0,"type":"dyn","name":"Form","pixelIds":["150910205450480"],"eventID":"e9f2e420-8ea7-4a5d-bbbd-de09130a12b8","params":{"page_title":"New Archie Comics Releases for 11\/9\/22","post_type":"post","post_id":28934,"plugin":"PixelYourSite","user_role":"guest","event_url":"archiecomics.com\/new-archie-comics-releases-for-11-9-22\/"},"e_id":"automatic_event_form","ids":[],"hasTimeWindow":false,"timeWindow":0,"woo_order":"","edd_order":""}},"automatic_event_download":{"facebook":{"delay":0,"type":"dyn","name":"Download","extensions":["","doc","exe","js","pdf","ppt","tgz","zip","xls"],"pixelIds":["150910205450480"],"eventID":"7fcf4b0f-4828-47b6-828d-821785f692eb","params":{"page_title":"New Archie Comics Releases for 11\/9\/22","post_type":"post","post_id":28934,"plugin":"PixelYourSite","user_role":"guest","event_url":"archiecomics.com\/new-archie-comics-releases-for-11-9-22\/"},"e_id":"automatic_event_download","ids":[],"hasTimeWindow":false,"timeWindow":0,"woo_order":"","edd_order":""}},"automatic_event_comment":{"facebook":{"delay":0,"type":"dyn","name":"Comment","pixelIds":["150910205450480"],"eventID":"41ca3814-8453-4028-8660-77df0f0df1ae","params":{"page_title":"New Archie Comics Releases for 11\/9\/22","post_type":"post","post_id":28934,"plugin":"PixelYourSite","user_role":"guest","event_url":"archiecomics.com\/new-archie-comics-releases-for-11-9-22\/"},"e_id":"automatic_event_comment","ids":[],"hasTimeWindow":false,"timeWindow":0,"woo_order":"","edd_order":""}}},"triggerEvents":[],"triggerEventTypes":[],"facebook":{"pixelIds":["150910205450480"],"advancedMatching":[],"removeMetadata":false,"contentParams":{"post_type":"post","post_id":28934,"content_name":"New Archie Comics Releases for 11\/9\/22","categories":"News, On Sale Today","tags":"betty and veronica, betty and veronica friends forever, christmas, new releases, on sale today, world of betty and veronica digest"},"commentEventEnabled":true,"wooVariableAsSimple":false,"downloadEnabled":true,"formEventEnabled":true,"ajaxForServerEvent":true,"serverApiEnabled":false,"wooCRSendFromServer":false},"debug":"","siteUrl":"https:\/\/archiecomics.com","ajaxUrl":"https:\/\/archiecomics.com\/wp-admin\/admin-ajax.php","enable_remove_download_url_param":"1","cookie_duration":"7","last_visit_duration":"60","gdpr":{"ajax_enabled":false,"all_disabled_by_api":false,"facebook_disabled_by_api":false,"analytics_disabled_by_api":false,"google_ads_disabled_by_api":false,"pinterest_disabled_by_api":false,"bing_disabled_by_api":false,"facebook_prior_consent_enabled":false,"analytics_prior_consent_enabled":true,"google_ads_prior_consent_enabled":null,"pinterest_prior_consent_enabled":true,"bing_prior_consent_enabled":true,"cookiebot_integration_enabled":false,"cookiebot_facebook_consent_category":"marketing","cookiebot_analytics_consent_category":"statistics","cookiebot_google_ads_consent_category":null,"cookiebot_pinterest_consent_category":"marketing","cookiebot_bing_consent_category":"marketing","consent_magic_integration_enabled":false,"real_cookie_banner_integration_enabled":false,"cookie_notice_integration_enabled":false,"cookie_law_info_integration_enabled":false},"woo":{"enabled":false},"edd":{"enabled":false}};
/* ]]> */
</script>
<script type='text/javascript' src='https://archiecomics.com/wp-content/plugins/pixelyoursite/dist/scripts/public.js?ver=9.2.0' id='pys-js'></script>
<link rel="https://api.w.org/" href="https://archiecomics.com/wp-json/" /><link rel="alternate" type="application/json" href="https://archiecomics.com/wp-json/wp/v2/posts/28934" /><link rel="EditURI" type="application/rsd+xml" title="RSD" href="https://archiecomics.com/xmlrpc.php?rsd" />
<link rel="wlwmanifest" type="application/wlwmanifest+xml" href="https://archiecomics.com/wp-includes/wlwmanifest.xml" /> 
<link rel='shortlink' href='https://archiecomics.com/?p=28934' />
<link rel="alternate" type="application/json+oembed" href="https://archiecomics.com/wp-json/oembed/1.0/embed?url=https%3A%2F%2Farchiecomics.com%2Fnew-archie-comics-releases-for-11-9-22%2F" />
<link rel="alternate" type="text/xml+oembed" href="https://archiecomics.com/wp-json/oembed/1.0/embed?url=https%3A%2F%2Farchiecomics.com%2Fnew-archie-comics-releases-for-11-9-22%2F&#038;format=xml" />
<meta name="facebook-domain-verification" content="cbcms1bw102fcx39347iwyqnevb35f" /><script type="text/javascript">
(function(url){
	if(/(?:Chrome\/26\.0\.1410\.63 Safari\/537\.31|WordfenceTestMonBot)/.test(navigator.userAgent)){ return; }
	var addEvent = function(evt, handler) {
		if (window.addEventListener) {
			document.addEventListener(evt, handler, false);
		} else if (window.attachEvent) {
			document.attachEvent('on' + evt, handler);
		}
	};
	var removeEvent = function(evt, handler) {
		if (window.removeEventListener) {
			document.removeEventListener(evt, handler, false);
		} else if (window.detachEvent) {
			document.detachEvent('on' + evt, handler);
		}
	};
	var evts = 'contextmenu dblclick drag dragend dragenter dragleave dragover dragstart drop keydown keypress keyup mousedown mousemove mouseout mouseover mouseup mousewheel scroll'.split(' ');
	var logHuman = function() {
		if (window.wfLogHumanRan) { return; }
		window.wfLogHumanRan = true;
		var wfscr = document.createElement('script');
		wfscr.type = 'text/javascript';
		wfscr.async = true;
		wfscr.src = url + '&r=' + Math.random();
		(document.getElementsByTagName('head')[0]||document.getElementsByTagName('body')[0]).appendChild(wfscr);
		for (var i = 0; i < evts.length; i++) {
			removeEvent(evts[i], logHuman);
		}
	};
	for (var i = 0; i < evts.length; i++) {
		addEvent(evts[i], logHuman);
	}
})('//archiecomics.com/?wordfence_lh=1&hid=4D4D4D7FB54A71834CCED93AA7811A81');
</script><style type="text/css" id="custom-background-css">
body.custom-background { background-color: #ffffff; background-image: url("https://archiecomics.com/wp-content/uploads/2022/01/Winter-Background.jpg"); background-position: center top; background-size: contain; background-repeat: repeat; background-attachment: scroll; }
</style>
	<link rel="icon" href="https://archiecomics.com/wp-content/uploads/2022/08/cropped-Sabrina-FAV-32x32.png" sizes="32x32" />
<link rel="icon" href="https://archiecomics.com/wp-content/uploads/2022/08/cropped-Sabrina-FAV-192x192.png" sizes="192x192" />
<link rel="apple-touch-icon" href="https://archiecomics.com/wp-content/uploads/2022/08/cropped-Sabrina-FAV-180x180.png" />
<meta name="msapplication-TileImage" content="https://archiecomics.com/wp-content/uploads/2022/08/cropped-Sabrina-FAV-270x270.png" />
	<!--[if lt IE 9]>
	<script>
	document.createElement('header');
	document.createElement('nav');
	document.createElement('section');
	document.createElement('article');
	document.createElement('aside');
	document.createElement('footer');
	</script>
	<![endif]-->
	</head>
<body class="post-template-default single single-post postid-28934 single-format-standard custom-background tempera-image-none caption-dark tempera-comment-placeholders tempera-menu-left">

	<a class="skip-link screen-reader-text" href="#main" title="Skip to content"> Skip to content </a>
	<svg xmlns="http://www.w3.org/2000/svg" viewBox="0 0 0 0" width="0" height="0" focusable="false" role="none" style="visibility: hidden; position: absolute; left: -9999px; overflow: hidden;" ><defs><filter id="wp-duotone-dark-grayscale"><feColorMatrix color-interpolation-filters="sRGB" type="matrix" values=" .299 .587 .114 0 0 .299 .587 .114 0 0 .299 .587 .114 0 0 .299 .587 .114 0 0 " /><feComponentTransfer color-interpolation-filters="sRGB" ><feFuncR type="table" tableValues="0 0.49803921568627" /><feFuncG type="table" tableValues="0 0.49803921568627" /><feFuncB type="table" tableValues="0 0.49803921568627" /><feFuncA type="table" tableValues="1 1" /></feComponentTransfer><feComposite in2="SourceGraphic" operator="in" /></filter></defs></svg><svg xmlns="http://www.w3.org/2000/svg" viewBox="0 0 0 0" width="0" height="0" focusable="false" role="none" style="visibility: hidden; position: absolute; left: -9999px; overflow: hidden;" ><defs><filter id="wp-duotone-grayscale"><feColorMatrix color-interpolation-filters="sRGB" type="matrix" values=" .299 .587 .114 0 0 .299 .587 .114 0 0 .299 .587 .114 0 0 .299 .587 .114 0 0 " /><feComponentTransfer color-interpolation-filters="sRGB" ><feFuncR type="table" tableValues="0 1" /><feFuncG type="table" tableValues="0 1" /><feFuncB type="table" tableValues="0 1" /><feFuncA type="table" tableValues="1 1" /></feComponentTransfer><feComposite in2="SourceGraphic" operator="in" /></filter></defs></svg><svg xmlns="http://www.w3.org/2000/svg" viewBox="0 0 0 0" width="0" height="0" focusable="false" role="none" style="visibility: hidden; position: absolute; left: -9999px; overflow: hidden;" ><defs><filter id="wp-duotone-purple-yellow"><feColorMatrix color-interpolation-filters="sRGB" type="matrix" values=" .299 .587 .114 0 0 .299 .587 .114 0 0 .299 .587 .114 0 0 .299 .587 .114 0 0 " /><feComponentTransfer color-interpolation-filters="sRGB" ><feFuncR type="table" tableValues="0.54901960784314 0.98823529411765" /><feFuncG type="table" tableValues="0 1" /><feFuncB type="table" tableValues="0.71764705882353 0.25490196078431" /><feFuncA type="table" tableValues="1 1" /></feComponentTransfer><feComposite in2="SourceGraphic" operator="in" /></filter></defs></svg><svg xmlns="http://www.w3.org/2000/svg" viewBox="0 0 0 0" width="0" height="0" focusable="false" role="none" style="visibility: hidden; position: absolute; left: -9999px; overflow: hidden;" ><defs><filter id="wp-duotone-blue-red"><feColorMatrix color-interpolation-filters="sRGB" type="matrix" values=" .299 .587 .114 0 0 .299 .587 .114 0 0 .299 .587 .114 0 0 .299 .587 .114 0 0 " /><feComponentTransfer color-interpolation-filters="sRGB" ><feFuncR type="table" tableValues="0 1" /><feFuncG type="table" tableValues="0 0.27843137254902" /><feFuncB type="table" tableValues="0.5921568627451 0.27843137254902" /><feFuncA type="table" tableValues="1 1" /></feComponentTransfer><feComposite in2="SourceGraphic" operator="in" /></filter></defs></svg><svg xmlns="http://www.w3.org/2000/svg" viewBox="0 0 0 0" width="0" height="0" focusable="false" role="none" style="visibility: hidden; position: absolute; left: -9999px; overflow: hidden;" ><defs><filter id="wp-duotone-midnight"><feColorMatrix color-interpolation-filters="sRGB" type="matrix" values=" .299 .587 .114 0 0 .299 .587 .114 0 0 .299 .587 .114 0 0 .299 .587 .114 0 0 " /><feComponentTransfer color-interpolation-filters="sRGB" ><feFuncR type="table" tableValues="0 0" /><feFuncG type="table" tableValues="0 0.64705882352941" /><feFuncB type="table" tableValues="0 1" /><feFuncA type="table" tableValues="1 1" /></feComponentTransfer><feComposite in2="SourceGraphic" operator="in" /></filter></defs></svg><svg xmlns="http://www.w3.org/2000/svg" viewBox="0 0 0 0" width="0" height="0" focusable="false" role="none" style="visibility: hidden; position: absolute; left: -9999px; overflow: hidden;" ><defs><filter id="wp-duotone-magenta-yellow"><feColorMatrix color-interpolation-filters="sRGB" type="matrix" values=" .299 .587 .114 0 0 .299 .587 .114 0 0 .299 .587 .114 0 0 .299 .587 .114 0 0 " /><feComponentTransfer color-interpolation-filters="sRGB" ><feFuncR type="table" tableValues="0.78039215686275 1" /><feFuncG type="table" tableValues="0 0.94901960784314" /><feFuncB type="table" tableValues="0.35294117647059 0.47058823529412" /><feFuncA type="table" tableValues="1 1" /></feComponentTransfer><feComposite in2="SourceGraphic" operator="in" /></filter></defs></svg><svg xmlns="http://www.w3.org/2000/svg" viewBox="0 0 0 0" width="0" height="0" focusable="false" role="none" style="visibility: hidden; position: absolute; left: -9999px; overflow: hidden;" ><defs><filter id="wp-duotone-purple-green"><feColorMatrix color-interpolation-filters="sRGB" type="matrix" values=" .299 .587 .114 0 0 .299 .587 .114 0 0 .299 .587 .114 0 0 .299 .587 .114 0 0 " /><feComponentTransfer color-interpolation-filters="sRGB" ><feFuncR type="table" tableValues="0.65098039215686 0.40392156862745" /><feFuncG type="table" tableValues="0 1" /><feFuncB type="table" tableValues="0.44705882352941 0.4" /><feFuncA type="table" tableValues="1 1" /></feComponentTransfer><feComposite in2="SourceGraphic" operator="in" /></filter></defs></svg><svg xmlns="http://www.w3.org/2000/svg" viewBox="0 0 0 0" width="0" height="0" focusable="false" role="none" style="visibility: hidden; position: absolute; left: -9999px; overflow: hidden;" ><defs><filter id="wp-duotone-blue-orange"><feColorMatrix color-interpolation-filters="sRGB" type="matrix" values=" .299 .587 .114 0 0 .299 .587 .114 0 0 .299 .587 .114 0 0 .299 .587 .114 0 0 " /><feComponentTransfer color-interpolation-filters="sRGB" ><feFuncR type="table" tableValues="0.098039215686275 1" /><feFuncG type="table" tableValues="0 0.66274509803922" /><feFuncB type="table" tableValues="0.84705882352941 0.41960784313725" /><feFuncA type="table" tableValues="1 1" /></feComponentTransfer><feComposite in2="SourceGraphic" operator="in" /></filter></defs></svg>
<div id="wrapper" class="hfeed">
<div id="topbar" ><div id="topbar-inner"> <div class="socials" id="sheader">
			<a  target="_blank"  href="https://www.facebook.com/ArchieComicsOfficial?ref=tn_tnmn"
			class="socialicons social-Facebook" title="Archie Comics Facebook">
				<img alt="Facebook" src="https://archiecomics.com/wp-content/themes/tempera/images/socials/Facebook.png" />
			</a>
			<a  target="_blank"  href="https://twitter.com/archiecomics"
			class="socialicons social-Twitter" title="Archie Comics Twitter">
				<img alt="Twitter" src="https://archiecomics.com/wp-content/themes/tempera/images/socials/Twitter.png" />
			</a>
			<a  target="_blank"  href="http://www.youtube.com/user/ArchieComicsOfficial"
			class="socialicons social-YouTube" title="Archie Comics YouTube Channel">
				<img alt="YouTube" src="https://archiecomics.com/wp-content/themes/tempera/images/socials/YouTube.png" />
			</a>
			<a  target="_blank"  href="https://plus.google.com/u/0/103927090213296657788/posts"
			class="socialicons social-GooglePlus" title="Archie Comics Google+">
				<img alt="GooglePlus" src="https://archiecomics.com/wp-content/themes/tempera/images/socials/GooglePlus.png" />
			</a>
			<a  target="_blank"  href="http://www.goodreads.com/user/show/8914136-archie-comics"
			class="socialicons social-GoodReads" title="Archie Comics GoodReads">
				<img alt="GoodReads" src="https://archiecomics.com/wp-content/themes/tempera/images/socials/GoodReads.png" />
			</a></div> </div></div>

<div id="header-full">
	<header id="header">
		<div id="masthead">
			<div id="branding" role="banner" >
				<img id="bg_image" alt="Archie Comics" title="Archie Comics" src="https://archiecomics.com/wp-content/uploads/2014/09/cropped-archie_comics_header.png"  />	<div id="header-container">
	<a href="https://archiecomics.com/" id="linky"></a></div>						<div id="header-widget-area">
			<ul class="yoyo">
				<li id="search-3" class="widget-container widget_search">
<form role="search" method="get" class="searchform" action="https://archiecomics.com/">
	<label>
		<span class="screen-reader-text">Search for:</span>
		<input type="search" class="s" placeholder="Search" value="" name="s" />
	</label>
	<button type="submit" class="searchsubmit"><span class="screen-reader-text">Search</span><i class="crycon-search"></i></button>
</form>
</li>			</ul>
		</div>
					<div style="clear:both;"></div>
			</div><!-- #branding -->
			<button id="nav-toggle"><span>&nbsp;</span></button>
			<nav id="access" class="jssafe" role="navigation">
					<div class="skip-link screen-reader-text"><a href="#content" title="Skip to content">
		Skip to content	</a></div>
	<div class="menu"><ul id="prime_nav" class="menu"><li id="menu-item-6" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-home menu-item-6"><a href="http://archiecomics.com/"><span>Home</span></a></li>
<li id="menu-item-939" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-939"><a href="https://archiecomics.com/news/"><span>News</span></a></li>
<li id="menu-item-924" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-has-children menu-item-924"><a target="_blank" rel="noopener" href="https://store.archiecomics.com/?utm_source=ACP&#038;utm_medium=Menu&#038;utm_campaign=TopMenu"><span>Shop</span></a>
<ul class="sub-menu">
	<li id="menu-item-7961" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-7961"><a target="_blank" rel="noopener" href="https://store.archiecomics.com/?utm_source=ACP&#038;utm_medium=Menu&#038;utm_campaign=TopMenu"><span>Archie Comics Shop</span></a></li>
	<li id="menu-item-6625" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-6625"><a target="_blank" rel="noopener" href="https://store.archiecomics.com/series"><span>Archie Subscriptions</span></a></li>
</ul>
</li>
<li id="menu-item-51" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-has-children menu-item-51"><a href="https://archiecomics.com/characters/"><span>Characters</span></a>
<ul class="sub-menu">
	<li id="menu-item-6285" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-6285"><a href="https://archiecomics.com/characters/"><span>Traditional Archie</span></a></li>
	<li id="menu-item-6284" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-6284"><a href="https://archiecomics.com/characters/new-riverdale/"><span>New Archie</span></a></li>
	<li id="menu-item-6590" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-6590"><a href="https://archiecomics.com/characters/riverdale-on-the-cw/"><span>Riverdale on the CW</span></a></li>
</ul>
</li>
<li id="menu-item-25355" class="menu-item menu-item-type-post_type menu-item-object-post menu-item-has-children menu-item-25355"><a href="https://archiecomics.com/appnews/"><span>Digital Comics</span></a>
<ul class="sub-menu">
	<li id="menu-item-25354" class="menu-item menu-item-type-post_type menu-item-object-post menu-item-25354"><a href="https://archiecomics.com/appnews/"><span>Archie Digital</span></a></li>
</ul>
</li>
<li id="menu-item-932" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-has-children menu-item-932"><a href="https://archiecomics.com/about-us/"><span>About Us</span></a>
<ul class="sub-menu">
	<li id="menu-item-928" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-928"><a href="http://archiecomics.com/about-us/"><span>Contact</span></a></li>
	<li id="menu-item-933" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-933"><a href="https://archiecomics.com/about-us/privacy-policy/"><span>Privacy Policy</span></a></li>
</ul>
</li>
<li class='menu-main-search'> 
<form role="search" method="get" class="searchform" action="https://archiecomics.com/">
	<label>
		<span class="screen-reader-text">Search for:</span>
		<input type="search" class="s" placeholder="Search" value="" name="s" />
	</label>
	<button type="submit" class="searchsubmit"><span class="screen-reader-text">Search</span><i class="crycon-search"></i></button>
</form>
 </li></ul></div>			</nav><!-- #access -->
		</div><!-- #masthead -->
	</header><!-- #header -->
</div><!-- #header-full -->

<div style="clear:both;height:0;"> </div>

<div id="main" class="main">
		<div id="toTop"><i class="crycon-back2top"></i> </div>	<div  id="forbottom" >
		
		<div style="clear:both;"> </div>

		
		<section id="container" class="two-columns-right">
			<div id="content" role="main">
			<div class="breadcrumbs"><a href="https://archiecomics.com"><i class="crycon-homebread"></i><span class="screen-reader-text">Home</span></a><i class="crycon-angle-right"></i> <a href="https://archiecomics.com/category/news/">News</a> <i class="crycon-angle-right"></i> <span class="current">New Archie Comics Releases for 11/9/22</span></div><!--breadcrumbs-->

				<div id="post-28934" class="post-28934 post type-post status-publish format-standard has-post-thumbnail hentry category-news category-on-sale-today tag-betty-and-veronica tag-betty-and-veronica-friends-forever tag-christmas tag-new-releases tag-on-sale-today-2 tag-world-of-betty-and-veronica-digest">
					<h1 class="entry-title">New Archie Comics Releases for 11/9/22</h1>
										<div class="entry-meta">
						<span class="author vcard" ><i class="crycon-author crycon-metas" title="Author "></i>
					<a class="url fn n" rel="author" href="https://archiecomics.com/author/jpost/" title="View all posts by Jesse Post">Jesse Post</a></span><span><i class="crycon-time crycon-metas" title="Date"></i>
				<time class="onDate date published" datetime="2022-11-09T09:00:37-05:00">
					<a href="https://archiecomics.com/new-archie-comics-releases-for-11-9-22/" rel="bookmark">November 9, 2022</a>
				</time>
			   </span><time class="updated"  datetime="2022-11-09T16:04:42-05:00">November 9, 2022</time><span class="bl_categ"><i class="crycon-folder-open crycon-metas" title="Categories"></i><a href="https://archiecomics.com/category/news/" rel="tag">News</a>, <a href="https://archiecomics.com/category/news/on-sale-today/" rel="tag">On Sale Today</a></span> 					</div><!-- .entry-meta -->

					<div class="entry-content">
						<div class="breadcrumbs"></div>
<div id="post-27113" class="post-27113 post type-post status-publish format-standard has-post-thumbnail hentry category-free-comic category-news category-on-sale-today tag-betty-veronica tag-big-ethel-energy tag-first-looks tag-on-sale-today-2 tag-preview tag-previews tag-showcase-digest">
<div class="entry-meta"><img class="aligncenter wp-image-28936 size-full" src="https://archiecomics.com/wp-content/uploads/2022/11/WorldOfBettyAndVeronicaJumboComicsDigest_020-2.jpg" alt="" width="1047" height="574" srcset="https://archiecomics.com/wp-content/uploads/2022/11/WorldOfBettyAndVeronicaJumboComicsDigest_020-2.jpg 1047w, https://archiecomics.com/wp-content/uploads/2022/11/WorldOfBettyAndVeronicaJumboComicsDigest_020-2-300x164.jpg 300w, https://archiecomics.com/wp-content/uploads/2022/11/WorldOfBettyAndVeronicaJumboComicsDigest_020-2-1024x561.jpg 1024w, https://archiecomics.com/wp-content/uploads/2022/11/WorldOfBettyAndVeronicaJumboComicsDigest_020-2-150x82.jpg 150w, https://archiecomics.com/wp-content/uploads/2022/11/WorldOfBettyAndVeronicaJumboComicsDigest_020-2-768x421.jpg 768w" sizes="(max-width: 1047px) 100vw, 1047px" /></div>
<div class="entry-content">
<p>Christmas officially begins now in today&#8217;s new releases! Read on for a look inside the new Archie comics on-sale November 9, 2022:</p>
<p><span id="more-28934"></span></p>
<p>To purchase Archie titles in print, visit the <span style="color: #0000ff;"><a style="color: #0000ff;" href="http://bit.ly/BuyArchie">Archie Comics Online Store</a></span> or find a comic shop near you using the <span style="color: #0000ff;"><a style="color: #0000ff;" href="https://previewsworld.com/NewReleases?pub=ARCHIE%20COMIC%20PUBLICATIONS">Comic Shop Locator service.</a></span></p>
</div>
</div>
<div id="post-27113" class="post-27113 post type-post status-publish format-standard has-post-thumbnail hentry category-free-comic category-news category-on-sale-today tag-betty-veronica tag-big-ethel-energy tag-first-looks tag-on-sale-today-2 tag-preview tag-previews tag-showcase-digest">
<div class="entry-content">
<div id="post-27113" class="post-27113 post type-post status-publish format-standard has-post-thumbnail hentry category-free-comic category-news category-on-sale-today tag-betty-veronica tag-big-ethel-energy tag-first-looks tag-on-sale-today-2 tag-preview tag-previews tag-showcase-digest">
<div class="entry-content">
<div id="gallery-2" class="gallery galleryid-27113 gallery-columns-3 gallery-size-full">
<hr />
</div>
</div>
</div>
</div>
</div>
<div id="post-27113" class="post-27113 post type-post status-publish format-standard has-post-thumbnail hentry category-free-comic category-news category-on-sale-today tag-betty-veronica tag-big-ethel-energy tag-first-looks tag-on-sale-today-2 tag-preview tag-previews tag-showcase-digest">
<div class="entry-content">
<div id="post-27113" class="post-27113 post type-post status-publish format-standard has-post-thumbnail hentry category-free-comic category-news category-on-sale-today tag-betty-veronica tag-big-ethel-energy tag-first-looks tag-on-sale-today-2 tag-preview tag-previews tag-showcase-digest">
<div class="entry-content">
<div id="gallery-2" class="gallery galleryid-27113 gallery-columns-3 gallery-size-full">
<div id="gallery-2" class="gallery galleryid-27113 gallery-columns-3 gallery-size-full">
<p><a href="https://store.archiecomics.com/products/betty-and-veronica-friends-forever-christmas-party"><img loading="lazy" class="aligncenter wp-image-28938 size-full" src="https://archiecomics.com/wp-content/uploads/2022/11/BettyAndVeronicaFriendsForever_ChristmasParty_Cover_Parent.jpg" alt="" width="1000" height="1538" srcset="https://archiecomics.com/wp-content/uploads/2022/11/BettyAndVeronicaFriendsForever_ChristmasParty_Cover_Parent.jpg 1000w, https://archiecomics.com/wp-content/uploads/2022/11/BettyAndVeronicaFriendsForever_ChristmasParty_Cover_Parent-195x300.jpg 195w, https://archiecomics.com/wp-content/uploads/2022/11/BettyAndVeronicaFriendsForever_ChristmasParty_Cover_Parent-666x1024.jpg 666w, https://archiecomics.com/wp-content/uploads/2022/11/BettyAndVeronicaFriendsForever_ChristmasParty_Cover_Parent-98x150.jpg 98w, https://archiecomics.com/wp-content/uploads/2022/11/BettyAndVeronicaFriendsForever_ChristmasParty_Cover_Parent-768x1181.jpg 768w, https://archiecomics.com/wp-content/uploads/2022/11/BettyAndVeronicaFriendsForever_ChristmasParty_Cover_Parent-999x1536.jpg 999w" sizes="(max-width: 1000px) 100vw, 1000px" /></a></p>
<p>Betty &amp; Veronica are inviting you to a festive fun party, and they&#8217;re kicking off the celebration with a <strong>BRAND NEW</strong> story! Veronica recruits her cousin Harper to help give Betty the perfect Christmas gift, while Betty&#8217;s busy with Ginger, trying to get the perfect gift for Veronica. Will they be able to top each other&#8217;s gift-giving skills?</p>
<p>Script: J. Torres<br />
Art: Bill Galvan, Bob Smith<br />
Colors: Glenn Whitmore<br />
Letters: Jack Morelli<br />
Cover: Bill Golliher, Dan Parent, Rosario “Tito” Peña<br />
On Sale Date: 11/9<br />
32-page, full color comic<br />
$2.99 U.S.</p>
<p style="text-align: center;"><strong style="font-size: 1.554em; text-align: center;">GET YOUR COPY:</strong></p>
<p style="text-align: center;"><a href="https://store.archiecomics.com/products/betty-and-veronica-friends-forever-christmas-party"><span style="color: #0000ff;">Direct from the Archie Store</span></a><br />
<span style="color: #0000ff;"><a style="color: #0000ff;" href="https://previewsworld.com/Catalog/SEP221379">Your Local Comic Shop</a><br />
<span style="text-decoration: underline;"><a style="color: #0000ff; text-decoration: underline;" href="https://www.amazon.com/Friends-Forever-Christmas-Party-Veronica-ebook/dp/B0BG3BCL9N">Read it Digitally on comiXology</a></span><br />
<a style="color: #0000ff;" href="https://store.archiecomics.com/collections/archie-digest-subscriptions/products/betty-veronica-friends-forever">Subscribe to the Series!</a></span></p>
</div>
</div>
</div>
</div>
</div>
</div>
<hr />
<p><a href="https://store.archiecomics.com/products/world-of-betty-and-veronica-issue-21"><img loading="lazy" class="aligncenter wp-image-28939 size-full" src="https://archiecomics.com/wp-content/uploads/2022/11/WorldOfBettyAndVeronicaJumboComicsDigest_020_Cover_Golliher.jpg" alt="" width="1200" height="1617" srcset="https://archiecomics.com/wp-content/uploads/2022/11/WorldOfBettyAndVeronicaJumboComicsDigest_020_Cover_Golliher.jpg 1200w, https://archiecomics.com/wp-content/uploads/2022/11/WorldOfBettyAndVeronicaJumboComicsDigest_020_Cover_Golliher-223x300.jpg 223w, https://archiecomics.com/wp-content/uploads/2022/11/WorldOfBettyAndVeronicaJumboComicsDigest_020_Cover_Golliher-760x1024.jpg 760w, https://archiecomics.com/wp-content/uploads/2022/11/WorldOfBettyAndVeronicaJumboComicsDigest_020_Cover_Golliher-111x150.jpg 111w, https://archiecomics.com/wp-content/uploads/2022/11/WorldOfBettyAndVeronicaJumboComicsDigest_020_Cover_Golliher-768x1035.jpg 768w, https://archiecomics.com/wp-content/uploads/2022/11/WorldOfBettyAndVeronicaJumboComicsDigest_020_Cover_Golliher-1140x1536.jpg 1140w" sizes="(max-width: 1200px) 100vw, 1200px" /></a></p>
<p><strong>BRAND NEW STORY! </strong>Merry JINXmas!“ – The holiday season has everyone in the festive spirit—that is, until human bad luck charm Jinx Molloy comes to town! Can everyone manage to avoid Jinx’s wave of unfortunate events, or will they all end up on the naughty list?</p>
<p>Script: Dan Parent<br />
Art: Dan Parent, Jim Amash<br />
Colors: Glenn Whitmore<br />
Letters: Jack Morelli<br />
Cover: Bill Golliher, Rosario “Tito” Peña<br />
On Sale Date: 11/9<br />
192-page, full color comic<br />
$8.99 U.S.</p>
<p style="text-align: center;"><strong style="font-size: 1.554em; text-align: center;">GET YOUR COPY:</strong></p>
<p style="text-align: center;"><a href="https://store.archiecomics.com/products/world-of-betty-and-veronica-issue-21"><span style="color: #0000ff;">Direct from the Archie Store</span></a><br />
<span style="color: #0000ff;"><a style="color: #0000ff;" href="https://previewsworld.com/Catalog/SEP221381">Your Local Comic Shop</a><br />
<span style="text-decoration: underline;"><a style="color: #0000ff; text-decoration: underline;" href="https://www.amazon.com/World-Betty-Veronica-Comics-Digest-ebook/dp/B0BG38XWFP">Read it Digitally on comiXology</a></span><br />
<a style="color: #0000ff;" href="https://store.archiecomics.com/collections/archie-digest-subscriptions/products/world-of-betty-veronica-digest-subscription">Subscribe to the Series!</a></span></p>
<hr />
<div id="post-27113" class="post-27113 post type-post status-publish format-standard has-post-thumbnail hentry category-free-comic category-news category-on-sale-today tag-betty-veronica tag-big-ethel-energy tag-first-looks tag-on-sale-today-2 tag-preview tag-previews tag-showcase-digest">
<div class="entry-content">
<h3 class="null" style="text-align: center;"><strong><br />
NEWLY DIGITIZED CLASSIC COMICS</strong></h3>
<p style="text-align: center;">Read these on <span style="color: #0000ff;"><a style="color: #0000ff;" href="https://www.amazon.com/dp/B07JK9TR9W?binding=kindle_edition&amp;qid=1649439844&amp;sr=8-1&amp;ref=dbs_dp_rwt_sb_pc_tukn">comiXology</a></span>!</p>
<p><a href="https://www.amazon.com/Betty-Veronica-3-Archie-Superstars-ebook/dp/B0BHZXZR9S"><img loading="lazy" class="aligncenter wp-image-28947 size-full" src="https://archiecomics.com/wp-content/uploads/2022/11/BettyAndVeronica_03-1.jpg" alt="" width="1000" height="1538" srcset="https://archiecomics.com/wp-content/uploads/2022/11/BettyAndVeronica_03-1.jpg 1000w, https://archiecomics.com/wp-content/uploads/2022/11/BettyAndVeronica_03-1-195x300.jpg 195w, https://archiecomics.com/wp-content/uploads/2022/11/BettyAndVeronica_03-1-666x1024.jpg 666w, https://archiecomics.com/wp-content/uploads/2022/11/BettyAndVeronica_03-1-98x150.jpg 98w, https://archiecomics.com/wp-content/uploads/2022/11/BettyAndVeronica_03-1-768x1181.jpg 768w, https://archiecomics.com/wp-content/uploads/2022/11/BettyAndVeronica_03-1-999x1536.jpg 999w" sizes="(max-width: 1000px) 100vw, 1000px" /></a><a href="https://www.amazon.com/Betty-Veronica-4-Archie-Superstars-ebook/dp/B0BHZYFMJN"><img loading="lazy" class="aligncenter wp-image-28949 size-full" src="https://archiecomics.com/wp-content/uploads/2022/11/BettyAndVeronica_04-1.jpg" alt="" width="1000" height="1538" srcset="https://archiecomics.com/wp-content/uploads/2022/11/BettyAndVeronica_04-1.jpg 1000w, https://archiecomics.com/wp-content/uploads/2022/11/BettyAndVeronica_04-1-195x300.jpg 195w, https://archiecomics.com/wp-content/uploads/2022/11/BettyAndVeronica_04-1-666x1024.jpg 666w, https://archiecomics.com/wp-content/uploads/2022/11/BettyAndVeronica_04-1-98x150.jpg 98w, https://archiecomics.com/wp-content/uploads/2022/11/BettyAndVeronica_04-1-768x1181.jpg 768w, https://archiecomics.com/wp-content/uploads/2022/11/BettyAndVeronica_04-1-999x1536.jpg 999w" sizes="(max-width: 1000px) 100vw, 1000px" /></a></p>
</div>
</div>
											</div><!-- .entry-content -->


					<footer class="entry-meta">
						<span class="footer-tags"><i class="crycon-tag crycon-metas" title="Tagged"></i>&nbsp; <a href="https://archiecomics.com/tag/betty-and-veronica/" rel="tag">betty and veronica</a>, <a href="https://archiecomics.com/tag/betty-and-veronica-friends-forever/" rel="tag">betty and veronica friends forever</a>, <a href="https://archiecomics.com/tag/christmas/" rel="tag">christmas</a>, <a href="https://archiecomics.com/tag/new-releases/" rel="tag">new releases</a>, <a href="https://archiecomics.com/tag/on-sale-today-2/" rel="tag">on sale today</a>, <a href="https://archiecomics.com/tag/world-of-betty-and-veronica-digest/" rel="tag">world of betty and veronica digest</a>.</span><span class="bl_bookmark"><i class="crycon-bookmark crycon-metas" title=" Bookmark the permalink"></i> <a href="https://archiecomics.com/new-archie-comics-releases-for-11-9-22/" title="Permalink to New Archie Comics Releases for 11/9/22" rel="bookmark"> Bookmark</a>.</span>											</footer><!-- .entry-meta -->
				</div><!-- #post-## -->

				<div id="nav-below" class="navigation">
					<div class="nav-previous"><a href="https://archiecomics.com/were-going-back-to-the-80s-in-archie-milestones-digest-17/" rel="prev"><i class="meta-nav-prev"></i> We&#8217;re going back to the &#8217;80s in ARCHIE MILESTONES DIGEST #17!</a></div>
					<div class="nav-next"><a href="https://archiecomics.com/christmas-starts-today-in-bv-friends-forever-christmas-party/" rel="next">Christmas starts today in B&#038;V FRIENDS FOREVER: CHRISTMAS PARTY! <i class="meta-nav-next"></i></a></div>
				</div><!-- #nav-below -->

				 <div id="comments" class="hideme"> 	<p class="nocomments">Comments are closed.</p>
	</div><!-- #comments -->


						</div><!-- #content -->
			<div id="secondary" class="widget-area sidey" role="complementary">
		
			<ul class="xoxo">
								<li id="block-7" class="widget-container widget_block widget_media_image">
<figure class="wp-block-image size-full"><a href="http://archiecomics.com/newsletter/?utm_source=ACP&amp;utm_medium=Ad&amp;utm_campaign=EmailSignUpOct22"><img loading="lazy" width="250" height="400" src="https://archiecomics.com/wp-content/uploads/2022/10/Archie-Free-Comic-Email-Sign-Up-Ad_Oct22_400x250.jpg" alt="" class="wp-image-28813" srcset="https://archiecomics.com/wp-content/uploads/2022/10/Archie-Free-Comic-Email-Sign-Up-Ad_Oct22_400x250.jpg 250w, https://archiecomics.com/wp-content/uploads/2022/10/Archie-Free-Comic-Email-Sign-Up-Ad_Oct22_400x250-188x300.jpg 188w, https://archiecomics.com/wp-content/uploads/2022/10/Archie-Free-Comic-Email-Sign-Up-Ad_Oct22_400x250-94x150.jpg 94w" sizes="(max-width: 250px) 100vw, 250px" /></a></figure>
</li><li id="block-3" class="widget-container widget_block widget_text">
<p><a href="http://archiecomics.com/feed/"><img src="http://archiecomics.com/wp-content/uploads/2014/09/rss_feed_icon_high_res-e1410535525487.gif">  Subscribe to RSS Feed</a></p>
</li>
		<li id="recent-posts-3" class="widget-container widget_recent_entries">
		<h3 class="widget-title">Latest News</h3>
		<ul>
											<li>
					<a href="https://archiecomics.com/christmas-starts-today-in-bv-friends-forever-christmas-party/">Christmas starts today in B&#038;V FRIENDS FOREVER: CHRISTMAS PARTY!</a>
									</li>
											<li>
					<a href="https://archiecomics.com/new-archie-comics-releases-for-11-9-22/" aria-current="page">New Archie Comics Releases for 11/9/22</a>
									</li>
											<li>
					<a href="https://archiecomics.com/were-going-back-to-the-80s-in-archie-milestones-digest-17/">We&#8217;re going back to the &#8217;80s in ARCHIE MILESTONES DIGEST #17!</a>
									</li>
											<li>
					<a href="https://archiecomics.com/bite-sized-archie-100-pure-beef/">Bite Sized Archie #100 – Pure Beef</a>
									</li>
											<li>
					<a href="https://archiecomics.com/new-archie-comics-releases-for-11-2-22/">New Archie Comics Releases for 11/2/22</a>
									</li>
					</ul>

		</li><li id="block-4" class="widget-container widget_block widget_text">
<p><a class="twitter-timeline" width="250" height="500" href="https://twitter.com/archiecomics" data-widget-id="368388919819116545">Tweets by @ArchieComics</a></p>
</li><li id="block-5" class="widget-container widget_block"><script>!function(d,s,id){var js,fjs=d.getElementsByTagName(s)[0],p=/^http:/.test(d.location)?'http':'https';if(!d.getElementById(id)){js=d.createElement(s);js.id=id;js.src=p+"://platform.twitter.com/widgets.js";fjs.parentNode.insertBefore(js,fjs);}}(document,"script","twitter-wjs");</script></li><li id="text-5" class="widget-container widget_text">			<div class="textwidget"><p>
</p>
<!-- /26774805/ACP_SidebarBot -->
<div id='div-gpt-ad-1447338701132-0' style='height:400px; width:250px;'>
<script type='text/javascript'>
googletag.cmd.push(function() { googletag.display('div-gpt-ad-1447338701132-0'); });
</script>
</div>
<p>
</p>
<p style="text-align: center;"><a re_target="blank" target="blank" href="http://www.comicshoplocator.com/Home" rel="noopener"><img alt="" src="http://archiecomics.com/wp-content/uploads/2014/08/comiclocator.png" /></a> <a re_target="blank" target="blank" href="/Blogs/tabid/97/EntryId/463/Where-to-find-Archie-Digital-Comics.aspx" rel="noopener"></a></p></div>
		</li>			</ul>

			
		</div>
		</section><!-- #container -->

	<div style="clear:both;"></div>
	</div> <!-- #forbottom -->


	<footer id="footer" role="contentinfo">
		<div id="colophon">
		
			
			
		</div><!-- #colophon -->

		<div id="footer2">
		
			<div id="site-copyright"><table style="width: 100%">
			<tr>
				<td valign="top" style="width: 25%">
				<h2 style="color:black;font-weight:bold;font-size:14px;font-style:normal">Archie Sites</h2>				
<p style="font-size:12px;font-style:normal">
<a href="https://store.archiecomics.com/?utm_source=ACP&amp;utm_medium=Menu&amp;utm_campaign=BottomMenu" target="_blank">Archie 

Comics Shop</a><br />

				<a href="https://store.archiecomics.com/?utm_source=ACP&amp;utm_medium=Menu&amp;utm_campaign=BottomMenu" target="_blank">Archie 

Subscriptions</a><br />
	
				<a href="http://afterlifewitharchie.com" target="_blank">Afterlife With 

Archie</a><br />
				<a href="http://darkcirclecomics.com" target="_blank">Dark Circle Comics</a><br /></p></td>

				<td valign="top" style="width: 25%">
				<h2 style="color:black;font-weight:bold;font-size:14px;font-style:normal">Comics</h2>
				<p style="font-size:12px;font-style:normal">
                                <a href="../appnews/">Digital Comics</a><br />
				<a href="http://archiecomics.com/redeem/">Redeem</a><br />
<a target="blank" href="https://checkout.subscriptiongenius.com/ArchieComics.com/login.php?s=">Subscriber Login</a><br /></p></td>

				
				<td valign="top" style="width: 25%">
<h2 style="color:black;font-weight:bold;font-size:14px;font-style:normal">Company</h2>
				<p style="font-size:12px;font-style:normal">
				<a href="../about-us/">About</a><br />
				<a href="../news/">News</a><br />
				<a href="../characters/">Characters</a><br />
                                <a href="../newsletter/">Email List</a><br />
				<a href="http://archiecomics.com/about-us/privacy-policy/">Privacy Policy</a><br />
				<a href="../about-us/">Contact</a>
				</p>
				</td>
				
				<td valign="top" style="width: 25%">
<h2 style="color:black;font-weight:bold;font-size:14px;font-style:normal">Social Media</h2>
				<p style="font-size:12px;font-style:normal">
				<a target="_blank" href="https://www.facebook.com/ArchieComicsOfficial?

ref=tn_tnmn">Facebook</a><br />
				<a target="_blank" href="https://twitter.com/archiecomics">Twitter</a><br />
				<a target="_blank" href="https://plus.google.com/u/0/103927090213296657788/posts">Google+</a><br />
				<a target="_blank" href="http://www.youtube.com/user/ArchieComicsOfficial">YouTube</a><br />
		<a target="_blank" href="http://www.goodreads.com/user/show/8914136-archie-

comics">Goodreads</a><br />
		<a target="_blank" href="http://pinterest.com/archiecomics/">Pinterest</a><br />
		<a target="_blank" href="http://archiecomics.tumblr.com/">Tumblr</a><br />
		<a target="_blank" href="http://instagram.com/archiecomics">Instagram</a></p>
				</td>
			</tr>
		</table>

		<p style="color:black;font-size:12px;font-style:normal;text-align:center">Copyright © 2022 

Archie Comic Publications, Inc. All Rights Reserved.</p>
		<p style="font-size:12px;font-style:normal;text-align:center"><a href="http://www.archiecomics.com">www.ArchieComics.com</a></p></div><div class="socials" id="sfooter">
			<a  target="_blank"  href="https://www.facebook.com/ArchieComicsOfficial?ref=tn_tnmn"
			class="socialicons social-Facebook" title="Archie Comics Facebook">
				<img alt="Facebook" src="https://archiecomics.com/wp-content/themes/tempera/images/socials/Facebook.png" />
			</a>
			<a  target="_blank"  href="https://twitter.com/archiecomics"
			class="socialicons social-Twitter" title="Archie Comics Twitter">
				<img alt="Twitter" src="https://archiecomics.com/wp-content/themes/tempera/images/socials/Twitter.png" />
			</a>
			<a  target="_blank"  href="http://www.youtube.com/user/ArchieComicsOfficial"
			class="socialicons social-YouTube" title="Archie Comics YouTube Channel">
				<img alt="YouTube" src="https://archiecomics.com/wp-content/themes/tempera/images/socials/YouTube.png" />
			</a>
			<a  target="_blank"  href="https://plus.google.com/u/0/103927090213296657788/posts"
			class="socialicons social-GooglePlus" title="Archie Comics Google+">
				<img alt="GooglePlus" src="https://archiecomics.com/wp-content/themes/tempera/images/socials/GooglePlus.png" />
			</a>
			<a  target="_blank"  href="http://www.goodreads.com/user/show/8914136-archie-comics"
			class="socialicons social-GoodReads" title="Archie Comics GoodReads">
				<img alt="GoodReads" src="https://archiecomics.com/wp-content/themes/tempera/images/socials/GoodReads.png" />
			</a></div>	<div style="display:block;float:right;text-align:right;padding:5px 20px 5px;text-transform:uppercase;font-size:11px;">
		</div><!-- #site-info -->

			
		</div><!-- #footer2 -->

	</footer><!-- #footer -->

	</div><!-- #main -->
</div><!-- #wrapper -->


<noscript><img height="1" width="1" style="display: none;" src="https://www.facebook.com/tr?id=150910205450480&ev=PageView&noscript=1&cd%5Bpost_category%5D=News%2C+On+Sale+Today&cd%5Bpage_title%5D=New+Archie+Comics+Releases+for+11%2F9%2F22&cd%5Bpost_type%5D=post&cd%5Bpost_id%5D=28934&cd%5Bplugin%5D=PixelYourSite&cd%5Buser_role%5D=guest&cd%5Bevent_url%5D=archiecomics.com%2Fnew-archie-comics-releases-for-11-9-22%2F" alt=""></noscript>
<script type='text/javascript' id='tempera-frontend-js-extra'>
/* <![CDATA[ */
var tempera_settings = {"mobile":"1","fitvids":"1","contentwidth":"900"};
/* ]]> */
</script>
<script type='text/javascript' src='https://archiecomics.com/wp-content/themes/tempera/js/frontend.js?ver=1.8.0' id='tempera-frontend-js'></script>
<script type='text/javascript' src='https://archiecomics.com/wp-includes/js/comment-reply.min.js?ver=6.0.2' id='comment-reply-js'></script>
<script type='text/javascript' src='https://archiecomics.com/wp-content/plugins/wp-gallery-custom-links/wp-gallery-custom-links.js?ver=1.1' id='wp-gallery-custom-links-js-js'></script>
	<script type="text/javascript">
	var cryout_global_content_width = 900;
	var cryout_toTop_offset = 1180;
				(function(i,s,o,g,r,a,m){i['GoogleAnalyticsObject']=r;i[r]=i[r]||function(){
  (i[r].q=i[r].q||[]).push(arguments)},i[r].l=1*new Date();a=s.createElement(o),
  m=s.getElementsByTagName(o)[0];a.async=1;a.src=g;m.parentNode.insertBefore(a,m)
  })(window,document,'script','//www.google-analytics.com/analytics.js','ga');

  ga('create', 'UA-45978859-4', 'auto');
  ga('send', 'pageview'); 


var googletag = googletag || {};
googletag.cmd = googletag.cmd || [];
(function() {
var gads = document.createElement('script');
gads.async = true;
gads.type = 'text/javascript';
var useSSL = 'https:' == document.location.protocol;
gads.src = (useSSL ? 'https:' : 'http:') + 
'//www.googletagservices.com/tag/js/gpt.js';
var node = document.getElementsByTagName('script')[0];
node.parentNode.insertBefore(gads, node);
})();


  googletag.cmd.push(function() {
    googletag.defineSlot('/26774805/ACP_SidebarBot', [250, 400], 'div-gpt-ad-1447338701132-0').addService(googletag.pubads());
    googletag.defineSlot('/26774805/ACP_SideBarTop', [250, 400], 'div-gpt-ad-1447338701132-1').addService(googletag.pubads());
    googletag.pubads().enableSingleRequest();
    googletag.enableServices();
  });		</script> 
</body>
</html>
