<!DOCTYPE html>
<html lang="en-US">
<head>
<meta name="viewport" content="width=device-width, user-scalable=no, initial-scale=1.0, minimum-scale=1.0, maximum-scale=1.0">
<meta http-equiv="Content-Type" content="text/html; charset=UTF-8" />
<link rel="profile" href="http://gmpg.org/xfn/11" />
<link rel="pingback" href="https://archiecomics.com/xmlrpc.php" />
<link rel="shortcut icon" href="http://archiecomics.com/wp-content/uploads/2015/10/Favicon.png" /><link rel="apple-touch-icon" href="http://archiecomics.com/wp-content/uploads/2015/10/Favicon.png" /><meta name='robots' content='index, follow, max-image-preview:large, max-snippet:-1, max-video-preview:-1' />

	<!-- This site is optimized with the Yoast SEO plugin v18.3 - https://yoast.com/wordpress/plugins/seo/ -->
	<title>Meet the New Kids! - Archie Comics</title>
	<link rel="canonical" href="https://archiecomics.com/meet-the-new-kids/" />
	<meta property="og:locale" content="en_US" />
	<meta property="og:type" content="article" />
	<meta property="og:title" content="Meet the New Kids! - Archie Comics" />
	<meta property="og:description" content="&nbsp; In this week&#8217;s ARCHIE SHOWCASE DIGEST #8: NEW KIDS OFF THE WALL we go waaaay back to revisit the explosive arrival of the Pine Point High new kids in Riverdale! The fun started in ARCHIE &amp; FRIENDS #148 by Alex Simmons and Dan Parent in 2010, and Riverdale was… Continue reading" />
	<meta property="og:url" content="https://archiecomics.com/meet-the-new-kids/" />
	<meta property="og:site_name" content="Archie Comics" />
	<meta property="article:publisher" content="https://www.facebook.com/ArchieComicsOfficial" />
	<meta property="article:published_time" content="2022-05-13T21:25:05+00:00" />
	<meta property="article:modified_time" content="2022-05-13T21:26:17+00:00" />
	<meta property="og:image" content="https://archiecomics.com/wp-content/uploads/2022/05/Archie_NewKidFactFiles_Intro.jpg" />
	<meta property="og:image:width" content="1200" />
	<meta property="og:image:height" content="1616" />
	<meta property="og:image:type" content="image/jpeg" />
	<meta name="twitter:card" content="summary_large_image" />
	<meta name="twitter:creator" content="@archiecomics" />
	<meta name="twitter:site" content="@archiecomics" />
	<meta name="twitter:label1" content="Written by" />
	<meta name="twitter:data1" content="Jesse Post" />
	<meta name="twitter:label2" content="Est. reading time" />
	<meta name="twitter:data2" content="1 minute" />
	<script type="application/ld+json" class="yoast-schema-graph">{"@context":"https://schema.org","@graph":[{"@type":"Organization","@id":"https://archiecomics.com/#organization","name":"Archie Comics Publications, Inc.","url":"https://archiecomics.com/","sameAs":["https://www.facebook.com/ArchieComicsOfficial","https://www.instagram.com/archiecomics/","https://www.youtube.com/user/ArchieComicsOfficial","https://www.pinterest.com/archiecomics/","https://twitter.com/archiecomics"],"logo":{"@type":"ImageObject","@id":"https://archiecomics.com/#logo","inLanguage":"en-US","url":"https://archiecomics.com/wp-content/uploads/2014/08/Archie_Logo-1.jpg","contentUrl":"https://archiecomics.com/wp-content/uploads/2014/08/Archie_Logo-1.jpg","width":750,"height":316,"caption":"Archie Comics Publications, Inc."},"image":{"@id":"https://archiecomics.com/#logo"}},{"@type":"WebSite","@id":"https://archiecomics.com/#website","url":"https://archiecomics.com/","name":"Archie Comics","description":"","publisher":{"@id":"https://archiecomics.com/#organization"},"potentialAction":[{"@type":"SearchAction","target":{"@type":"EntryPoint","urlTemplate":"https://archiecomics.com/?s={search_term_string}"},"query-input":"required name=search_term_string"}],"inLanguage":"en-US"},{"@type":"ImageObject","@id":"https://archiecomics.com/meet-the-new-kids/#primaryimage","inLanguage":"en-US","url":"https://archiecomics.com/wp-content/uploads/2022/05/Archie_NewKidFactFiles_Intro.jpg","contentUrl":"https://archiecomics.com/wp-content/uploads/2022/05/Archie_NewKidFactFiles_Intro.jpg","width":1200,"height":1616},{"@type":"WebPage","@id":"https://archiecomics.com/meet-the-new-kids/#webpage","url":"https://archiecomics.com/meet-the-new-kids/","name":"Meet the New Kids! - Archie Comics","isPartOf":{"@id":"https://archiecomics.com/#website"},"primaryImageOfPage":{"@id":"https://archiecomics.com/meet-the-new-kids/#primaryimage"},"datePublished":"2022-05-13T21:25:05+00:00","dateModified":"2022-05-13T21:26:17+00:00","breadcrumb":{"@id":"https://archiecomics.com/meet-the-new-kids/#breadcrumb"},"inLanguage":"en-US","potentialAction":[{"@type":"ReadAction","target":["https://archiecomics.com/meet-the-new-kids/"]}]},{"@type":"BreadcrumbList","@id":"https://archiecomics.com/meet-the-new-kids/#breadcrumb","itemListElement":[{"@type":"ListItem","position":1,"name":"Home","item":"https://archiecomics.com/"},{"@type":"ListItem","position":2,"name":"Meet the New Kids!"}]},{"@type":"Article","@id":"https://archiecomics.com/meet-the-new-kids/#article","isPartOf":{"@id":"https://archiecomics.com/meet-the-new-kids/#webpage"},"author":{"@id":"https://archiecomics.com/#/schema/person/0c9d5a47ba5d680d6d911712d7ee2042"},"headline":"Meet the New Kids!","datePublished":"2022-05-13T21:25:05+00:00","dateModified":"2022-05-13T21:26:17+00:00","mainEntityOfPage":{"@id":"https://archiecomics.com/meet-the-new-kids/#webpage"},"wordCount":118,"publisher":{"@id":"https://archiecomics.com/#organization"},"image":{"@id":"https://archiecomics.com/meet-the-new-kids/#primaryimage"},"thumbnailUrl":"https://archiecomics.com/wp-content/uploads/2022/05/Archie_NewKidFactFiles_Intro.jpg","keywords":["Archie and Friends","archie showcase digest","archives","betty","new kids","new kids off the wall","pine point"],"articleSection":["From the Archie Archives"],"inLanguage":"en-US"},{"@type":"Person","@id":"https://archiecomics.com/#/schema/person/0c9d5a47ba5d680d6d911712d7ee2042","name":"Jesse Post","image":{"@type":"ImageObject","@id":"https://archiecomics.com/#personlogo","inLanguage":"en-US","url":"https://secure.gravatar.com/avatar/5998aa36d17ed36b30b20065c5006017?s=96&d=mm&r=g","contentUrl":"https://secure.gravatar.com/avatar/5998aa36d17ed36b30b20065c5006017?s=96&d=mm&r=g","caption":"Jesse Post"},"url":"https://archiecomics.com/author/jpost/"}]}</script>
	<!-- / Yoast SEO plugin. -->


<script type='application/javascript'>console.log('PixelYourSite Free version 8.2.17');</script>
<link rel='dns-prefetch' href='//s.w.org' />
<link rel="alternate" type="application/rss+xml" title="Archie Comics &raquo; Feed" href="https://archiecomics.com/feed/" />
<link rel="alternate" type="application/rss+xml" title="Archie Comics &raquo; Comments Feed" href="https://archiecomics.com/comments/feed/" />
		<script type="text/javascript">
			window._wpemojiSettings = {"baseUrl":"https:\/\/s.w.org\/images\/core\/emoji\/13.1.0\/72x72\/","ext":".png","svgUrl":"https:\/\/s.w.org\/images\/core\/emoji\/13.1.0\/svg\/","svgExt":".svg","source":{"concatemoji":"https:\/\/archiecomics.com\/wp-includes\/js\/wp-emoji-release.min.js?ver=5.8.3"}};
			!function(e,a,t){var n,r,o,i=a.createElement("canvas"),p=i.getContext&&i.getContext("2d");function s(e,t){var a=String.fromCharCode;p.clearRect(0,0,i.width,i.height),p.fillText(a.apply(this,e),0,0);e=i.toDataURL();return p.clearRect(0,0,i.width,i.height),p.fillText(a.apply(this,t),0,0),e===i.toDataURL()}function c(e){var t=a.createElement("script");t.src=e,t.defer=t.type="text/javascript",a.getElementsByTagName("head")[0].appendChild(t)}for(o=Array("flag","emoji"),t.supports={everything:!0,everythingExceptFlag:!0},r=0;r<o.length;r++)t.supports[o[r]]=function(e){if(!p||!p.fillText)return!1;switch(p.textBaseline="top",p.font="600 32px Arial",e){case"flag":return s([127987,65039,8205,9895,65039],[127987,65039,8203,9895,65039])?!1:!s([55356,56826,55356,56819],[55356,56826,8203,55356,56819])&&!s([55356,57332,56128,56423,56128,56418,56128,56421,56128,56430,56128,56423,56128,56447],[55356,57332,8203,56128,56423,8203,56128,56418,8203,56128,56421,8203,56128,56430,8203,56128,56423,8203,56128,56447]);case"emoji":return!s([10084,65039,8205,55357,56613],[10084,65039,8203,55357,56613])}return!1}(o[r]),t.supports.everything=t.supports.everything&&t.supports[o[r]],"flag"!==o[r]&&(t.supports.everythingExceptFlag=t.supports.everythingExceptFlag&&t.supports[o[r]]);t.supports.everythingExceptFlag=t.supports.everythingExceptFlag&&!t.supports.flag,t.DOMReady=!1,t.readyCallback=function(){t.DOMReady=!0},t.supports.everything||(n=function(){t.readyCallback()},a.addEventListener?(a.addEventListener("DOMContentLoaded",n,!1),e.addEventListener("load",n,!1)):(e.attachEvent("onload",n),a.attachEvent("onreadystatechange",function(){"complete"===a.readyState&&t.readyCallback()})),(n=t.source||{}).concatemoji?c(n.concatemoji):n.wpemoji&&n.twemoji&&(c(n.twemoji),c(n.wpemoji)))}(window,document,window._wpemojiSettings);
		</script>
		<style type="text/css">
img.wp-smiley,
img.emoji {
	display: inline !important;
	border: none !important;
	box-shadow: none !important;
	height: 1em !important;
	width: 1em !important;
	margin: 0 .07em !important;
	vertical-align: -0.1em !important;
	background: none !important;
	padding: 0 !important;
}
</style>
	<link rel='stylesheet' id='wp-block-library-css'  href='https://archiecomics.com/wp-includes/css/dist/block-library/style.min.css?ver=5.8.3' type='text/css' media='all' />
<link rel='stylesheet' id='wonderplugin-carousel-engine-css-css'  href='https://archiecomics.com/wp-content/plugins/wonderplugin-carousel/engine/wonderplugincarouselengine.css?ver=18.5C' type='text/css' media='all' />
<link rel='stylesheet' id='tempera-fonts-css'  href='https://archiecomics.com/wp-content/themes/tempera/fonts/fontfaces.css?ver=1.7.2' type='text/css' media='all' />
<link rel='stylesheet' id='tempera-style-css'  href='https://archiecomics.com/wp-content/themes/tempera-nocopyrt/style.css?ver=1.7.2' type='text/css' media='all' />
<script type='text/javascript' src='https://archiecomics.com/wp-includes/js/jquery/jquery.min.js?ver=3.6.0' id='jquery-core-js'></script>
<script type='text/javascript' src='https://archiecomics.com/wp-includes/js/jquery/jquery-migrate.min.js?ver=3.3.2' id='jquery-migrate-js'></script>
<script type='text/javascript' src='https://archiecomics.com/wp-content/plugins/wonderplugin-carousel/engine/wonderplugincarouselskins.js?ver=18.5C' id='wonderplugin-carousel-skins-script-js'></script>
<script type='text/javascript' src='https://archiecomics.com/wp-content/plugins/wonderplugin-carousel/engine/wonderplugincarousel.js?ver=18.5C' id='wonderplugin-carousel-script-js'></script>
<script type='text/javascript' src='https://archiecomics.com/wp-content/plugins/pixelyoursite/dist/scripts/jquery.bind-first-0.2.3.min.js?ver=5.8.3' id='jquery-bind-first-js'></script>
<script type='text/javascript' src='https://archiecomics.com/wp-content/plugins/pixelyoursite/dist/scripts/js.cookie-2.1.3.min.js?ver=2.1.3' id='js-cookie-js'></script>
<script type='text/javascript' id='pys-js-extra'>
/* <![CDATA[ */
var pysOptions = {"staticEvents":{"facebook":{"init_event":[{"delay":0,"type":"static","name":"PageView","pixelIds":["150910205450480"],"params":{"post_category":"From the Archie Archives","page_title":"Meet the New Kids!","post_type":"post","post_id":27561,"plugin":"PixelYourSite","user_role":"guest","event_url":"archiecomics.com\/meet-the-new-kids\/"},"e_id":"init_event","ids":[],"hasTimeWindow":false,"timeWindow":0,"eventID":"","woo_order":"","edd_order":""}]}},"dynamicEvents":{"signal_form":{"facebook":{"delay":0,"type":"dyn","name":"Signal","pixelIds":["150910205450480"],"params":{"event_action":"Form","page_title":"Meet the New Kids!","post_type":"post","post_id":27561,"plugin":"PixelYourSite","user_role":"guest","event_url":"archiecomics.com\/meet-the-new-kids\/"},"e_id":"signal_form","ids":[],"hasTimeWindow":false,"timeWindow":0,"eventID":"","woo_order":"","edd_order":""}},"signal_download":{"facebook":{"delay":0,"type":"dyn","name":"Signal","extensions":["","doc","exe","js","pdf","ppt","tgz","zip","xls"],"pixelIds":["150910205450480"],"params":{"event_action":"Download","page_title":"Meet the New Kids!","post_type":"post","post_id":27561,"plugin":"PixelYourSite","user_role":"guest","event_url":"archiecomics.com\/meet-the-new-kids\/"},"e_id":"signal_download","ids":[],"hasTimeWindow":false,"timeWindow":0,"eventID":"","woo_order":"","edd_order":""}},"signal_comment":{"facebook":{"delay":0,"type":"dyn","name":"Signal","pixelIds":["150910205450480"],"params":{"event_action":"Comment","page_title":"Meet the New Kids!","post_type":"post","post_id":27561,"plugin":"PixelYourSite","user_role":"guest","event_url":"archiecomics.com\/meet-the-new-kids\/"},"e_id":"signal_comment","ids":[],"hasTimeWindow":false,"timeWindow":0,"eventID":"","woo_order":"","edd_order":""}}},"triggerEvents":[],"triggerEventTypes":[],"facebook":{"pixelIds":["150910205450480"],"advancedMatching":[],"removeMetadata":false,"contentParams":{"post_type":"post","post_id":27561,"content_name":"Meet the New Kids!","categories":"From the Archie Archives","tags":"Archie and Friends, archie showcase digest, archives, betty, new kids, new kids off the wall, pine point"},"commentEventEnabled":true,"wooVariableAsSimple":false,"downloadEnabled":true,"formEventEnabled":true,"ajaxForServerEvent":true,"serverApiEnabled":false,"wooCRSendFromServer":false},"debug":"","siteUrl":"https:\/\/archiecomics.com","ajaxUrl":"https:\/\/archiecomics.com\/wp-admin\/admin-ajax.php","enable_remove_download_url_param":"1","gdpr":{"ajax_enabled":false,"all_disabled_by_api":false,"facebook_disabled_by_api":false,"analytics_disabled_by_api":false,"google_ads_disabled_by_api":false,"pinterest_disabled_by_api":false,"bing_disabled_by_api":false,"facebook_prior_consent_enabled":false,"analytics_prior_consent_enabled":true,"google_ads_prior_consent_enabled":null,"pinterest_prior_consent_enabled":true,"bing_prior_consent_enabled":true,"cookiebot_integration_enabled":false,"cookiebot_facebook_consent_category":"marketing","cookiebot_analytics_consent_category":"statistics","cookiebot_google_ads_consent_category":null,"cookiebot_pinterest_consent_category":"marketing","cookiebot_bing_consent_category":"marketing","consent_magic_integration_enabled":false,"real_cookie_banner_integration_enabled":false,"cookie_notice_integration_enabled":false,"cookie_law_info_integration_enabled":false},"edd":{"enabled":false},"woo":{"enabled":false}};
/* ]]> */
</script>
<script type='text/javascript' src='https://archiecomics.com/wp-content/plugins/pixelyoursite/dist/scripts/public.js?ver=8.2.17' id='pys-js'></script>
<link rel="https://api.w.org/" href="https://archiecomics.com/wp-json/" /><link rel="alternate" type="application/json" href="https://archiecomics.com/wp-json/wp/v2/posts/27561" /><link rel="EditURI" type="application/rsd+xml" title="RSD" href="https://archiecomics.com/xmlrpc.php?rsd" />
<link rel="wlwmanifest" type="application/wlwmanifest+xml" href="https://archiecomics.com/wp-includes/wlwmanifest.xml" /> 
<link rel='shortlink' href='https://archiecomics.com/?p=27561' />
<link rel="alternate" type="application/json+oembed" href="https://archiecomics.com/wp-json/oembed/1.0/embed?url=https%3A%2F%2Farchiecomics.com%2Fmeet-the-new-kids%2F" />
<link rel="alternate" type="text/xml+oembed" href="https://archiecomics.com/wp-json/oembed/1.0/embed?url=https%3A%2F%2Farchiecomics.com%2Fmeet-the-new-kids%2F&#038;format=xml" />
<meta name="facebook-domain-verification" content="cbcms1bw102fcx39347iwyqnevb35f" /><script type="text/javascript">
(function(url){
	if(/(?:Chrome\/26\.0\.1410\.63 Safari\/537\.31|WordfenceTestMonBot)/.test(navigator.userAgent)){ return; }
	var addEvent = function(evt, handler) {
		if (window.addEventListener) {
			document.addEventListener(evt, handler, false);
		} else if (window.attachEvent) {
			document.attachEvent('on' + evt, handler);
		}
	};
	var removeEvent = function(evt, handler) {
		if (window.removeEventListener) {
			document.removeEventListener(evt, handler, false);
		} else if (window.detachEvent) {
			document.detachEvent('on' + evt, handler);
		}
	};
	var evts = 'contextmenu dblclick drag dragend dragenter dragleave dragover dragstart drop keydown keypress keyup mousedown mousemove mouseout mouseover mouseup mousewheel scroll'.split(' ');
	var logHuman = function() {
		if (window.wfLogHumanRan) { return; }
		window.wfLogHumanRan = true;
		var wfscr = document.createElement('script');
		wfscr.type = 'text/javascript';
		wfscr.async = true;
		wfscr.src = url + '&r=' + Math.random();
		(document.getElementsByTagName('head')[0]||document.getElementsByTagName('body')[0]).appendChild(wfscr);
		for (var i = 0; i < evts.length; i++) {
			removeEvent(evts[i], logHuman);
		}
	};
	for (var i = 0; i < evts.length; i++) {
		addEvent(evts[i], logHuman);
	}
})('//archiecomics.com/?wordfence_lh=1&hid=782322368B86FCBC0DFB5CBB840EDFF4');
</script><style type="text/css" id="custom-background-css">
body.custom-background { background-color: #ffffff; background-image: url("https://archiecomics.com/wp-content/uploads/2021/08/bg-scaled.jpg"); background-position: center top; background-size: contain; background-repeat: repeat; background-attachment: scroll; }
</style>
	<style type="text/css">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</style> 
<style type="text/css">/* Tempera Custom CSS */ 
#main {
	clear: both;
	padding: 0px ;
	margin-top: 0px; 
} 
#access {
display: block;
float: left;
margin: -4px auto 0;
width: 100%;
} 

#branding {
display: block;
float: left;
clear: both;
padding: 0 0 0 0;
position: relative;
overflow: hidden;
margin-top: 5px; 
width: 100%;
}</style>
<link rel='stylesheet' id='tempera-style-mobile'  href='https://archiecomics.com/wp-content/themes/tempera/styles/style-mobile.css?ver=1.7.2' type='text/css' media='all' />	<!--[if lt IE 9]>
	<script>
	document.createElement('header');
	document.createElement('nav');
	document.createElement('section');
	document.createElement('article');
	document.createElement('aside');
	document.createElement('footer');
	</script>
	<![endif]-->
	</head>
<body class="post-template-default single single-post postid-27561 single-format-standard custom-background tempera-image-none caption-dark tempera-menu-left">


<div id="wrapper" class="hfeed">
<div id="topbar" ><div id="topbar-inner"> <div class="socials" id="sheader">
			<a  target="_blank"  href="https://www.facebook.com/ArchieComicsOfficial?ref=tn_tnmn"
			class="socialicons social-Facebook" title="Archie Comics Facebook">
				<img alt="Facebook" src="https://archiecomics.com/wp-content/themes/tempera/images/socials/Facebook.png" />
			</a>
			<a  target="_blank"  href="https://twitter.com/archiecomics"
			class="socialicons social-Twitter" title="Archie Comics Twitter">
				<img alt="Twitter" src="https://archiecomics.com/wp-content/themes/tempera/images/socials/Twitter.png" />
			</a>
			<a  target="_blank"  href="http://www.youtube.com/user/ArchieComicsOfficial"
			class="socialicons social-YouTube" title="Archie Comics YouTube Channel">
				<img alt="YouTube" src="https://archiecomics.com/wp-content/themes/tempera/images/socials/YouTube.png" />
			</a>
			<a  target="_blank"  href="https://plus.google.com/u/0/103927090213296657788/posts"
			class="socialicons social-GooglePlus" title="Archie Comics Google+">
				<img alt="GooglePlus" src="https://archiecomics.com/wp-content/themes/tempera/images/socials/GooglePlus.png" />
			</a>
			<a  target="_blank"  href="http://www.goodreads.com/user/show/8914136-archie-comics"
			class="socialicons social-GoodReads" title="Archie Comics GoodReads">
				<img alt="GoodReads" src="https://archiecomics.com/wp-content/themes/tempera/images/socials/GoodReads.png" />
			</a></div> </div></div>

<div id="header-full">
	<header id="header">
		<div id="masthead">
			<div id="branding" role="banner" >
				<img id="bg_image" alt="" title="" src="https://archiecomics.com/wp-content/uploads/2014/09/cropped-archie_comics_header.png"  />	<div id="header-container">
	<a href="https://archiecomics.com/" id="linky"></a></div>						<div id="header-widget-area">
			<ul class="yoyo">
				<li id="search-3" class="widget-container widget_search">
<form role="search" method="get" class="searchform" action="https://archiecomics.com/">
	<label>
		<span class="screen-reader-text">Search for:</span>
		<input type="search" class="s" placeholder="Search" value="" name="s" />
	</label>
	<button type="submit" class="searchsubmit"><span class="screen-reader-text">Search</span><i class="crycon-search"></i></button>
</form>
</li>			</ul>
		</div>
					<div style="clear:both;"></div>
			</div><!-- #branding -->
			<a id="nav-toggle"><span>&nbsp;</span></a>
			<nav id="access" role="navigation">
					<div class="skip-link screen-reader-text"><a href="#content" title="Skip to content">
		Skip to content	</a></div>
	<div class="menu"><ul id="prime_nav" class="menu"><li id="menu-item-6" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-home menu-item-6"><a href="http://archiecomics.com/"><span>Home</span></a></li>
<li id="menu-item-939" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-939"><a href="https://archiecomics.com/news/"><span>News</span></a></li>
<li id="menu-item-27404" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-27404"><a target="_blank" rel="noopener" href="https://archiecomics.com/nft/?utm_source=ACP&#038;utm_medium=Top%20Nav&#038;utm_campaign=ACP_Top_Menu"><span>NFT</span></a></li>
<li id="menu-item-924" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-has-children menu-item-924"><a target="_blank" rel="noopener" href="https://store.archiecomics.com/?utm_source=ACP&#038;utm_medium=Menu&#038;utm_campaign=TopMenu"><span>Shop</span></a>
<ul class="sub-menu">
	<li id="menu-item-7961" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-7961"><a target="_blank" rel="noopener" href="https://store.archiecomics.com/?utm_source=ACP&#038;utm_medium=Menu&#038;utm_campaign=TopMenu"><span>Archie Comics Shop</span></a></li>
	<li id="menu-item-6625" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-6625"><a target="_blank" rel="noopener" href="https://store.archiecomics.com/series"><span>Archie Subscriptions</span></a></li>
</ul>
</li>
<li id="menu-item-51" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-has-children menu-item-51"><a href="https://archiecomics.com/characters/"><span>Characters</span></a>
<ul class="sub-menu">
	<li id="menu-item-6285" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-6285"><a href="https://archiecomics.com/characters/"><span>Traditional Archie</span></a></li>
	<li id="menu-item-6284" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-6284"><a href="https://archiecomics.com/characters/new-riverdale/"><span>New Archie</span></a></li>
	<li id="menu-item-6590" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-6590"><a href="https://archiecomics.com/characters/riverdale-on-the-cw/"><span>Riverdale on the CW</span></a></li>
</ul>
</li>
<li id="menu-item-25355" class="menu-item menu-item-type-post_type menu-item-object-post menu-item-has-children menu-item-25355"><a href="https://archiecomics.com/appnews/"><span>Digital Comics</span></a>
<ul class="sub-menu">
	<li id="menu-item-25354" class="menu-item menu-item-type-post_type menu-item-object-post menu-item-25354"><a href="https://archiecomics.com/appnews/"><span>Archie Digital</span></a></li>
</ul>
</li>
<li id="menu-item-932" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-has-children menu-item-932"><a href="https://archiecomics.com/about-us/"><span>About Us</span></a>
<ul class="sub-menu">
	<li id="menu-item-928" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-928"><a href="http://archiecomics.com/about-us/"><span>Contact</span></a></li>
	<li id="menu-item-933" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-933"><a href="https://archiecomics.com/about-us/privacy-policy/"><span>Privacy Policy</span></a></li>
</ul>
</li>
<li class='menu-main-search'> 
<form role="search" method="get" class="searchform" action="https://archiecomics.com/">
	<label>
		<span class="screen-reader-text">Search for:</span>
		<input type="search" class="s" placeholder="Search" value="" name="s" />
	</label>
	<button type="submit" class="searchsubmit"><span class="screen-reader-text">Search</span><i class="crycon-search"></i></button>
</form>
 </li></ul></div>			</nav><!-- #access -->
		</div><!-- #masthead -->
	</header><!-- #header -->
</div><!-- #header-full -->

<div style="clear:both;height:0;"> </div>

<div id="main" class="main">
		<div id="toTop"><i class="crycon-back2top"></i> </div>	<div  id="forbottom" >
		
		<div style="clear:both;"> </div>

		
		<section id="container" class="two-columns-right">
			<div id="content" role="main">
			<div class="breadcrumbs"><a href="https://archiecomics.com"><i class="crycon-homebread"></i><span class="screen-reader-text">Home</span></a><i class="crycon-angle-right"></i> <a href="https://archiecomics.com/category/from-the-archie-archives/">From the Archie Archives</a> <i class="crycon-angle-right"></i> <span class="current">Meet the New Kids!</span></div><!--breadcrumbs-->

				<div id="post-27561" class="post-27561 post type-post status-publish format-standard has-post-thumbnail hentry category-from-the-archie-archives tag-archie-and-friends tag-archie-showcase-digest tag-archives tag-betty tag-new-kids tag-new-kids-off-the-wall tag-pine-point">
					<h1 class="entry-title">Meet the New Kids!</h1>
										<div class="entry-meta">
						<span class="author vcard" ><i class="crycon-author crycon-metas" title="Author "></i>
					<a class="url fn n" rel="author" href="https://archiecomics.com/author/jpost/" title="View all posts by Jesse Post">Jesse Post</a></span><span><i class="crycon-time crycon-metas" title="Date"></i>
				<time class="onDate date published" datetime="2022-05-13T17:25:05-04:00">
					<a href="https://archiecomics.com/meet-the-new-kids/" rel="bookmark">May 13, 2022</a>
				</time>
			   </span><time class="updated"  datetime="2022-05-13T17:26:17-04:00">May 13, 2022</time><span class="bl_categ"><i class="crycon-folder-open crycon-metas" title="Categories"></i><a href="https://archiecomics.com/category/from-the-archie-archives/" rel="tag">From the Archie Archives</a></span> 					</div><!-- .entry-meta -->

					<div class="entry-content">
						<p>&nbsp;</p>
<p><img loading="lazy" class="aligncenter size-full wp-image-27543" src="https://archiecomics.com/wp-content/uploads/2022/05/ArchieShowcaseDigest_08_Cover_Parent.jpg" alt="" width="1200" height="1616" srcset="https://archiecomics.com/wp-content/uploads/2022/05/ArchieShowcaseDigest_08_Cover_Parent.jpg 1200w, https://archiecomics.com/wp-content/uploads/2022/05/ArchieShowcaseDigest_08_Cover_Parent-223x300.jpg 223w, https://archiecomics.com/wp-content/uploads/2022/05/ArchieShowcaseDigest_08_Cover_Parent-760x1024.jpg 760w, https://archiecomics.com/wp-content/uploads/2022/05/ArchieShowcaseDigest_08_Cover_Parent-111x150.jpg 111w, https://archiecomics.com/wp-content/uploads/2022/05/ArchieShowcaseDigest_08_Cover_Parent-768x1034.jpg 768w, https://archiecomics.com/wp-content/uploads/2022/05/ArchieShowcaseDigest_08_Cover_Parent-1141x1536.jpg 1141w" sizes="(max-width: 1200px) 100vw, 1200px" /></p>
<p>In this week&#8217;s <span style="color: #3366ff;"><strong><a style="color: #3366ff;" href="https://archiecomics.com/new-archie-comics-releases-for-5-11-22/">ARCHIE SHOWCASE DIGEST #8: NEW KIDS OFF THE WALL</a></strong></span> we go waaaay back to revisit the explosive arrival of the Pine Point High new kids in Riverdale!</p>
<p><span id="more-27561"></span>The fun started in ARCHIE &amp; FRIENDS #148 by <strong>Alex Simmons</strong> and <strong>Dan Parent</strong> in 2010, and Riverdale was never the same again. The original storyline featured new pranks, new love triangles, new chemistry, and lots of ups and downs, and it&#8217;s all reprinted here in SHOWCASE DIGEST #8.</p>
<p>If you&#8217;d like to meet the new kids while you <span style="color: #3366ff;"><a style="color: #3366ff;" href="https://store.archiecomics.com/collections/archie-digest-subscriptions/products/archie-showcase-digest-subscription">wait for your copy</a>,</span> click through the gallery below, and try to make &#8217;em feel a little more welcome than Veronica did!</p>
<p><img loading="lazy" class="aligncenter size-full wp-image-27568" src="https://archiecomics.com/wp-content/uploads/2022/05/Archie_NewKidFactFiles_Intro.jpg" alt="" width="1200" height="1616" srcset="https://archiecomics.com/wp-content/uploads/2022/05/Archie_NewKidFactFiles_Intro.jpg 1200w, https://archiecomics.com/wp-content/uploads/2022/05/Archie_NewKidFactFiles_Intro-223x300.jpg 223w, https://archiecomics.com/wp-content/uploads/2022/05/Archie_NewKidFactFiles_Intro-760x1024.jpg 760w, https://archiecomics.com/wp-content/uploads/2022/05/Archie_NewKidFactFiles_Intro-111x150.jpg 111w, https://archiecomics.com/wp-content/uploads/2022/05/Archie_NewKidFactFiles_Intro-768x1034.jpg 768w, https://archiecomics.com/wp-content/uploads/2022/05/Archie_NewKidFactFiles_Intro-1141x1536.jpg 1141w" sizes="(max-width: 1200px) 100vw, 1200px" /></p>
<p>&nbsp;</p>

		<style type="text/css">
			#gallery-2 {
				margin: auto;
			}
			#gallery-2 .gallery-item {
				float: left;
				margin-top: 10px;
				text-align: center;
				width: 33%;
			}
			#gallery-2 img {
				border: 2px solid #cfcfcf;
			}
			#gallery-2 .gallery-caption {
				margin-left: 0;
			}
			/* see gallery_shortcode() in wp-includes/media.php */
		</style>
		<div id='gallery-2' class='gallery galleryid-27561 gallery-columns-3 gallery-size-full'><dl class='gallery-item'>
			<dt class='gallery-icon portrait'>
				<a href='https://archiecomics.com/meet-the-new-kids/archie_newkidfactfiles_bigvic/'><img width="1200" height="1616" src="https://archiecomics.com/wp-content/uploads/2022/05/Archie_NewKidFactFiles_BigVic.jpg" class="attachment-full size-full" alt="" loading="lazy" srcset="https://archiecomics.com/wp-content/uploads/2022/05/Archie_NewKidFactFiles_BigVic.jpg 1200w, https://archiecomics.com/wp-content/uploads/2022/05/Archie_NewKidFactFiles_BigVic-223x300.jpg 223w, https://archiecomics.com/wp-content/uploads/2022/05/Archie_NewKidFactFiles_BigVic-760x1024.jpg 760w, https://archiecomics.com/wp-content/uploads/2022/05/Archie_NewKidFactFiles_BigVic-111x150.jpg 111w, https://archiecomics.com/wp-content/uploads/2022/05/Archie_NewKidFactFiles_BigVic-768x1034.jpg 768w, https://archiecomics.com/wp-content/uploads/2022/05/Archie_NewKidFactFiles_BigVic-1141x1536.jpg 1141w" sizes="(max-width: 1200px) 100vw, 1200px" /></a>
			</dt></dl><dl class='gallery-item'>
			<dt class='gallery-icon portrait'>
				<a href='https://archiecomics.com/meet-the-new-kids/archie_newkidfactfiles_bobbi/'><img width="1200" height="1616" src="https://archiecomics.com/wp-content/uploads/2022/05/Archie_NewKidFactFiles_Bobbi.jpg" class="attachment-full size-full" alt="" loading="lazy" srcset="https://archiecomics.com/wp-content/uploads/2022/05/Archie_NewKidFactFiles_Bobbi.jpg 1200w, https://archiecomics.com/wp-content/uploads/2022/05/Archie_NewKidFactFiles_Bobbi-223x300.jpg 223w, https://archiecomics.com/wp-content/uploads/2022/05/Archie_NewKidFactFiles_Bobbi-760x1024.jpg 760w, https://archiecomics.com/wp-content/uploads/2022/05/Archie_NewKidFactFiles_Bobbi-111x150.jpg 111w, https://archiecomics.com/wp-content/uploads/2022/05/Archie_NewKidFactFiles_Bobbi-768x1034.jpg 768w, https://archiecomics.com/wp-content/uploads/2022/05/Archie_NewKidFactFiles_Bobbi-1141x1536.jpg 1141w" sizes="(max-width: 1200px) 100vw, 1200px" /></a>
			</dt></dl><dl class='gallery-item'>
			<dt class='gallery-icon portrait'>
				<a href='https://archiecomics.com/meet-the-new-kids/archie_newkidfactfiles_carla/'><img width="1200" height="1616" src="https://archiecomics.com/wp-content/uploads/2022/05/Archie_NewKidFactFiles_Carla.jpg" class="attachment-full size-full" alt="" loading="lazy" srcset="https://archiecomics.com/wp-content/uploads/2022/05/Archie_NewKidFactFiles_Carla.jpg 1200w, https://archiecomics.com/wp-content/uploads/2022/05/Archie_NewKidFactFiles_Carla-223x300.jpg 223w, https://archiecomics.com/wp-content/uploads/2022/05/Archie_NewKidFactFiles_Carla-760x1024.jpg 760w, https://archiecomics.com/wp-content/uploads/2022/05/Archie_NewKidFactFiles_Carla-111x150.jpg 111w, https://archiecomics.com/wp-content/uploads/2022/05/Archie_NewKidFactFiles_Carla-768x1034.jpg 768w, https://archiecomics.com/wp-content/uploads/2022/05/Archie_NewKidFactFiles_Carla-1141x1536.jpg 1141w" sizes="(max-width: 1200px) 100vw, 1200px" /></a>
			</dt></dl><br style="clear: both" /><dl class='gallery-item'>
			<dt class='gallery-icon portrait'>
				<a href='https://archiecomics.com/meet-the-new-kids/archie_newkidfactfiles_chloe/'><img width="1200" height="1616" src="https://archiecomics.com/wp-content/uploads/2022/05/Archie_NewKidFactFiles_Chloe.jpg" class="attachment-full size-full" alt="" loading="lazy" srcset="https://archiecomics.com/wp-content/uploads/2022/05/Archie_NewKidFactFiles_Chloe.jpg 1200w, https://archiecomics.com/wp-content/uploads/2022/05/Archie_NewKidFactFiles_Chloe-223x300.jpg 223w, https://archiecomics.com/wp-content/uploads/2022/05/Archie_NewKidFactFiles_Chloe-760x1024.jpg 760w, https://archiecomics.com/wp-content/uploads/2022/05/Archie_NewKidFactFiles_Chloe-111x150.jpg 111w, https://archiecomics.com/wp-content/uploads/2022/05/Archie_NewKidFactFiles_Chloe-768x1034.jpg 768w, https://archiecomics.com/wp-content/uploads/2022/05/Archie_NewKidFactFiles_Chloe-1141x1536.jpg 1141w" sizes="(max-width: 1200px) 100vw, 1200px" /></a>
			</dt></dl><dl class='gallery-item'>
			<dt class='gallery-icon portrait'>
				<a href='https://archiecomics.com/meet-the-new-kids/archie_newkidfactfiles_chunk/'><img width="1200" height="1616" src="https://archiecomics.com/wp-content/uploads/2022/05/Archie_NewKidFactFiles_Chunk.jpg" class="attachment-full size-full" alt="" loading="lazy" srcset="https://archiecomics.com/wp-content/uploads/2022/05/Archie_NewKidFactFiles_Chunk.jpg 1200w, https://archiecomics.com/wp-content/uploads/2022/05/Archie_NewKidFactFiles_Chunk-223x300.jpg 223w, https://archiecomics.com/wp-content/uploads/2022/05/Archie_NewKidFactFiles_Chunk-760x1024.jpg 760w, https://archiecomics.com/wp-content/uploads/2022/05/Archie_NewKidFactFiles_Chunk-111x150.jpg 111w, https://archiecomics.com/wp-content/uploads/2022/05/Archie_NewKidFactFiles_Chunk-768x1034.jpg 768w, https://archiecomics.com/wp-content/uploads/2022/05/Archie_NewKidFactFiles_Chunk-1141x1536.jpg 1141w" sizes="(max-width: 1200px) 100vw, 1200px" /></a>
			</dt></dl><dl class='gallery-item'>
			<dt class='gallery-icon portrait'>
				<a href='https://archiecomics.com/meet-the-new-kids/archie_newkidfactfiles_kevin/'><img width="1200" height="1616" src="https://archiecomics.com/wp-content/uploads/2022/05/Archie_NewKidFactFiles_Kevin.jpg" class="attachment-full size-full" alt="" loading="lazy" srcset="https://archiecomics.com/wp-content/uploads/2022/05/Archie_NewKidFactFiles_Kevin.jpg 1200w, https://archiecomics.com/wp-content/uploads/2022/05/Archie_NewKidFactFiles_Kevin-223x300.jpg 223w, https://archiecomics.com/wp-content/uploads/2022/05/Archie_NewKidFactFiles_Kevin-760x1024.jpg 760w, https://archiecomics.com/wp-content/uploads/2022/05/Archie_NewKidFactFiles_Kevin-111x150.jpg 111w, https://archiecomics.com/wp-content/uploads/2022/05/Archie_NewKidFactFiles_Kevin-768x1034.jpg 768w, https://archiecomics.com/wp-content/uploads/2022/05/Archie_NewKidFactFiles_Kevin-1141x1536.jpg 1141w" sizes="(max-width: 1200px) 100vw, 1200px" /></a>
			</dt></dl><br style="clear: both" /><dl class='gallery-item'>
			<dt class='gallery-icon portrait'>
				<a href='https://archiecomics.com/meet-the-new-kids/archie_newkidfactfiles_lawrence/'><img width="1200" height="1616" src="https://archiecomics.com/wp-content/uploads/2022/05/Archie_NewKidFactFiles_Lawrence.jpg" class="attachment-full size-full" alt="" loading="lazy" srcset="https://archiecomics.com/wp-content/uploads/2022/05/Archie_NewKidFactFiles_Lawrence.jpg 1200w, https://archiecomics.com/wp-content/uploads/2022/05/Archie_NewKidFactFiles_Lawrence-223x300.jpg 223w, https://archiecomics.com/wp-content/uploads/2022/05/Archie_NewKidFactFiles_Lawrence-760x1024.jpg 760w, https://archiecomics.com/wp-content/uploads/2022/05/Archie_NewKidFactFiles_Lawrence-111x150.jpg 111w, https://archiecomics.com/wp-content/uploads/2022/05/Archie_NewKidFactFiles_Lawrence-768x1034.jpg 768w, https://archiecomics.com/wp-content/uploads/2022/05/Archie_NewKidFactFiles_Lawrence-1141x1536.jpg 1141w" sizes="(max-width: 1200px) 100vw, 1200px" /></a>
			</dt></dl><dl class='gallery-item'>
			<dt class='gallery-icon portrait'>
				<a href='https://archiecomics.com/meet-the-new-kids/archie_newkidfactfiles_prankenstein/'><img width="1200" height="1616" src="https://archiecomics.com/wp-content/uploads/2022/05/Archie_NewKidFactFiles_Prankenstein.jpg" class="attachment-full size-full" alt="" loading="lazy" srcset="https://archiecomics.com/wp-content/uploads/2022/05/Archie_NewKidFactFiles_Prankenstein.jpg 1200w, https://archiecomics.com/wp-content/uploads/2022/05/Archie_NewKidFactFiles_Prankenstein-223x300.jpg 223w, https://archiecomics.com/wp-content/uploads/2022/05/Archie_NewKidFactFiles_Prankenstein-760x1024.jpg 760w, https://archiecomics.com/wp-content/uploads/2022/05/Archie_NewKidFactFiles_Prankenstein-111x150.jpg 111w, https://archiecomics.com/wp-content/uploads/2022/05/Archie_NewKidFactFiles_Prankenstein-768x1034.jpg 768w, https://archiecomics.com/wp-content/uploads/2022/05/Archie_NewKidFactFiles_Prankenstein-1141x1536.jpg 1141w" sizes="(max-width: 1200px) 100vw, 1200px" /></a>
			</dt></dl><dl class='gallery-item'>
			<dt class='gallery-icon portrait'>
				<a href='https://archiecomics.com/meet-the-new-kids/archie_newkidfactfiles_rob/'><img width="1200" height="1616" src="https://archiecomics.com/wp-content/uploads/2022/05/Archie_NewKidFactFiles_Rob.jpg" class="attachment-full size-full" alt="" loading="lazy" srcset="https://archiecomics.com/wp-content/uploads/2022/05/Archie_NewKidFactFiles_Rob.jpg 1200w, https://archiecomics.com/wp-content/uploads/2022/05/Archie_NewKidFactFiles_Rob-223x300.jpg 223w, https://archiecomics.com/wp-content/uploads/2022/05/Archie_NewKidFactFiles_Rob-760x1024.jpg 760w, https://archiecomics.com/wp-content/uploads/2022/05/Archie_NewKidFactFiles_Rob-111x150.jpg 111w, https://archiecomics.com/wp-content/uploads/2022/05/Archie_NewKidFactFiles_Rob-768x1034.jpg 768w, https://archiecomics.com/wp-content/uploads/2022/05/Archie_NewKidFactFiles_Rob-1141x1536.jpg 1141w" sizes="(max-width: 1200px) 100vw, 1200px" /></a>
			</dt></dl><br style="clear: both" /><dl class='gallery-item'>
			<dt class='gallery-icon portrait'>
				<a href='https://archiecomics.com/meet-the-new-kids/archie_newkidfactfiles_sayid/'><img width="1200" height="1616" src="https://archiecomics.com/wp-content/uploads/2022/05/Archie_NewKidFactFiles_Sayid.jpg" class="attachment-full size-full" alt="" loading="lazy" srcset="https://archiecomics.com/wp-content/uploads/2022/05/Archie_NewKidFactFiles_Sayid.jpg 1200w, https://archiecomics.com/wp-content/uploads/2022/05/Archie_NewKidFactFiles_Sayid-223x300.jpg 223w, https://archiecomics.com/wp-content/uploads/2022/05/Archie_NewKidFactFiles_Sayid-760x1024.jpg 760w, https://archiecomics.com/wp-content/uploads/2022/05/Archie_NewKidFactFiles_Sayid-111x150.jpg 111w, https://archiecomics.com/wp-content/uploads/2022/05/Archie_NewKidFactFiles_Sayid-768x1034.jpg 768w, https://archiecomics.com/wp-content/uploads/2022/05/Archie_NewKidFactFiles_Sayid-1141x1536.jpg 1141w" sizes="(max-width: 1200px) 100vw, 1200px" /></a>
			</dt></dl><dl class='gallery-item'>
			<dt class='gallery-icon portrait'>
				<a href='https://archiecomics.com/meet-the-new-kids/archie_newkidfactfiles_sheila/'><img width="1200" height="1616" src="https://archiecomics.com/wp-content/uploads/2022/05/Archie_NewKidFactFiles_Sheila.jpg" class="attachment-full size-full" alt="" loading="lazy" srcset="https://archiecomics.com/wp-content/uploads/2022/05/Archie_NewKidFactFiles_Sheila.jpg 1200w, https://archiecomics.com/wp-content/uploads/2022/05/Archie_NewKidFactFiles_Sheila-223x300.jpg 223w, https://archiecomics.com/wp-content/uploads/2022/05/Archie_NewKidFactFiles_Sheila-760x1024.jpg 760w, https://archiecomics.com/wp-content/uploads/2022/05/Archie_NewKidFactFiles_Sheila-111x150.jpg 111w, https://archiecomics.com/wp-content/uploads/2022/05/Archie_NewKidFactFiles_Sheila-768x1034.jpg 768w, https://archiecomics.com/wp-content/uploads/2022/05/Archie_NewKidFactFiles_Sheila-1141x1536.jpg 1141w" sizes="(max-width: 1200px) 100vw, 1200px" /></a>
			</dt></dl><dl class='gallery-item'>
			<dt class='gallery-icon portrait'>
				<a href='https://archiecomics.com/meet-the-new-kids/archie_newkidfactfiles_sherry/'><img width="1200" height="1616" src="https://archiecomics.com/wp-content/uploads/2022/05/Archie_NewKidFactFiles_Sherry.jpg" class="attachment-full size-full" alt="" loading="lazy" srcset="https://archiecomics.com/wp-content/uploads/2022/05/Archie_NewKidFactFiles_Sherry.jpg 1200w, https://archiecomics.com/wp-content/uploads/2022/05/Archie_NewKidFactFiles_Sherry-223x300.jpg 223w, https://archiecomics.com/wp-content/uploads/2022/05/Archie_NewKidFactFiles_Sherry-760x1024.jpg 760w, https://archiecomics.com/wp-content/uploads/2022/05/Archie_NewKidFactFiles_Sherry-111x150.jpg 111w, https://archiecomics.com/wp-content/uploads/2022/05/Archie_NewKidFactFiles_Sherry-768x1034.jpg 768w, https://archiecomics.com/wp-content/uploads/2022/05/Archie_NewKidFactFiles_Sherry-1141x1536.jpg 1141w" sizes="(max-width: 1200px) 100vw, 1200px" /></a>
			</dt></dl><br style="clear: both" /><dl class='gallery-item'>
			<dt class='gallery-icon portrait'>
				<a href='https://archiecomics.com/meet-the-new-kids/archie_newkidfactfiles_shrill/'><img width="1200" height="1616" src="https://archiecomics.com/wp-content/uploads/2022/05/Archie_NewKidFactFiles_Shrill.jpg" class="attachment-full size-full" alt="" loading="lazy" srcset="https://archiecomics.com/wp-content/uploads/2022/05/Archie_NewKidFactFiles_Shrill.jpg 1200w, https://archiecomics.com/wp-content/uploads/2022/05/Archie_NewKidFactFiles_Shrill-223x300.jpg 223w, https://archiecomics.com/wp-content/uploads/2022/05/Archie_NewKidFactFiles_Shrill-760x1024.jpg 760w, https://archiecomics.com/wp-content/uploads/2022/05/Archie_NewKidFactFiles_Shrill-111x150.jpg 111w, https://archiecomics.com/wp-content/uploads/2022/05/Archie_NewKidFactFiles_Shrill-768x1034.jpg 768w, https://archiecomics.com/wp-content/uploads/2022/05/Archie_NewKidFactFiles_Shrill-1141x1536.jpg 1141w" sizes="(max-width: 1200px) 100vw, 1200px" /></a>
			</dt></dl><dl class='gallery-item'>
			<dt class='gallery-icon portrait'>
				<a href='https://archiecomics.com/meet-the-new-kids/archie_newkidfactfiles_simon/'><img width="1200" height="1616" src="https://archiecomics.com/wp-content/uploads/2022/05/Archie_NewKidFactFiles_Simon.jpg" class="attachment-full size-full" alt="" loading="lazy" srcset="https://archiecomics.com/wp-content/uploads/2022/05/Archie_NewKidFactFiles_Simon.jpg 1200w, https://archiecomics.com/wp-content/uploads/2022/05/Archie_NewKidFactFiles_Simon-223x300.jpg 223w, https://archiecomics.com/wp-content/uploads/2022/05/Archie_NewKidFactFiles_Simon-760x1024.jpg 760w, https://archiecomics.com/wp-content/uploads/2022/05/Archie_NewKidFactFiles_Simon-111x150.jpg 111w, https://archiecomics.com/wp-content/uploads/2022/05/Archie_NewKidFactFiles_Simon-768x1034.jpg 768w, https://archiecomics.com/wp-content/uploads/2022/05/Archie_NewKidFactFiles_Simon-1141x1536.jpg 1141w" sizes="(max-width: 1200px) 100vw, 1200px" /></a>
			</dt></dl><dl class='gallery-item'>
			<dt class='gallery-icon portrait'>
				<a href='https://archiecomics.com/meet-the-new-kids/archie_newkidfactfiles_teachers/'><img width="1200" height="1616" src="https://archiecomics.com/wp-content/uploads/2022/05/Archie_NewKidFactFiles_Teachers.jpg" class="attachment-full size-full" alt="" loading="lazy" srcset="https://archiecomics.com/wp-content/uploads/2022/05/Archie_NewKidFactFiles_Teachers.jpg 1200w, https://archiecomics.com/wp-content/uploads/2022/05/Archie_NewKidFactFiles_Teachers-223x300.jpg 223w, https://archiecomics.com/wp-content/uploads/2022/05/Archie_NewKidFactFiles_Teachers-760x1024.jpg 760w, https://archiecomics.com/wp-content/uploads/2022/05/Archie_NewKidFactFiles_Teachers-111x150.jpg 111w, https://archiecomics.com/wp-content/uploads/2022/05/Archie_NewKidFactFiles_Teachers-768x1034.jpg 768w, https://archiecomics.com/wp-content/uploads/2022/05/Archie_NewKidFactFiles_Teachers-1141x1536.jpg 1141w" sizes="(max-width: 1200px) 100vw, 1200px" /></a>
			</dt></dl><br style="clear: both" /><dl class='gallery-item'>
			<dt class='gallery-icon portrait'>
				<a href='https://archiecomics.com/meet-the-new-kids/archie_newkidfactfiles_thetwitters/'><img width="1200" height="1616" src="https://archiecomics.com/wp-content/uploads/2022/05/Archie_NewKidFactFiles_TheTwitters.jpg" class="attachment-full size-full" alt="" loading="lazy" srcset="https://archiecomics.com/wp-content/uploads/2022/05/Archie_NewKidFactFiles_TheTwitters.jpg 1200w, https://archiecomics.com/wp-content/uploads/2022/05/Archie_NewKidFactFiles_TheTwitters-223x300.jpg 223w, https://archiecomics.com/wp-content/uploads/2022/05/Archie_NewKidFactFiles_TheTwitters-760x1024.jpg 760w, https://archiecomics.com/wp-content/uploads/2022/05/Archie_NewKidFactFiles_TheTwitters-111x150.jpg 111w, https://archiecomics.com/wp-content/uploads/2022/05/Archie_NewKidFactFiles_TheTwitters-768x1034.jpg 768w, https://archiecomics.com/wp-content/uploads/2022/05/Archie_NewKidFactFiles_TheTwitters-1141x1536.jpg 1141w" sizes="(max-width: 1200px) 100vw, 1200px" /></a>
			</dt></dl><dl class='gallery-item'>
			<dt class='gallery-icon portrait'>
				<a href='https://archiecomics.com/meet-the-new-kids/archie_newkidfactfiles_danny/'><img width="1200" height="1616" src="https://archiecomics.com/wp-content/uploads/2022/05/Archie_NewKidFactFiles_Danny.jpg" class="attachment-full size-full" alt="" loading="lazy" srcset="https://archiecomics.com/wp-content/uploads/2022/05/Archie_NewKidFactFiles_Danny.jpg 1200w, https://archiecomics.com/wp-content/uploads/2022/05/Archie_NewKidFactFiles_Danny-223x300.jpg 223w, https://archiecomics.com/wp-content/uploads/2022/05/Archie_NewKidFactFiles_Danny-760x1024.jpg 760w, https://archiecomics.com/wp-content/uploads/2022/05/Archie_NewKidFactFiles_Danny-111x150.jpg 111w, https://archiecomics.com/wp-content/uploads/2022/05/Archie_NewKidFactFiles_Danny-768x1034.jpg 768w, https://archiecomics.com/wp-content/uploads/2022/05/Archie_NewKidFactFiles_Danny-1141x1536.jpg 1141w" sizes="(max-width: 1200px) 100vw, 1200px" /></a>
			</dt></dl>
			<br style='clear: both' />
		</div>

<p>&nbsp;</p>
											</div><!-- .entry-content -->


					<footer class="entry-meta">
						<span class="footer-tags"><i class="crycon-tag crycon-metas" title="Tagged"></i>&nbsp; <a href="https://archiecomics.com/tag/archie-and-friends/" rel="tag">Archie and Friends</a>, <a href="https://archiecomics.com/tag/archie-showcase-digest/" rel="tag">archie showcase digest</a>, <a href="https://archiecomics.com/tag/archives/" rel="tag">archives</a>, <a href="https://archiecomics.com/tag/betty/" rel="tag">betty</a>, <a href="https://archiecomics.com/tag/new-kids/" rel="tag">new kids</a>, <a href="https://archiecomics.com/tag/new-kids-off-the-wall/" rel="tag">new kids off the wall</a>, <a href="https://archiecomics.com/tag/pine-point/" rel="tag">pine point</a>.</span><span class="bl_bookmark"><i class="crycon-bookmark crycon-metas" title=" Bookmark the permalink"></i> <a href="https://archiecomics.com/meet-the-new-kids/" title="Permalink to Meet the New Kids!" rel="bookmark"> Bookmark</a>.</span>											</footer><!-- .entry-meta -->
				</div><!-- #post-## -->

				<div id="nav-below" class="navigation">
					<div class="nav-previous"><a href="https://archiecomics.com/bite-sized-archie-075-buried-in-a-bookstore/" rel="prev"><i class="meta-nav-prev"></i> Bite Sized Archie #075 – Buried in a Bookstore</a></div>
					<div class="nav-next"></div>
				</div><!-- #nav-below -->

				 <div id="comments" class="hideme"> 	<p class="nocomments">Comments are closed.</p>
	</div><!-- #comments -->


						</div><!-- #content -->
			<div id="secondary" class="widget-area sidey" role="complementary">
		
			<ul class="xoxo">
								<li id="text-8" class="widget-container widget_text">			<div class="textwidget"><!-- /26774805/ACP_SideBarTop -->
<div id='div-gpt-ad-1447338701132-1' style='height:400px; width:250px;'>
<script type='text/javascript'>
googletag.cmd.push(function() { googletag.display('div-gpt-ad-1447338701132-1'); });
</script>
</div></div>
		</li>
		<li id="recent-posts-3" class="widget-container widget_recent_entries">
		<h3 class="widget-title">Latest News</h3>
		<ul>
											<li>
					<a href="https://archiecomics.com/meet-the-new-kids/" aria-current="page">Meet the New Kids!</a>
									</li>
											<li>
					<a href="https://archiecomics.com/bite-sized-archie-075-buried-in-a-bookstore/">Bite Sized Archie #075 – Buried in a Bookstore</a>
									</li>
											<li>
					<a href="https://archiecomics.com/new-archie-comics-releases-for-5-11-22/">New Archie Comics Releases for 5/11/22</a>
									</li>
											<li>
					<a href="https://archiecomics.com/bite-sized-archie-074-the-council-of-crowns/">Bite Sized Archie #074 – The Council of Crowns</a>
									</li>
											<li>
					<a href="https://archiecomics.com/new-archie-comics-releases-for-5-4-22/">New Archie Comics Releases for 5/4/22</a>
									</li>
					</ul>

		</li><li id="text-5" class="widget-container widget_text">			<div class="textwidget"><p>
</p>
<!-- /26774805/ACP_SidebarBot -->
<div id='div-gpt-ad-1447338701132-0' style='height:400px; width:250px;'>
<script type='text/javascript'>
googletag.cmd.push(function() { googletag.display('div-gpt-ad-1447338701132-0'); });
</script>
</div>
<p>
</p>
<p style="text-align: center;"><a re_target="blank" target="blank" href="http://www.comicshoplocator.com/Home" rel="noopener"><img alt="" src="http://archiecomics.com/wp-content/uploads/2014/08/comiclocator.png" /></a> <a re_target="blank" target="blank" href="/Blogs/tabid/97/EntryId/463/Where-to-find-Archie-Digital-Comics.aspx" rel="noopener"></a></p></div>
		</li>			</ul>

			
		</div>
		</section><!-- #container -->

	<div style="clear:both;"></div>
	</div> <!-- #forbottom -->


	<footer id="footer" role="contentinfo">
		<div id="colophon">
		
			
			
		</div><!-- #colophon -->

		<div id="footer2">
		
			<div id="site-copyright"><table style="width: 100%">
			<tr>
				<td valign="top" style="width: 25%">
				<h2 style="color:black;font-weight:bold;font-size:14px;font-style:normal">Archie Sites</h2>
<p style="font-size:12px;font-style:normal">
<a href="https://archiecomics.com/nft/?utm_source=ACP&amp;utm_medium=Footer%20Nav&amp;utm_campaign=ACP_Bottom_Menu" target="_blank">Archieverse NFTs</a><br />				
<p style="font-size:12px;font-style:normal">
<a href="https://store.archiecomics.com/?utm_source=ACP&amp;utm_medium=Menu&amp;utm_campaign=BottomMenu" target="_blank">Archie 

Comics Shop</a><br />

				<a href="https://store.archiecomics.com/?utm_source=ACP&amp;utm_medium=Menu&amp;utm_campaign=BottomMenu" target="_blank">Archie 

Subscriptions</a><br />
	
				<a href="http://afterlifewitharchie.com" target="_blank">Afterlife With 

Archie</a><br />
				<a href="http://darkcirclecomics.com" target="_blank">Dark Circle Comics</a><br /></p></td>

				<td valign="top" style="width: 25%">
				<h2 style="color:black;font-weight:bold;font-size:14px;font-style:normal">Comics</h2>
				<p style="font-size:12px;font-style:normal">
                                <a href="../appnews/">Digital Comics</a><br />
				<a href="http://archiecomics.com/redeem/">Redeem</a><br />
<a target="blank" href="https://checkout.subscriptiongenius.com/ArchieComics.com/login.php?s=">Subscriber Login</a><br /></p></td>

				
				<td valign="top" style="width: 25%">
<h2 style="color:black;font-weight:bold;font-size:14px;font-style:normal">Company</h2>
				<p style="font-size:12px;font-style:normal">
				<a href="../about-us/">About</a><br />
				<a href="../news/">News</a><br />
				<a href="../characters/">Characters</a><br />
                                <a href="../newsletter/">Email List</a><br />
				<a href="http://archiecomics.com/about-us/privacy-policy/">Privacy Policy</a><br />
				<a href="../about-us/">Contact</a>
				</p>
				</td>
				
				<td valign="top" style="width: 25%">
<h2 style="color:black;font-weight:bold;font-size:14px;font-style:normal">Social Media</h2>
				<p style="font-size:12px;font-style:normal">
				<a target="_blank" href="https://www.facebook.com/ArchieComicsOfficial?

ref=tn_tnmn">Facebook</a><br />
				<a target="_blank" href="https://twitter.com/archiecomics">Twitter</a><br />
				<a target="_blank" href="https://plus.google.com/u/0/103927090213296657788/posts">Google+</a><br />
				<a target="_blank" href="http://www.youtube.com/user/ArchieComicsOfficial">YouTube</a><br />
		<a target="_blank" href="http://www.goodreads.com/user/show/8914136-archie-

comics">Goodreads</a><br />
		<a target="_blank" href="http://pinterest.com/archiecomics/">Pinterest</a><br />
		<a target="_blank" href="http://archiecomics.tumblr.com/">Tumblr</a><br />
		<a target="_blank" href="http://instagram.com/archiecomics">Instagram</a></p>
				</td>
			</tr>
		</table>

		<p style="color:black;font-size:12px;font-style:normal;text-align:center">Copyright © 2022 

Archie Comic Publications, Inc. All Rights Reserved.</p>
		<p style="font-size:12px;font-style:normal;text-align:center"><a href="http://www.archiecomics.com">www.ArchieComics.com</a></p></div><div class="socials" id="sfooter">
			<a  target="_blank"  href="https://www.facebook.com/ArchieComicsOfficial?ref=tn_tnmn"
			class="socialicons social-Facebook" title="Archie Comics Facebook">
				<img alt="Facebook" src="https://archiecomics.com/wp-content/themes/tempera/images/socials/Facebook.png" />
			</a>
			<a  target="_blank"  href="https://twitter.com/archiecomics"
			class="socialicons social-Twitter" title="Archie Comics Twitter">
				<img alt="Twitter" src="https://archiecomics.com/wp-content/themes/tempera/images/socials/Twitter.png" />
			</a>
			<a  target="_blank"  href="http://www.youtube.com/user/ArchieComicsOfficial"
			class="socialicons social-YouTube" title="Archie Comics YouTube Channel">
				<img alt="YouTube" src="https://archiecomics.com/wp-content/themes/tempera/images/socials/YouTube.png" />
			</a>
			<a  target="_blank"  href="https://plus.google.com/u/0/103927090213296657788/posts"
			class="socialicons social-GooglePlus" title="Archie Comics Google+">
				<img alt="GooglePlus" src="https://archiecomics.com/wp-content/themes/tempera/images/socials/GooglePlus.png" />
			</a>
			<a  target="_blank"  href="http://www.goodreads.com/user/show/8914136-archie-comics"
			class="socialicons social-GoodReads" title="Archie Comics GoodReads">
				<img alt="GoodReads" src="https://archiecomics.com/wp-content/themes/tempera/images/socials/GoodReads.png" />
			</a></div>	<div style="display:block;float:right;text-align:right;padding:5px 20px 5px;text-transform:uppercase;font-size:11px;">
		</div><!-- #site-info -->

			
		</div><!-- #footer2 -->

	</footer><!-- #footer -->

	</div><!-- #main -->
</div><!-- #wrapper -->


<noscript><img height="1" width="1" style="display: none;" src="https://www.facebook.com/tr?id=150910205450480&ev=PageView&noscript=1&cd%5Bpost_category%5D=From+the+Archie+Archives&cd%5Bpage_title%5D=Meet+the+New+Kids%21&cd%5Bpost_type%5D=post&cd%5Bpost_id%5D=27561&cd%5Bplugin%5D=PixelYourSite&cd%5Buser_role%5D=guest&cd%5Bevent_url%5D=archiecomics.com%2Fmeet-the-new-kids%2F" alt="facebook_pixel"></noscript>
<script type='text/javascript' id='tempera-frontend-js-extra'>
/* <![CDATA[ */
var tempera_settings = {"mobile":"1","fitvids":"1"};
/* ]]> */
</script>
<script type='text/javascript' src='https://archiecomics.com/wp-content/themes/tempera/js/frontend.js?ver=1.7.2' id='tempera-frontend-js'></script>
<script type='text/javascript' src='https://archiecomics.com/wp-includes/js/comment-reply.min.js?ver=5.8.3' id='comment-reply-js'></script>
<script type='text/javascript' src='https://archiecomics.com/wp-content/plugins/wp-gallery-custom-links/wp-gallery-custom-links.js?ver=1.1' id='wp-gallery-custom-links-js-js'></script>
<script type='text/javascript' src='https://archiecomics.com/wp-includes/js/wp-embed.min.js?ver=5.8.3' id='wp-embed-js'></script>
	<script type="text/javascript">
	var cryout_global_content_width = 900;
	var cryout_toTop_offset = 1150;
				(function(i,s,o,g,r,a,m){i['GoogleAnalyticsObject']=r;i[r]=i[r]||function(){
  (i[r].q=i[r].q||[]).push(arguments)},i[r].l=1*new Date();a=s.createElement(o),
  m=s.getElementsByTagName(o)[0];a.async=1;a.src=g;m.parentNode.insertBefore(a,m)
  })(window,document,'script','//www.google-analytics.com/analytics.js','ga');

  ga('create', 'UA-45978859-4', 'auto');
  ga('send', 'pageview'); 


var googletag = googletag || {};
googletag.cmd = googletag.cmd || [];
(function() {
var gads = document.createElement('script');
gads.async = true;
gads.type = 'text/javascript';
var useSSL = 'https:' == document.location.protocol;
gads.src = (useSSL ? 'https:' : 'http:') + 
'//www.googletagservices.com/tag/js/gpt.js';
var node = document.getElementsByTagName('script')[0];
node.parentNode.insertBefore(gads, node);
})();


  googletag.cmd.push(function() {
    googletag.defineSlot('/26774805/ACP_SidebarBot', [250, 400], 'div-gpt-ad-1447338701132-0').addService(googletag.pubads());
    googletag.defineSlot('/26774805/ACP_SideBarTop', [250, 400], 'div-gpt-ad-1447338701132-1').addService(googletag.pubads());
    googletag.pubads().enableSingleRequest();
    googletag.enableServices();
  });		</script> 
</body>
</html>
