<!DOCTYPE html>
<html lang="en-US">
<head>
<meta name="viewport" content="width=device-width, user-scalable=no, initial-scale=1.0, minimum-scale=1.0, maximum-scale=1.0">
<meta http-equiv="Content-Type" content="text/html; charset=UTF-8" />
<link rel="profile" href="http://gmpg.org/xfn/11" />
<link rel="pingback" href="http://archiecomics.com/xmlrpc.php" />
<link rel="shortcut icon" href="http://archiecomics.com/wp-content/uploads/2015/10/Favicon.png" /><link rel="apple-touch-icon" href="http://archiecomics.com/wp-content/uploads/2015/10/Favicon.png" /><title>Riverdale Chapter Sixty-Seven: Varsity Blues - Trailer - Archie Comics</title>

<!-- This site is optimized with the Yoast SEO plugin v11.7 - https://yoast.com/wordpress/plugins/seo/ -->
<meta name="description" content="Riverdale Chapter Sixty-Seven: Varsity Blues premieres Wednesday, January 22 at 8/7c on The CW. Stream for free next-day on The CW App."/>
<link rel="canonical" href="http://archiecomics.com/riverdale-chapter-sixty-seven-varsity-blues-trailer/" />
<meta property="og:locale" content="en_US" />
<meta property="og:type" content="article" />
<meta property="og:title" content="Riverdale Chapter Sixty-Seven: Varsity Blues - Trailer - Archie Comics" />
<meta property="og:description" content="Riverdale Chapter Sixty-Seven: Varsity Blues premieres Wednesday, January 22 at 8/7c on The CW. Stream for free next-day on The CW App." />
<meta property="og:url" content="http://archiecomics.com/riverdale-chapter-sixty-seven-varsity-blues-trailer/" />
<meta property="og:site_name" content="Archie Comics" />
<meta property="article:publisher" content="https://www.facebook.com/ArchieComicsOfficial" />
<meta property="article:tag" content="riverdale" />
<meta property="article:tag" content="riverdale season 4" />
<meta property="article:section" content="News" />
<meta property="article:published_time" content="2019-12-12T20:31:50+00:00" />
<meta property="og:image" content="http://archiecomics.com/wp-content/uploads/2019/12/ythumb.jpg" />
<meta property="og:image:width" content="1280" />
<meta property="og:image:height" content="720" />
<meta name="twitter:card" content="summary_large_image" />
<meta name="twitter:description" content="Riverdale Chapter Sixty-Seven: Varsity Blues premieres Wednesday, January 22 at 8/7c on The CW. Stream for free next-day on The CW App." />
<meta name="twitter:title" content="Riverdale Chapter Sixty-Seven: Varsity Blues - Trailer - Archie Comics" />
<meta name="twitter:site" content="@archiecomics" />
<meta name="twitter:image" content="http://archiecomics.com/wp-content/uploads/2019/12/ythumb.jpg" />
<meta name="twitter:creator" content="@archiecomics" />
<script type='application/ld+json' class='yoast-schema-graph yoast-schema-graph--main'>{"@context":"https://schema.org","@graph":[{"@type":"Organization","@id":"http://archiecomics.com/#organization","name":"Archie Comics Publications, Inc.","url":"http://archiecomics.com/","sameAs":["https://www.facebook.com/ArchieComicsOfficial","https://www.instagram.com/archiecomics/","https://www.youtube.com/user/ArchieComicsOfficial","https://www.pinterest.com/archiecomics/","https://twitter.com/archiecomics"],"logo":{"@type":"ImageObject","@id":"http://archiecomics.com/#logo","url":"http://archiecomics.com/wp-content/uploads/2014/08/Archie_Logo-1.jpg","width":750,"height":316,"caption":"Archie Comics Publications, Inc."},"image":{"@id":"http://archiecomics.com/#logo"}},{"@type":"WebSite","@id":"http://archiecomics.com/#website","url":"http://archiecomics.com/","name":"Archie Comics","publisher":{"@id":"http://archiecomics.com/#organization"},"potentialAction":{"@type":"SearchAction","target":"http://archiecomics.com/?s={search_term_string}","query-input":"required name=search_term_string"}},{"@type":"ImageObject","@id":"http://archiecomics.com/riverdale-chapter-sixty-seven-varsity-blues-trailer/#primaryimage","url":"http://archiecomics.com/wp-content/uploads/2019/12/ythumb.jpg","width":1280,"height":720},{"@type":"WebPage","@id":"http://archiecomics.com/riverdale-chapter-sixty-seven-varsity-blues-trailer/#webpage","url":"http://archiecomics.com/riverdale-chapter-sixty-seven-varsity-blues-trailer/","inLanguage":"en-US","name":"Riverdale Chapter Sixty-Seven: Varsity Blues - Trailer - Archie Comics","isPartOf":{"@id":"http://archiecomics.com/#website"},"primaryImageOfPage":{"@id":"http://archiecomics.com/riverdale-chapter-sixty-seven-varsity-blues-trailer/#primaryimage"},"datePublished":"2019-12-12T20:31:50+00:00","dateModified":"2019-12-12T20:31:50+00:00","description":"Riverdale Chapter Sixty-Seven: Varsity Blues premieres Wednesday, January 22 at 8/7c on The CW. Stream for free next-day on The CW App."},{"@type":"Article","@id":"http://archiecomics.com/riverdale-chapter-sixty-seven-varsity-blues-trailer/#article","isPartOf":{"@id":"http://archiecomics.com/riverdale-chapter-sixty-seven-varsity-blues-trailer/#webpage"},"author":{"@id":"http://archiecomics.com/#/schema/person/37b250aa9eabd973c84d6f50468707b8"},"headline":"Riverdale Chapter Sixty-Seven: Varsity Blues &#8211; Trailer","datePublished":"2019-12-12T20:31:50+00:00","dateModified":"2019-12-12T20:31:50+00:00","commentCount":0,"mainEntityOfPage":{"@id":"http://archiecomics.com/riverdale-chapter-sixty-seven-varsity-blues-trailer/#webpage"},"publisher":{"@id":"http://archiecomics.com/#organization"},"image":{"@id":"http://archiecomics.com/riverdale-chapter-sixty-seven-varsity-blues-trailer/#primaryimage"},"keywords":"riverdale,riverdale season 4","articleSection":"News,Riverdale"},{"@type":["Person"],"@id":"http://archiecomics.com/#/schema/person/37b250aa9eabd973c84d6f50468707b8","name":"Ron C.","image":{"@type":"ImageObject","@id":"http://archiecomics.com/#authorlogo","url":"http://2.gravatar.com/avatar/e74404b5ed23e22a98e32e34e257caa6?s=96&d=mm&r=g","caption":"Ron C."},"sameAs":[]}]}</script>
<!-- / Yoast SEO plugin. -->

<script type='text/javascript'>console.log('PixelYourSite Free version 7.1.0');</script>
<link rel='dns-prefetch' href='//s.w.org' />
<link rel="alternate" type="application/rss+xml" title="Archie Comics &raquo; Feed" href="http://archiecomics.com/feed/" />
<link rel="alternate" type="application/rss+xml" title="Archie Comics &raquo; Comments Feed" href="http://archiecomics.com/comments/feed/" />
		<script type="text/javascript">
			window._wpemojiSettings = {"baseUrl":"https:\/\/s.w.org\/images\/core\/emoji\/12.0.0-1\/72x72\/","ext":".png","svgUrl":"https:\/\/s.w.org\/images\/core\/emoji\/12.0.0-1\/svg\/","svgExt":".svg","source":{"concatemoji":"http:\/\/archiecomics.com\/wp-includes\/js\/wp-emoji-release.min.js?ver=5.2.2"}};
			!function(a,b,c){function d(a,b){var c=String.fromCharCode;l.clearRect(0,0,k.width,k.height),l.fillText(c.apply(this,a),0,0);var d=k.toDataURL();l.clearRect(0,0,k.width,k.height),l.fillText(c.apply(this,b),0,0);var e=k.toDataURL();return d===e}function e(a){var b;if(!l||!l.fillText)return!1;switch(l.textBaseline="top",l.font="600 32px Arial",a){case"flag":return!(b=d([55356,56826,55356,56819],[55356,56826,8203,55356,56819]))&&(b=d([55356,57332,56128,56423,56128,56418,56128,56421,56128,56430,56128,56423,56128,56447],[55356,57332,8203,56128,56423,8203,56128,56418,8203,56128,56421,8203,56128,56430,8203,56128,56423,8203,56128,56447]),!b);case"emoji":return b=d([55357,56424,55356,57342,8205,55358,56605,8205,55357,56424,55356,57340],[55357,56424,55356,57342,8203,55358,56605,8203,55357,56424,55356,57340]),!b}return!1}function f(a){var c=b.createElement("script");c.src=a,c.defer=c.type="text/javascript",b.getElementsByTagName("head")[0].appendChild(c)}var g,h,i,j,k=b.createElement("canvas"),l=k.getContext&&k.getContext("2d");for(j=Array("flag","emoji"),c.supports={everything:!0,everythingExceptFlag:!0},i=0;i<j.length;i++)c.supports[j[i]]=e(j[i]),c.supports.everything=c.supports.everything&&c.supports[j[i]],"flag"!==j[i]&&(c.supports.everythingExceptFlag=c.supports.everythingExceptFlag&&c.supports[j[i]]);c.supports.everythingExceptFlag=c.supports.everythingExceptFlag&&!c.supports.flag,c.DOMReady=!1,c.readyCallback=function(){c.DOMReady=!0},c.supports.everything||(h=function(){c.readyCallback()},b.addEventListener?(b.addEventListener("DOMContentLoaded",h,!1),a.addEventListener("load",h,!1)):(a.attachEvent("onload",h),b.attachEvent("onreadystatechange",function(){"complete"===b.readyState&&c.readyCallback()})),g=c.source||{},g.concatemoji?f(g.concatemoji):g.wpemoji&&g.twemoji&&(f(g.twemoji),f(g.wpemoji)))}(window,document,window._wpemojiSettings);
		</script>
		<style type="text/css">
img.wp-smiley,
img.emoji {
	display: inline !important;
	border: none !important;
	box-shadow: none !important;
	height: 1em !important;
	width: 1em !important;
	margin: 0 .07em !important;
	vertical-align: -0.1em !important;
	background: none !important;
	padding: 0 !important;
}
</style>
	<link rel='stylesheet' id='wp-block-library-css'  href='http://archiecomics.com/wp-includes/css/dist/block-library/style.min.css?ver=5.2.2' type='text/css' media='all' />
<link rel='stylesheet' id='tempera-fonts-css'  href='http://archiecomics.com/wp-content/themes/tempera/fonts/fontfaces.css?ver=1.7.1' type='text/css' media='all' />
<link rel='stylesheet' id='tempera-style-css'  href='http://archiecomics.com/wp-content/themes/tempera-nocopyrt/style.css?ver=1.7.1' type='text/css' media='all' />
<script type='text/javascript' src='http://archiecomics.com/wp-includes/js/jquery/jquery.js?ver=1.12.4-wp'></script>
<script type='text/javascript' src='http://archiecomics.com/wp-includes/js/jquery/jquery-migrate.min.js?ver=1.4.1'></script>
<script type='text/javascript' src='http://archiecomics.com/wp-content/plugins/wonderplugin-carousel/engine/wonderplugincarouselskins.js?ver=2.2'></script>
<script type='text/javascript' src='http://archiecomics.com/wp-content/plugins/wonderplugin-carousel/engine/wonderplugincarousel.js?ver=2.2'></script>
<script type='text/javascript' src='http://archiecomics.com/wp-content/plugins/pixelyoursite/dist/scripts/jquery.bind-first-0.2.3.min.js?ver=5.2.2'></script>
<script type='text/javascript' src='http://archiecomics.com/wp-content/plugins/pixelyoursite/dist/scripts/js.cookie-2.1.3.min.js?ver=2.1.3'></script>
<script type='text/javascript'>
/* <![CDATA[ */
var pysOptions = {"staticEvents":{"facebook":{"PageView":[{"params":[],"delay":0,"ids":[]}],"GeneralEvent":[{"params":{"post_type":"post","post_id":"21477","content_name":"Riverdale Chapter Sixty-Seven: Varsity Blues - Trailer","categories":"News, Riverdale","tags":"riverdale, riverdale season 4"},"delay":0,"ids":[]}]}},"facebook":{"pixelIds":["150910205450480"],"advancedMatching":[],"removeMetadata":false,"contentParams":{"post_type":"post","post_id":21477,"content_name":"Riverdale Chapter Sixty-Seven: Varsity Blues - Trailer","categories":"News, Riverdale","tags":"riverdale, riverdale season 4"},"commentEventEnabled":true,"wooVariableAsSimple":false,"downloadEnabled":true,"formEventEnabled":true},"debug":"","siteUrl":"http:\/\/archiecomics.com","ajaxUrl":"http:\/\/archiecomics.com\/wp-admin\/admin-ajax.php","commonEventParams":{"domain":"archiecomics.com","user_roles":"guest","plugin":"PixelYourSite"},"commentEventEnabled":"1","downloadEventEnabled":"1","downloadExtensions":["doc","exe","js","pdf","ppt","tgz","zip","xls"],"formEventEnabled":"1","gdpr":{"ajax_enabled":false,"all_disabled_by_api":false,"facebook_disabled_by_api":false,"analytics_disabled_by_api":false,"google_ads_disabled_by_api":false,"pinterest_disabled_by_api":false,"bing_disabled_by_api":false,"facebook_prior_consent_enabled":false,"analytics_prior_consent_enabled":true,"google_ads_prior_consent_enabled":null,"pinterest_prior_consent_enabled":true,"bing_prior_consent_enabled":true,"cookiebot_integration_enabled":false,"cookiebot_facebook_consent_category":"marketing","cookiebot_analytics_consent_category":"statistics","cookiebot_google_ads_consent_category":null,"cookiebot_pinterest_consent_category":"marketing","cookiebot_bing_consent_category":"marketing","ginger_integration_enabled":false,"cookie_notice_integration_enabled":false,"cookie_law_info_integration_enabled":false},"woo":{"enabled":false,"addToCartOnButtonEnabled":false,"addToCartOnButtonValueEnabled":false,"addToCartOnButtonValueOption":"price","removeFromCartEnabled":true,"removeFromCartSelector":".cart .product-remove .remove"},"edd":{"enabled":false,"addToCartOnButtonEnabled":false,"addToCartOnButtonValueEnabled":false,"addToCartOnButtonValueOption":"price","removeFromCartEnabled":true}};
/* ]]> */
</script>
<script type='text/javascript' src='http://archiecomics.com/wp-content/plugins/pixelyoursite/dist/scripts/public.js?ver=7.1.0'></script>
<link rel='https://api.w.org/' href='http://archiecomics.com/wp-json/' />
<link rel="EditURI" type="application/rsd+xml" title="RSD" href="http://archiecomics.com/xmlrpc.php?rsd" />
<link rel="wlwmanifest" type="application/wlwmanifest+xml" href="http://archiecomics.com/wp-includes/wlwmanifest.xml" /> 
<link rel='shortlink' href='http://archiecomics.com/?p=21477' />
<link rel="alternate" type="application/json+oembed" href="http://archiecomics.com/wp-json/oembed/1.0/embed?url=http%3A%2F%2Farchiecomics.com%2Friverdale-chapter-sixty-seven-varsity-blues-trailer%2F" />
<link rel="alternate" type="text/xml+oembed" href="http://archiecomics.com/wp-json/oembed/1.0/embed?url=http%3A%2F%2Farchiecomics.com%2Friverdale-chapter-sixty-seven-varsity-blues-trailer%2F&#038;format=xml" />
<script type="text/javascript">
(function(url){
	if(/(?:Chrome\/26\.0\.1410\.63 Safari\/537\.31|WordfenceTestMonBot)/.test(navigator.userAgent)){ return; }
	var addEvent = function(evt, handler) {
		if (window.addEventListener) {
			document.addEventListener(evt, handler, false);
		} else if (window.attachEvent) {
			document.attachEvent('on' + evt, handler);
		}
	};
	var removeEvent = function(evt, handler) {
		if (window.removeEventListener) {
			document.removeEventListener(evt, handler, false);
		} else if (window.detachEvent) {
			document.detachEvent('on' + evt, handler);
		}
	};
	var evts = 'contextmenu dblclick drag dragend dragenter dragleave dragover dragstart drop keydown keypress keyup mousedown mousemove mouseout mouseover mouseup mousewheel scroll'.split(' ');
	var logHuman = function() {
		if (window.wfLogHumanRan) { return; }
		window.wfLogHumanRan = true;
		var wfscr = document.createElement('script');
		wfscr.type = 'text/javascript';
		wfscr.async = true;
		wfscr.src = url + '&r=' + Math.random();
		(document.getElementsByTagName('head')[0]||document.getElementsByTagName('body')[0]).appendChild(wfscr);
		for (var i = 0; i < evts.length; i++) {
			removeEvent(evts[i], logHuman);
		}
	};
	for (var i = 0; i < evts.length; i++) {
		addEvent(evts[i], logHuman);
	}
})('//archiecomics.com/?wordfence_lh=1&hid=6684232B2866B396542B175E65EC7777');
</script><style type="text/css" id="custom-background-css">
body.custom-background { background-color: #ffffff; background-image: url("http://archiecomics.com/wp-content/uploads/2014/09/Background-2.jpg"); background-position: center top; background-size: auto; background-repeat: no-repeat; background-attachment: fixed; }
</style>
	<style type="text/css">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</style> 
<style type="text/css">/* Tempera Custom CSS */ 
#main {
	clear: both;
	padding: 0px ;
	margin-top: 0px; 
} 
#access {
display: block;
float: left;
margin: -4px auto 0;
width: 100%;
} 

#branding {
display: block;
float: left;
clear: both;
padding: 0 0 0 0;
position: relative;
overflow: hidden;
margin-top: 5px; 
width: 100%;
}</style>
<link rel='stylesheet' id='tempera-style-mobile'  href='http://archiecomics.com/wp-content/themes/tempera/styles/style-mobile.css?ver=1.7.1' type='text/css' media='all' />	<!--[if lt IE 9]>
	<script>
	document.createElement('header');
	document.createElement('nav');
	document.createElement('section');
	document.createElement('article');
	document.createElement('aside');
	document.createElement('footer');
	</script>
	<![endif]-->
	</head>
<body class="post-template-default single single-post postid-21477 single-format-video custom-background tempera-image-none caption-dark tempera-menu-left">


<div id="wrapper" class="hfeed">
<div id="topbar" ><div id="topbar-inner"> <div class="socials" id="sheader">
			<a  target="_blank"  href="https://www.facebook.com/ArchieComicsOfficial?ref=tn_tnmn"
			class="socialicons social-Facebook" title="Archie Comics Facebook">
				<img alt="Facebook" src="http://archiecomics.com/wp-content/themes/tempera/images/socials/Facebook.png" />
			</a>
			<a  target="_blank"  href="https://twitter.com/archiecomics"
			class="socialicons social-Twitter" title="Archie Comics Twitter">
				<img alt="Twitter" src="http://archiecomics.com/wp-content/themes/tempera/images/socials/Twitter.png" />
			</a>
			<a  target="_blank"  href="http://www.youtube.com/user/ArchieComicsOfficial"
			class="socialicons social-YouTube" title="Archie Comics YouTube Channel">
				<img alt="YouTube" src="http://archiecomics.com/wp-content/themes/tempera/images/socials/YouTube.png" />
			</a>
			<a  target="_blank"  href="https://plus.google.com/u/0/103927090213296657788/posts"
			class="socialicons social-GooglePlus" title="Archie Comics Google+">
				<img alt="GooglePlus" src="http://archiecomics.com/wp-content/themes/tempera/images/socials/GooglePlus.png" />
			</a>
			<a  target="_blank"  href="http://www.goodreads.com/user/show/8914136-archie-comics"
			class="socialicons social-GoodReads" title="Archie Comics GoodReads">
				<img alt="GoodReads" src="http://archiecomics.com/wp-content/themes/tempera/images/socials/GoodReads.png" />
			</a></div> </div></div>

<div id="header-full">
	<header id="header">
		<div id="masthead">
			<div id="branding" role="banner" >
				<img id="bg_image" alt="" title="" src="http://archiecomics.com/wp-content/uploads/2014/09/cropped-archie_comics_header.png"  />	<div id="header-container">
	<a href="http://archiecomics.com/" id="linky"></a></div>						<div id="header-widget-area">
			<ul class="yoyo">
				<li id="search-3" class="widget-container widget_search">
<form role="search" method="get" class="searchform" action="http://archiecomics.com/">
	<label>
		<span class="screen-reader-text">Search for:</span>
		<input type="search" class="s" placeholder="Search" value="" name="s" />
	</label>
	<button type="submit" class="searchsubmit"><span class="screen-reader-text">Search</span><i class="crycon-search"></i></button>
</form>
</li>			</ul>
		</div>
					<div style="clear:both;"></div>
			</div><!-- #branding -->
			<a id="nav-toggle"><span>&nbsp;</span></a>
			<nav id="access" role="navigation">
					<div class="skip-link screen-reader-text"><a href="#content" title="Skip to content">
		Skip to content	</a></div>
	<div class="menu"><ul id="prime_nav" class="menu"><li id="menu-item-6" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-home menu-item-6"><a href="http://archiecomics.com/"><span>Home</span></a></li>
<li id="menu-item-939" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-939"><a href="http://archiecomics.com/news/"><span>News</span></a></li>
<li id="menu-item-924" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-has-children menu-item-924"><a target="_blank" rel="noopener noreferrer" href="https://store.archiecomics.com/?utm_source=ACP&#038;utm_medium=Menu&#038;utm_campaign=TopMenu"><span>Shop</span></a>
<ul class="sub-menu">
	<li id="menu-item-7961" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-7961"><a target="_blank" rel="noopener noreferrer" href="https://store.archiecomics.com/?utm_source=ACP&#038;utm_medium=Menu&#038;utm_campaign=TopMenu"><span>Archie Comics Shop</span></a></li>
	<li id="menu-item-6625" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-6625"><a target="_blank" rel="noopener noreferrer" href="https://store.archiecomics.com/series"><span>Archie Subscriptions</span></a></li>
</ul>
</li>
<li id="menu-item-51" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-has-children menu-item-51"><a href="http://archiecomics.com/characters/"><span>Characters</span></a>
<ul class="sub-menu">
	<li id="menu-item-6285" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-6285"><a href="http://archiecomics.com/characters/"><span>Traditional Archie</span></a></li>
	<li id="menu-item-6284" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-6284"><a href="http://archiecomics.com/characters/new-riverdale/"><span>New Archie</span></a></li>
	<li id="menu-item-6590" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-6590"><a href="http://archiecomics.com/characters/riverdale-on-the-cw/"><span>Riverdale on the CW</span></a></li>
</ul>
</li>
<li id="menu-item-927" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-has-children menu-item-927"><a href="http://archiecomics.com/digital-comics/"><span>Digital Comics</span></a>
<ul class="sub-menu">
	<li id="menu-item-5223" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-5223"><a href="http://archiecomics.com/digital-comics/"><span>Archie Digital</span></a></li>
	<li id="menu-item-5216" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-5216"><a href="http://archiecomics.com/digital-comics/archie-unlimited/"><span>Archie Unlimited</span></a></li>
	<li id="menu-item-5215" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-5215"><a href="http://archiecomics.com/digital-comics/frequently-asked-questions/"><span>Frequently Asked Questions</span></a></li>
</ul>
</li>
<li id="menu-item-932" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-has-children menu-item-932"><a href="http://archiecomics.com/about-us/"><span>About Us</span></a>
<ul class="sub-menu">
	<li id="menu-item-928" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-928"><a href="http://archiecomics.com/about-us/"><span>Contact</span></a></li>
	<li id="menu-item-933" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-933"><a href="http://archiecomics.com/about-us/privacy-policy/"><span>Privacy Policy</span></a></li>
</ul>
</li>
<li class='menu-main-search'> 
<form role="search" method="get" class="searchform" action="http://archiecomics.com/">
	<label>
		<span class="screen-reader-text">Search for:</span>
		<input type="search" class="s" placeholder="Search" value="" name="s" />
	</label>
	<button type="submit" class="searchsubmit"><span class="screen-reader-text">Search</span><i class="crycon-search"></i></button>
</form>
 </li></ul></div>			</nav><!-- #access -->
		</div><!-- #masthead -->
	</header><!-- #header -->
</div><!-- #header-full -->

<div style="clear:both;height:0;"> </div>

<div id="main" class="main">
		<div id="toTop"><i class="crycon-back2top"></i> </div>	<div  id="forbottom" >
		
		<div style="clear:both;"> </div>

		
		<section id="container" class="two-columns-right">
			<div id="content" role="main">
			<div class="breadcrumbs"><a href="http://archiecomics.com"><i class="crycon-homebread"></i><span class="screen-reader-text">Home</span></a><i class="crycon-angle-right"></i> <a href="http://archiecomics.com/category/news/">News</a> <i class="crycon-angle-right"></i> <span class="current">Riverdale Chapter Sixty-Seven: Varsity Blues &#8211; Trailer</span></div><!--breadcrumbs-->

				<div id="post-21477" class="post-21477 post type-post status-publish format-video has-post-thumbnail hentry category-news category-riverdale tag-riverdale tag-riverdale-season-4 post_format-post-format-video">
					<h1 class="entry-title">Riverdale Chapter Sixty-Seven: Varsity Blues &#8211; Trailer</h1>
										<div class="entry-meta">
						<span class="author vcard" ><i class="crycon-author crycon-metas" title="Author "></i>
					<a class="url fn n" rel="author" href="http://archiecomics.com/author/ronc/" title="View all posts by Ron C.">Ron C.</a></span><span><i class="crycon-time crycon-metas" title="Date"></i>
				<time class="onDate date published" datetime="2019-12-12T20:31:50+00:00">
					<a href="http://archiecomics.com/riverdale-chapter-sixty-seven-varsity-blues-trailer/" rel="bookmark">December 12, 2019</a>
				</time>
			   </span><time class="updated"  datetime="2019-12-12T20:31:50+00:00">December 12, 2019</time><span class="bl_categ"><i class="crycon-folder-open crycon-metas" title="Categories"></i><a href="http://archiecomics.com/category/news/" rel="tag">News</a>, <a href="http://archiecomics.com/category/riverdale/" rel="tag">Riverdale</a></span> 					</div><!-- .entry-meta -->

					<div class="entry-content">
						<p><iframe title="Riverdale | Season 4 Episode 10 | Chapter Sixty-Seven: Varsity Blues Promo | The CW" width="900" height="506" src="https://www.youtube.com/embed/RUQiEdUSM8w?feature=oembed" frameborder="0" allow="accelerometer; autoplay; encrypted-media; gyroscope; picture-in-picture" allowfullscreen></iframe></p>
<p>Riverdale Chapter Sixty-Seven: Varsity Blues premieres Wednesday, January 22 at 8/7c on The CW. Stream for free next-day on The CW App.</p>
<p><span id="more-21477"></span></p>
<p>Read the Riverdale tie-in comics on the <span style="color: #3366ff;"><a style="color: #3366ff;" href="http://bit.ly/ArchieDigital">Archie Comics App</a></span> or <span style="color: #3366ff;"><a style="color: #3366ff;" href="https://www.comixology.com/Riverdale/comics-series/84667">ComiXology</a></span>. Get the <span style="color: #3366ff;"><a style="color: #3366ff;" href="https://store.archiecomics.com/collections/riverdale">graphic novels from the Archie Comics Shop</a></span>.</p>
<p>For more information about ‘RIVERDALE’ and everything Archie Comics, follow us on <span style="color: #3366ff;"><a style="color: #3366ff;" href="http://twitter.com/archiecomics" target="_blank" rel="noopener noreferrer" data-cke-saved-href="http://twitter.com/archiecomics"><u>Twitter</u></a></span>, <span style="color: #3366ff;"><a style="color: #3366ff;" href="http://facebook.com/archiecomicsofficial" target="_blank" rel="noopener noreferrer" data-cke-saved-href="http://facebook.com/archiecomicsofficial"><u>Facebook</u></a></span>, and <span style="color: #3366ff;"><a style="color: #3366ff;" href="http://instagram.com/archiecomics" target="_blank" rel="noopener noreferrer" data-cke-saved-href="http://instagram.com/archiecomics"><u>Instagram</u></a></span>.</p>
<p>Stream episodes of RIVERDALE on <span style="color: #3366ff;"><a style="color: #3366ff;" href="http://on.cwtv.com/2kLTPOG" data-cke-saved-href="http://on.cwtv.com/2kLTPOG">The CW App</a> </span>and Netflix.</p>
<p>&nbsp;</p>
											</div><!-- .entry-content -->


					<footer class="entry-meta">
						<span class="footer-tags"><i class="crycon-tag crycon-metas" title="Tagged"></i>&nbsp; <a href="http://archiecomics.com/tag/riverdale/" rel="tag">riverdale</a>, <a href="http://archiecomics.com/tag/riverdale-season-4/" rel="tag">riverdale season 4</a>.</span><span class="bl_bookmark"><i class="crycon-bookmark crycon-metas" title=" Bookmark the permalink"></i> <a href="http://archiecomics.com/riverdale-chapter-sixty-seven-varsity-blues-trailer/" title="Permalink to Riverdale Chapter Sixty-Seven: Varsity Blues &#8211; Trailer" rel="bookmark"> Bookmark</a>.</span>											</footer><!-- .entry-meta -->
				</div><!-- #post-## -->

				<div id="nav-below" class="navigation">
					<div class="nav-previous"><a href="http://archiecomics.com/katy-keene-season-trailer/" rel="prev"><i class="meta-nav-prev"></i> Katy Keene &#8211; Season Trailer</a></div>
					<div class="nav-next"><a href="http://archiecomics.com/newly-digitized-classic-comics-12-11-19/" rel="next">Newly Digitized Classic Comics – 12/11/19 <i class="meta-nav-next"></i></a></div>
				</div><!-- #nav-below -->

				 <div id="comments" class="hideme"> 	<p class="nocomments">Comments are closed.</p>
	</div><!-- #comments -->


						</div><!-- #content -->
			<div id="secondary" class="widget-area sidey" role="complementary">
		
			<ul class="xoxo">
								<li id="text-8" class="widget-container widget_text">			<div class="textwidget"><!-- /26774805/ACP_SideBarTop -->
<div id='div-gpt-ad-1447338701132-1' style='height:400px; width:250px;'>
<script type='text/javascript'>
googletag.cmd.push(function() { googletag.display('div-gpt-ad-1447338701132-1'); });
</script>
</div></div>
		</li>		<li id="recent-posts-3" class="widget-container widget_recent_entries">		<h3 class="widget-title">Latest News</h3>		<ul>
											<li>
					<a href="http://archiecomics.com/newly-digitized-classic-comics-12-11-19/">Newly Digitized Classic Comics – 12/11/19</a>
									</li>
											<li>
					<a href="http://archiecomics.com/riverdale-chapter-sixty-seven-varsity-blues-trailer/">Riverdale Chapter Sixty-Seven: Varsity Blues &#8211; Trailer</a>
									</li>
											<li>
					<a href="http://archiecomics.com/katy-keene-season-trailer/">Katy Keene &#8211; Season Trailer</a>
									</li>
											<li>
					<a href="http://archiecomics.com/new-releases-for-12-11-19/">New Releases for 12/11/19</a>
									</li>
											<li>
					<a href="http://archiecomics.com/new-to-archie-unlimited-12-9-19/">New to Archie Unlimited – 12/9/19</a>
									</li>
					</ul>
		</li><li id="text-5" class="widget-container widget_text">			<div class="textwidget"><p>
</p>
<!-- /26774805/ACP_SidebarBot -->
<div id='div-gpt-ad-1447338701132-0' style='height:400px; width:250px;'>
<script type='text/javascript'>
googletag.cmd.push(function() { googletag.display('div-gpt-ad-1447338701132-0'); });
</script>
</div>
<p>
</p>
<p style="text-align: center;"><a re_target="blank" target="blank" href="http://www.comicshoplocator.com/Home" rel="noopener noreferrer"><img alt="" src="http://archiecomics.com/wp-content/uploads/2014/08/comiclocator.png" /></a> <a re_target="blank" target="blank" href="/Blogs/tabid/97/EntryId/463/Where-to-find-Archie-Digital-Comics.aspx" rel="noopener noreferrer"></a></p></div>
		</li>			</ul>

			
		</div>
		</section><!-- #container -->

	<div style="clear:both;"></div>
	</div> <!-- #forbottom -->


	<footer id="footer" role="contentinfo">
		<div id="colophon">
		
			
			
		</div><!-- #colophon -->

		<div id="footer2">
		
			<div id="site-copyright"><table style="width: 100%">
			<tr>
				<td valign="top" style="width: 25%">
				<h2 style="color:black;font-weight:bold;font-size:14px;font-style:normal">Archie Sites</h2>
				<p style="font-size:12px;font-style:normal">
<a href="https://store.archiecomics.com/?utm_source=ACP&amp;utm_medium=Menu&amp;utm_campaign=BottomMenu" target="_blank">Archie 

Comics Shop</a><br />

				<a href="https://store.archiecomics.com/?utm_source=ACP&amp;utm_medium=Menu&amp;utm_campaign=BottomMenu" target="_blank">Archie 

Subscriptions</a><br />
	
				<a href="http://afterlifewitharchie.com" target="_blank">Afterlife With 

Archie</a><br />
				<a href="http://darkcirclecomics.com" target="_blank">Dark Circle Comics</a><br /></p></td>

				<td valign="top" style="width: 25%">
				<h2 style="color:black;font-weight:bold;font-size:14px;font-style:normal">Comics</h2>
				<p style="font-size:12px;font-style:normal">
                                <a href="../digital-comics/">Digital Comics</a><br />
				<a href="http://archiecomics.com/redeem/">Redeem</a><br />
<a target="blank" href="https://checkout.subscriptiongenius.com/ArchieComics.com/login.php?s=">Subscriber Login</a><br /></p></td>

				
				<td valign="top" style="width: 25%">
<h2 style="color:black;font-weight:bold;font-size:14px;font-style:normal">Company</h2>
				<p style="font-size:12px;font-style:normal">
				<a href="../about-us/">About</a><br />
				<a href="../news/">News</a><br />
				<a href="../characters/">Characters</a><br />
                                <a href="../newsletter/">Email List</a><br />
				<a href="http://archiecomics.com/about-us/privacy-policy/">Privacy Policy</a><br />
				<a href="../about-us/">Contact</a>
				</p>
				</td>
				
				<td valign="top" style="width: 25%">
<h2 style="color:black;font-weight:bold;font-size:14px;font-style:normal">Social Media</h2>
				<p style="font-size:12px;font-style:normal">
				<a target="_blank" href="https://www.facebook.com/ArchieComicsOfficial?

ref=tn_tnmn">Facebook</a><br />
				<a target="_blank" href="https://twitter.com/archiecomics">Twitter</a><br />
				<a target="_blank" href="https://plus.google.com/u/0/103927090213296657788/posts">Google+</a><br />
				<a target="_blank" href="http://www.youtube.com/user/ArchieComicsOfficial">YouTube</a><br />
		<a target="_blank" href="http://www.goodreads.com/user/show/8914136-archie-

comics">Goodreads</a><br />
		<a target="_blank" href="http://pinterest.com/archiecomics/">Pinterest</a><br />
		<a target="_blank" href="http://archiecomics.tumblr.com/">Tumblr</a><br />
		<a target="_blank" href="http://instagram.com/archiecomics">Instagram</a></p>
				</td>
			</tr>
		</table>

		<p style="color:black;font-size:12px;font-style:normal;text-align:center">Copyright © 2017 

Archie Comic Publications, Inc. All Rights Reserved.</p>
		<p style="font-size:12px;font-style:normal;text-align:center"><a href="http://www.archiecomics.com">www.ArchieComics.com</a></p></div><div class="socials" id="sfooter">
			<a  target="_blank"  href="https://www.facebook.com/ArchieComicsOfficial?ref=tn_tnmn"
			class="socialicons social-Facebook" title="Archie Comics Facebook">
				<img alt="Facebook" src="http://archiecomics.com/wp-content/themes/tempera/images/socials/Facebook.png" />
			</a>
			<a  target="_blank"  href="https://twitter.com/archiecomics"
			class="socialicons social-Twitter" title="Archie Comics Twitter">
				<img alt="Twitter" src="http://archiecomics.com/wp-content/themes/tempera/images/socials/Twitter.png" />
			</a>
			<a  target="_blank"  href="http://www.youtube.com/user/ArchieComicsOfficial"
			class="socialicons social-YouTube" title="Archie Comics YouTube Channel">
				<img alt="YouTube" src="http://archiecomics.com/wp-content/themes/tempera/images/socials/YouTube.png" />
			</a>
			<a  target="_blank"  href="https://plus.google.com/u/0/103927090213296657788/posts"
			class="socialicons social-GooglePlus" title="Archie Comics Google+">
				<img alt="GooglePlus" src="http://archiecomics.com/wp-content/themes/tempera/images/socials/GooglePlus.png" />
			</a>
			<a  target="_blank"  href="http://www.goodreads.com/user/show/8914136-archie-comics"
			class="socialicons social-GoodReads" title="Archie Comics GoodReads">
				<img alt="GoodReads" src="http://archiecomics.com/wp-content/themes/tempera/images/socials/GoodReads.png" />
			</a></div>	<div style="display:block;float:right;text-align:right;padding:5px 20px 5px;text-transform:uppercase;font-size:11px;">
		</div><!-- #site-info -->

			
		</div><!-- #footer2 -->

	</footer><!-- #footer -->

	</div><!-- #main -->
</div><!-- #wrapper -->


<div id="wondercarousellightbox_options" data-skinsfoldername=""  data-jsfolder="http://archiecomics.com/wp-content/plugins/wonderplugin-carousel/engine/" style="display:none;"></div><noscript><img height="1" width="1" style="display: none;" src="https://www.facebook.com/tr?id=150910205450480&ev=PageView&noscript=1" alt="facebook_pixel"></noscript>
<noscript><img height="1" width="1" style="display: none;" src="https://www.facebook.com/tr?id=150910205450480&ev=GeneralEvent&noscript=1&cd[post_type]=post&cd[post_id]=21477&cd[content_name]=Riverdale+Chapter+Sixty-Seven%3A+Varsity+Blues+-+Trailer&cd[categories]=News%2C+Riverdale&cd[tags]=riverdale%2C+riverdale+season+4" alt="facebook_pixel"></noscript>
<script type='text/javascript'>
/* <![CDATA[ */
var tempera_settings = {"mobile":"1","fitvids":"1"};
/* ]]> */
</script>
<script type='text/javascript' src='http://archiecomics.com/wp-content/themes/tempera/js/frontend.js?ver=1.7.1'></script>
<script type='text/javascript' src='http://archiecomics.com/wp-includes/js/comment-reply.min.js?ver=5.2.2'></script>
<script type='text/javascript' src='http://archiecomics.com/wp-content/plugins/wp-gallery-custom-links/wp-gallery-custom-links.js?ver=1.1'></script>
<script type='text/javascript' src='http://archiecomics.com/wp-includes/js/wp-embed.min.js?ver=5.2.2'></script>
	<script type="text/javascript">
	var cryout_global_content_width = 900;
	var cryout_toTop_offset = 1150;
				(function(i,s,o,g,r,a,m){i['GoogleAnalyticsObject']=r;i[r]=i[r]||function(){
  (i[r].q=i[r].q||[]).push(arguments)},i[r].l=1*new Date();a=s.createElement(o),
  m=s.getElementsByTagName(o)[0];a.async=1;a.src=g;m.parentNode.insertBefore(a,m)
  })(window,document,'script','//www.google-analytics.com/analytics.js','ga');

  ga('create', 'UA-45978859-4', 'auto');
  ga('send', 'pageview'); 


var googletag = googletag || {};
googletag.cmd = googletag.cmd || [];
(function() {
var gads = document.createElement('script');
gads.async = true;
gads.type = 'text/javascript';
var useSSL = 'https:' == document.location.protocol;
gads.src = (useSSL ? 'https:' : 'http:') + 
'//www.googletagservices.com/tag/js/gpt.js';
var node = document.getElementsByTagName('script')[0];
node.parentNode.insertBefore(gads, node);
})();


  googletag.cmd.push(function() {
    googletag.defineSlot('/26774805/ACP_SidebarBot', [250, 400], 'div-gpt-ad-1447338701132-0').addService(googletag.pubads());
    googletag.defineSlot('/26774805/ACP_SideBarTop', [250, 400], 'div-gpt-ad-1447338701132-1').addService(googletag.pubads());
    googletag.pubads().enableSingleRequest();
    googletag.enableServices();
  });		</script> 
</body>
</html>
