<!DOCTYPE html>
<html lang="en-US">
<head>
<meta name="viewport" content="width=device-width, user-scalable=no, initial-scale=1.0, minimum-scale=1.0, maximum-scale=1.0">
<meta http-equiv="Content-Type" content="text/html; charset=UTF-8" />
<link rel="profile" href="http://gmpg.org/xfn/11" />
<link rel="pingback" href="https://archiecomics.com/xmlrpc.php" />
<meta name='robots' content='index, follow, max-image-preview:large, max-snippet:-1, max-video-preview:-1' />

	<!-- This site is optimized with the Yoast SEO plugin v19.2 - https://yoast.com/wordpress/plugins/seo/ -->
	<title>New Archie Comics Releases for 7/13/22 - Archie Comics</title>
	<link rel="canonical" href="https://archiecomics.com/new-archie-comics-releases-for-7-13-22/" />
	<meta property="og:locale" content="en_US" />
	<meta property="og:type" content="article" />
	<meta property="og:title" content="New Archie Comics Releases for 7/13/22 - Archie Comics" />
	<meta property="og:description" content="Stacy Banks makes her big debut in today&#8217;s batch of new releases! Read on for a look inside the new Archie comics hitting stores 7/13/22: To purchase Archie titles in print, visit the Archie Comics Online Store or find a comic shop near you using the Comic Shop Locator service. &nbsp;… Continue reading" />
	<meta property="og:url" content="https://archiecomics.com/new-archie-comics-releases-for-7-13-22/" />
	<meta property="og:site_name" content="Archie Comics" />
	<meta property="article:publisher" content="https://www.facebook.com/ArchieComicsOfficial" />
	<meta property="article:published_time" content="2022-07-13T13:00:12+00:00" />
	<meta property="article:modified_time" content="2022-07-07T21:48:17+00:00" />
	<meta property="og:image" content="https://archiecomics.com/wp-content/uploads/2022/07/BettyAndVeronicaFriendsForever_SummerSurfParty_01-13.jpg" />
	<meta property="og:image:width" content="975" />
	<meta property="og:image:height" content="404" />
	<meta property="og:image:type" content="image/jpeg" />
	<meta name="author" content="Jesse Post" />
	<meta name="twitter:card" content="summary_large_image" />
	<meta name="twitter:creator" content="@archiecomics" />
	<meta name="twitter:site" content="@archiecomics" />
	<meta name="twitter:label1" content="Written by" />
	<meta name="twitter:data1" content="Jesse Post" />
	<meta name="twitter:label2" content="Est. reading time" />
	<meta name="twitter:data2" content="4 minutes" />
	<script type="application/ld+json" class="yoast-schema-graph">{"@context":"https://schema.org","@graph":[{"@type":"Organization","@id":"https://archiecomics.com/#organization","name":"Archie Comics Publications, Inc.","url":"https://archiecomics.com/","sameAs":["https://www.instagram.com/archiecomics/","https://www.pinterest.com/archiecomics/","https://www.youtube.com/user/ArchieComicsOfficial","https://www.facebook.com/ArchieComicsOfficial","https://twitter.com/archiecomics"],"logo":{"@type":"ImageObject","inLanguage":"en-US","@id":"https://archiecomics.com/#/schema/logo/image/","url":"https://archiecomics.com/wp-content/uploads/2014/08/Archie_Logo-1.jpg","contentUrl":"https://archiecomics.com/wp-content/uploads/2014/08/Archie_Logo-1.jpg","width":750,"height":316,"caption":"Archie Comics Publications, Inc."},"image":{"@id":"https://archiecomics.com/#/schema/logo/image/"}},{"@type":"WebSite","@id":"https://archiecomics.com/#website","url":"https://archiecomics.com/","name":"Archie Comics","description":"","publisher":{"@id":"https://archiecomics.com/#organization"},"potentialAction":[{"@type":"SearchAction","target":{"@type":"EntryPoint","urlTemplate":"https://archiecomics.com/?s={search_term_string}"},"query-input":"required name=search_term_string"}],"inLanguage":"en-US"},{"@type":"ImageObject","inLanguage":"en-US","@id":"https://archiecomics.com/new-archie-comics-releases-for-7-13-22/#primaryimage","url":"https://archiecomics.com/wp-content/uploads/2022/07/BettyAndVeronicaFriendsForever_SummerSurfParty_01-13.jpg","contentUrl":"https://archiecomics.com/wp-content/uploads/2022/07/BettyAndVeronicaFriendsForever_SummerSurfParty_01-13.jpg","width":975,"height":404},{"@type":"WebPage","@id":"https://archiecomics.com/new-archie-comics-releases-for-7-13-22/#webpage","url":"https://archiecomics.com/new-archie-comics-releases-for-7-13-22/","name":"New Archie Comics Releases for 7/13/22 - Archie Comics","isPartOf":{"@id":"https://archiecomics.com/#website"},"primaryImageOfPage":{"@id":"https://archiecomics.com/new-archie-comics-releases-for-7-13-22/#primaryimage"},"datePublished":"2022-07-13T13:00:12+00:00","dateModified":"2022-07-07T21:48:17+00:00","breadcrumb":{"@id":"https://archiecomics.com/new-archie-comics-releases-for-7-13-22/#breadcrumb"},"inLanguage":"en-US","potentialAction":[{"@type":"ReadAction","target":["https://archiecomics.com/new-archie-comics-releases-for-7-13-22/"]}]},{"@type":"BreadcrumbList","@id":"https://archiecomics.com/new-archie-comics-releases-for-7-13-22/#breadcrumb","itemListElement":[{"@type":"ListItem","position":1,"name":"Home","item":"https://archiecomics.com/"},{"@type":"ListItem","position":2,"name":"New Archie Comics Releases for 7/13/22"}]},{"@type":"Article","@id":"https://archiecomics.com/new-archie-comics-releases-for-7-13-22/#article","isPartOf":{"@id":"https://archiecomics.com/new-archie-comics-releases-for-7-13-22/#webpage"},"author":{"name":"Jesse Post","@id":"https://archiecomics.com/#/schema/person/0c9d5a47ba5d680d6d911712d7ee2042"},"headline":"New Archie Comics Releases for 7/13/22","datePublished":"2022-07-13T13:00:12+00:00","dateModified":"2022-07-07T21:48:17+00:00","mainEntityOfPage":{"@id":"https://archiecomics.com/new-archie-comics-releases-for-7-13-22/#webpage"},"wordCount":528,"publisher":{"@id":"https://archiecomics.com/#organization"},"image":{"@id":"https://archiecomics.com/new-archie-comics-releases-for-7-13-22/#primaryimage"},"thumbnailUrl":"https://archiecomics.com/wp-content/uploads/2022/07/BettyAndVeronicaFriendsForever_SummerSurfParty_01-13.jpg","keywords":["betty and veronica","betty and veronica digest","betty and veronica friends forever","big ethel energy","first looks","josie","jughead","new releases","on sale today","preview","previews","Stacy Banks","summer","summer surf party","world of archie digest","young dr. masters"],"articleSection":["Free Comic","News","On Sale Today"],"inLanguage":"en-US"},{"@type":"Person","@id":"https://archiecomics.com/#/schema/person/0c9d5a47ba5d680d6d911712d7ee2042","name":"Jesse Post","image":{"@type":"ImageObject","inLanguage":"en-US","@id":"https://archiecomics.com/#/schema/person/image/","url":"https://secure.gravatar.com/avatar/5998aa36d17ed36b30b20065c5006017?s=96&d=mm&r=g","contentUrl":"https://secure.gravatar.com/avatar/5998aa36d17ed36b30b20065c5006017?s=96&d=mm&r=g","caption":"Jesse Post"},"url":"https://archiecomics.com/author/jpost/"}]}</script>
	<!-- / Yoast SEO plugin. -->


<script type='application/javascript'>console.log('PixelYourSite Free version 9.1.1');</script>
<link rel='dns-prefetch' href='//s.w.org' />
<link rel="alternate" type="application/rss+xml" title="Archie Comics &raquo; Feed" href="https://archiecomics.com/feed/" />
<link rel="alternate" type="application/rss+xml" title="Archie Comics &raquo; Comments Feed" href="https://archiecomics.com/comments/feed/" />
<script type="text/javascript">
window._wpemojiSettings = {"baseUrl":"https:\/\/s.w.org\/images\/core\/emoji\/14.0.0\/72x72\/","ext":".png","svgUrl":"https:\/\/s.w.org\/images\/core\/emoji\/14.0.0\/svg\/","svgExt":".svg","source":{"concatemoji":"https:\/\/archiecomics.com\/wp-includes\/js\/wp-emoji-release.min.js?ver=6.0"}};
/*! This file is auto-generated */
!function(e,a,t){var n,r,o,i=a.createElement("canvas"),p=i.getContext&&i.getContext("2d");function s(e,t){var a=String.fromCharCode,e=(p.clearRect(0,0,i.width,i.height),p.fillText(a.apply(this,e),0,0),i.toDataURL());return p.clearRect(0,0,i.width,i.height),p.fillText(a.apply(this,t),0,0),e===i.toDataURL()}function c(e){var t=a.createElement("script");t.src=e,t.defer=t.type="text/javascript",a.getElementsByTagName("head")[0].appendChild(t)}for(o=Array("flag","emoji"),t.supports={everything:!0,everythingExceptFlag:!0},r=0;r<o.length;r++)t.supports[o[r]]=function(e){if(!p||!p.fillText)return!1;switch(p.textBaseline="top",p.font="600 32px Arial",e){case"flag":return s([127987,65039,8205,9895,65039],[127987,65039,8203,9895,65039])?!1:!s([55356,56826,55356,56819],[55356,56826,8203,55356,56819])&&!s([55356,57332,56128,56423,56128,56418,56128,56421,56128,56430,56128,56423,56128,56447],[55356,57332,8203,56128,56423,8203,56128,56418,8203,56128,56421,8203,56128,56430,8203,56128,56423,8203,56128,56447]);case"emoji":return!s([129777,127995,8205,129778,127999],[129777,127995,8203,129778,127999])}return!1}(o[r]),t.supports.everything=t.supports.everything&&t.supports[o[r]],"flag"!==o[r]&&(t.supports.everythingExceptFlag=t.supports.everythingExceptFlag&&t.supports[o[r]]);t.supports.everythingExceptFlag=t.supports.everythingExceptFlag&&!t.supports.flag,t.DOMReady=!1,t.readyCallback=function(){t.DOMReady=!0},t.supports.everything||(n=function(){t.readyCallback()},a.addEventListener?(a.addEventListener("DOMContentLoaded",n,!1),e.addEventListener("load",n,!1)):(e.attachEvent("onload",n),a.attachEvent("onreadystatechange",function(){"complete"===a.readyState&&t.readyCallback()})),(e=t.source||{}).concatemoji?c(e.concatemoji):e.wpemoji&&e.twemoji&&(c(e.twemoji),c(e.wpemoji)))}(window,document,window._wpemojiSettings);
</script>
<style type="text/css">
img.wp-smiley,
img.emoji {
	display: inline !important;
	border: none !important;
	box-shadow: none !important;
	height: 1em !important;
	width: 1em !important;
	margin: 0 0.07em !important;
	vertical-align: -0.1em !important;
	background: none !important;
	padding: 0 !important;
}
</style>
	<link rel='stylesheet' id='wp-block-library-css'  href='https://archiecomics.com/wp-includes/css/dist/block-library/style.min.css?ver=6.0' type='text/css' media='all' />
<style id='global-styles-inline-css' type='text/css'>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</style>
<link rel='stylesheet' id='wonderplugin-carousel-engine-css-css'  href='https://archiecomics.com/wp-content/plugins/wonderplugin-carousel/engine/wonderplugincarouselengine.css?ver=18.5C' type='text/css' media='all' />
<link rel='stylesheet' id='tempera-fonts-css'  href='https://archiecomics.com/wp-content/themes/tempera/fonts/fontfaces.css?ver=1.8.0' type='text/css' media='all' />
<link rel='stylesheet' id='tempera-style-css'  href='https://archiecomics.com/wp-content/themes/tempera-nocopyrt/style.css?ver=1.8.0' type='text/css' media='all' />
<style id='tempera-style-inline-css' type='text/css'>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</style>
<link rel='stylesheet' id='nirvana-mobile-css'  href='https://archiecomics.com/wp-content/themes/tempera/styles/style-mobile.css?ver=1.8.0' type='text/css' media='all' />
<script type='text/javascript' src='https://archiecomics.com/wp-includes/js/jquery/jquery.min.js?ver=3.6.0' id='jquery-core-js'></script>
<script type='text/javascript' src='https://archiecomics.com/wp-includes/js/jquery/jquery-migrate.min.js?ver=3.3.2' id='jquery-migrate-js'></script>
<script type='text/javascript' src='https://archiecomics.com/wp-content/plugins/wonderplugin-carousel/engine/wonderplugincarouselskins.js?ver=18.5C' id='wonderplugin-carousel-skins-script-js'></script>
<script type='text/javascript' src='https://archiecomics.com/wp-content/plugins/wonderplugin-carousel/engine/wonderplugincarousel.js?ver=18.5C' id='wonderplugin-carousel-script-js'></script>
<script type='text/javascript' src='https://archiecomics.com/wp-content/plugins/pixelyoursite/dist/scripts/jquery.bind-first-0.2.3.min.js?ver=6.0' id='jquery-bind-first-js'></script>
<script type='text/javascript' src='https://archiecomics.com/wp-content/plugins/pixelyoursite/dist/scripts/js.cookie-2.1.3.min.js?ver=2.1.3' id='js-cookie-js'></script>
<script type='text/javascript' id='pys-js-extra'>
/* <![CDATA[ */
var pysOptions = {"staticEvents":{"facebook":{"init_event":[{"delay":0,"type":"static","name":"PageView","pixelIds":["150910205450480"],"eventID":"ba660b4a-a672-4c0a-9502-7642f1014074","params":{"post_category":"Free Comic, News, On Sale Today","page_title":"New Archie Comics Releases for 7\/13\/22","post_type":"post","post_id":27985,"plugin":"PixelYourSite","user_role":"guest","event_url":"archiecomics.com\/new-archie-comics-releases-for-7-13-22\/"},"e_id":"init_event","ids":[],"hasTimeWindow":false,"timeWindow":0,"woo_order":"","edd_order":""}]}},"dynamicEvents":{"automatic_event_form":{"facebook":{"delay":0,"type":"dyn","name":"Form","pixelIds":["150910205450480"],"eventID":"b11d61ff-6f0e-4696-98ba-cd2b4796df6f","params":{"page_title":"New Archie Comics Releases for 7\/13\/22","post_type":"post","post_id":27985,"plugin":"PixelYourSite","user_role":"guest","event_url":"archiecomics.com\/new-archie-comics-releases-for-7-13-22\/"},"e_id":"automatic_event_form","ids":[],"hasTimeWindow":false,"timeWindow":0,"woo_order":"","edd_order":""}},"automatic_event_download":{"facebook":{"delay":0,"type":"dyn","name":"Download","extensions":["","doc","exe","js","pdf","ppt","tgz","zip","xls"],"pixelIds":["150910205450480"],"eventID":"0749df50-fa74-4523-982d-ae363a21b4de","params":{"page_title":"New Archie Comics Releases for 7\/13\/22","post_type":"post","post_id":27985,"plugin":"PixelYourSite","user_role":"guest","event_url":"archiecomics.com\/new-archie-comics-releases-for-7-13-22\/"},"e_id":"automatic_event_download","ids":[],"hasTimeWindow":false,"timeWindow":0,"woo_order":"","edd_order":""}},"automatic_event_comment":{"facebook":{"delay":0,"type":"dyn","name":"Comment","pixelIds":["150910205450480"],"eventID":"0c83ca10-6850-4f74-8036-4deeffb73054","params":{"page_title":"New Archie Comics Releases for 7\/13\/22","post_type":"post","post_id":27985,"plugin":"PixelYourSite","user_role":"guest","event_url":"archiecomics.com\/new-archie-comics-releases-for-7-13-22\/"},"e_id":"automatic_event_comment","ids":[],"hasTimeWindow":false,"timeWindow":0,"woo_order":"","edd_order":""}}},"triggerEvents":[],"triggerEventTypes":[],"facebook":{"pixelIds":["150910205450480"],"advancedMatching":[],"removeMetadata":false,"contentParams":{"post_type":"post","post_id":27985,"content_name":"New Archie Comics Releases for 7\/13\/22","categories":"Free Comic, News, On Sale Today","tags":"betty and veronica, betty and veronica digest, betty and veronica friends forever, big ethel energy, first looks, josie, jughead, new releases, on sale today, preview, previews, Stacy Banks, summer, summer surf party, world of archie digest, young dr. masters"},"commentEventEnabled":true,"wooVariableAsSimple":false,"downloadEnabled":true,"formEventEnabled":true,"ajaxForServerEvent":true,"serverApiEnabled":false,"wooCRSendFromServer":false},"debug":"","siteUrl":"https:\/\/archiecomics.com","ajaxUrl":"https:\/\/archiecomics.com\/wp-admin\/admin-ajax.php","enable_remove_download_url_param":"1","gdpr":{"ajax_enabled":false,"all_disabled_by_api":false,"facebook_disabled_by_api":false,"analytics_disabled_by_api":false,"google_ads_disabled_by_api":false,"pinterest_disabled_by_api":false,"bing_disabled_by_api":false,"facebook_prior_consent_enabled":false,"analytics_prior_consent_enabled":true,"google_ads_prior_consent_enabled":null,"pinterest_prior_consent_enabled":true,"bing_prior_consent_enabled":true,"cookiebot_integration_enabled":false,"cookiebot_facebook_consent_category":"marketing","cookiebot_analytics_consent_category":"statistics","cookiebot_google_ads_consent_category":null,"cookiebot_pinterest_consent_category":"marketing","cookiebot_bing_consent_category":"marketing","consent_magic_integration_enabled":false,"real_cookie_banner_integration_enabled":false,"cookie_notice_integration_enabled":false,"cookie_law_info_integration_enabled":false},"woo":{"enabled":false},"edd":{"enabled":false}};
/* ]]> */
</script>
<script type='text/javascript' src='https://archiecomics.com/wp-content/plugins/pixelyoursite/dist/scripts/public.js?ver=9.1.1' id='pys-js'></script>
<link rel="https://api.w.org/" href="https://archiecomics.com/wp-json/" /><link rel="alternate" type="application/json" href="https://archiecomics.com/wp-json/wp/v2/posts/27985" /><link rel="EditURI" type="application/rsd+xml" title="RSD" href="https://archiecomics.com/xmlrpc.php?rsd" />
<link rel="wlwmanifest" type="application/wlwmanifest+xml" href="https://archiecomics.com/wp-includes/wlwmanifest.xml" /> 
<link rel='shortlink' href='https://archiecomics.com/?p=27985' />
<link rel="alternate" type="application/json+oembed" href="https://archiecomics.com/wp-json/oembed/1.0/embed?url=https%3A%2F%2Farchiecomics.com%2Fnew-archie-comics-releases-for-7-13-22%2F" />
<link rel="alternate" type="text/xml+oembed" href="https://archiecomics.com/wp-json/oembed/1.0/embed?url=https%3A%2F%2Farchiecomics.com%2Fnew-archie-comics-releases-for-7-13-22%2F&#038;format=xml" />
<meta name="facebook-domain-verification" content="cbcms1bw102fcx39347iwyqnevb35f" /><script type="text/javascript">
(function(url){
	if(/(?:Chrome\/26\.0\.1410\.63 Safari\/537\.31|WordfenceTestMonBot)/.test(navigator.userAgent)){ return; }
	var addEvent = function(evt, handler) {
		if (window.addEventListener) {
			document.addEventListener(evt, handler, false);
		} else if (window.attachEvent) {
			document.attachEvent('on' + evt, handler);
		}
	};
	var removeEvent = function(evt, handler) {
		if (window.removeEventListener) {
			document.removeEventListener(evt, handler, false);
		} else if (window.detachEvent) {
			document.detachEvent('on' + evt, handler);
		}
	};
	var evts = 'contextmenu dblclick drag dragend dragenter dragleave dragover dragstart drop keydown keypress keyup mousedown mousemove mouseout mouseover mouseup mousewheel scroll'.split(' ');
	var logHuman = function() {
		if (window.wfLogHumanRan) { return; }
		window.wfLogHumanRan = true;
		var wfscr = document.createElement('script');
		wfscr.type = 'text/javascript';
		wfscr.async = true;
		wfscr.src = url + '&r=' + Math.random();
		(document.getElementsByTagName('head')[0]||document.getElementsByTagName('body')[0]).appendChild(wfscr);
		for (var i = 0; i < evts.length; i++) {
			removeEvent(evts[i], logHuman);
		}
	};
	for (var i = 0; i < evts.length; i++) {
		addEvent(evts[i], logHuman);
	}
})('//archiecomics.com/?wordfence_lh=1&hid=9CC02979BD5AA0AB5388EA40734598D4');
</script><style type="text/css" id="custom-background-css">
body.custom-background { background-color: #ffffff; background-image: url("https://archiecomics.com/wp-content/uploads/2021/10/Holiday-2021-Red-Background.jpg"); background-position: center top; background-size: contain; background-repeat: repeat; background-attachment: scroll; }
</style>
	<link rel="icon" href="https://archiecomics.com/wp-content/uploads/2022/07/cropped-Archie-Santa-Icon-01_512x512-32x32.png" sizes="32x32" />
<link rel="icon" href="https://archiecomics.com/wp-content/uploads/2022/07/cropped-Archie-Santa-Icon-01_512x512-192x192.png" sizes="192x192" />
<link rel="apple-touch-icon" href="https://archiecomics.com/wp-content/uploads/2022/07/cropped-Archie-Santa-Icon-01_512x512-180x180.png" />
<meta name="msapplication-TileImage" content="https://archiecomics.com/wp-content/uploads/2022/07/cropped-Archie-Santa-Icon-01_512x512-270x270.png" />
	<!--[if lt IE 9]>
	<script>
	document.createElement('header');
	document.createElement('nav');
	document.createElement('section');
	document.createElement('article');
	document.createElement('aside');
	document.createElement('footer');
	</script>
	<![endif]-->
	</head>
<body class="post-template-default single single-post postid-27985 single-format-standard custom-background tempera-image-none caption-dark tempera-comment-placeholders tempera-menu-left">

	<a class="skip-link screen-reader-text" href="#main" title="Skip to content"> Skip to content </a>
	<svg xmlns="http://www.w3.org/2000/svg" viewBox="0 0 0 0" width="0" height="0" focusable="false" role="none" style="visibility: hidden; position: absolute; left: -9999px; overflow: hidden;" ><defs><filter id="wp-duotone-dark-grayscale"><feColorMatrix color-interpolation-filters="sRGB" type="matrix" values=" .299 .587 .114 0 0 .299 .587 .114 0 0 .299 .587 .114 0 0 .299 .587 .114 0 0 " /><feComponentTransfer color-interpolation-filters="sRGB" ><feFuncR type="table" tableValues="0 0.49803921568627" /><feFuncG type="table" tableValues="0 0.49803921568627" /><feFuncB type="table" tableValues="0 0.49803921568627" /><feFuncA type="table" tableValues="1 1" /></feComponentTransfer><feComposite in2="SourceGraphic" operator="in" /></filter></defs></svg><svg xmlns="http://www.w3.org/2000/svg" viewBox="0 0 0 0" width="0" height="0" focusable="false" role="none" style="visibility: hidden; position: absolute; left: -9999px; overflow: hidden;" ><defs><filter id="wp-duotone-grayscale"><feColorMatrix color-interpolation-filters="sRGB" type="matrix" values=" .299 .587 .114 0 0 .299 .587 .114 0 0 .299 .587 .114 0 0 .299 .587 .114 0 0 " /><feComponentTransfer color-interpolation-filters="sRGB" ><feFuncR type="table" tableValues="0 1" /><feFuncG type="table" tableValues="0 1" /><feFuncB type="table" tableValues="0 1" /><feFuncA type="table" tableValues="1 1" /></feComponentTransfer><feComposite in2="SourceGraphic" operator="in" /></filter></defs></svg><svg xmlns="http://www.w3.org/2000/svg" viewBox="0 0 0 0" width="0" height="0" focusable="false" role="none" style="visibility: hidden; position: absolute; left: -9999px; overflow: hidden;" ><defs><filter id="wp-duotone-purple-yellow"><feColorMatrix color-interpolation-filters="sRGB" type="matrix" values=" .299 .587 .114 0 0 .299 .587 .114 0 0 .299 .587 .114 0 0 .299 .587 .114 0 0 " /><feComponentTransfer color-interpolation-filters="sRGB" ><feFuncR type="table" tableValues="0.54901960784314 0.98823529411765" /><feFuncG type="table" tableValues="0 1" /><feFuncB type="table" tableValues="0.71764705882353 0.25490196078431" /><feFuncA type="table" tableValues="1 1" /></feComponentTransfer><feComposite in2="SourceGraphic" operator="in" /></filter></defs></svg><svg xmlns="http://www.w3.org/2000/svg" viewBox="0 0 0 0" width="0" height="0" focusable="false" role="none" style="visibility: hidden; position: absolute; left: -9999px; overflow: hidden;" ><defs><filter id="wp-duotone-blue-red"><feColorMatrix color-interpolation-filters="sRGB" type="matrix" values=" .299 .587 .114 0 0 .299 .587 .114 0 0 .299 .587 .114 0 0 .299 .587 .114 0 0 " /><feComponentTransfer color-interpolation-filters="sRGB" ><feFuncR type="table" tableValues="0 1" /><feFuncG type="table" tableValues="0 0.27843137254902" /><feFuncB type="table" tableValues="0.5921568627451 0.27843137254902" /><feFuncA type="table" tableValues="1 1" /></feComponentTransfer><feComposite in2="SourceGraphic" operator="in" /></filter></defs></svg><svg xmlns="http://www.w3.org/2000/svg" viewBox="0 0 0 0" width="0" height="0" focusable="false" role="none" style="visibility: hidden; position: absolute; left: -9999px; overflow: hidden;" ><defs><filter id="wp-duotone-midnight"><feColorMatrix color-interpolation-filters="sRGB" type="matrix" values=" .299 .587 .114 0 0 .299 .587 .114 0 0 .299 .587 .114 0 0 .299 .587 .114 0 0 " /><feComponentTransfer color-interpolation-filters="sRGB" ><feFuncR type="table" tableValues="0 0" /><feFuncG type="table" tableValues="0 0.64705882352941" /><feFuncB type="table" tableValues="0 1" /><feFuncA type="table" tableValues="1 1" /></feComponentTransfer><feComposite in2="SourceGraphic" operator="in" /></filter></defs></svg><svg xmlns="http://www.w3.org/2000/svg" viewBox="0 0 0 0" width="0" height="0" focusable="false" role="none" style="visibility: hidden; position: absolute; left: -9999px; overflow: hidden;" ><defs><filter id="wp-duotone-magenta-yellow"><feColorMatrix color-interpolation-filters="sRGB" type="matrix" values=" .299 .587 .114 0 0 .299 .587 .114 0 0 .299 .587 .114 0 0 .299 .587 .114 0 0 " /><feComponentTransfer color-interpolation-filters="sRGB" ><feFuncR type="table" tableValues="0.78039215686275 1" /><feFuncG type="table" tableValues="0 0.94901960784314" /><feFuncB type="table" tableValues="0.35294117647059 0.47058823529412" /><feFuncA type="table" tableValues="1 1" /></feComponentTransfer><feComposite in2="SourceGraphic" operator="in" /></filter></defs></svg><svg xmlns="http://www.w3.org/2000/svg" viewBox="0 0 0 0" width="0" height="0" focusable="false" role="none" style="visibility: hidden; position: absolute; left: -9999px; overflow: hidden;" ><defs><filter id="wp-duotone-purple-green"><feColorMatrix color-interpolation-filters="sRGB" type="matrix" values=" .299 .587 .114 0 0 .299 .587 .114 0 0 .299 .587 .114 0 0 .299 .587 .114 0 0 " /><feComponentTransfer color-interpolation-filters="sRGB" ><feFuncR type="table" tableValues="0.65098039215686 0.40392156862745" /><feFuncG type="table" tableValues="0 1" /><feFuncB type="table" tableValues="0.44705882352941 0.4" /><feFuncA type="table" tableValues="1 1" /></feComponentTransfer><feComposite in2="SourceGraphic" operator="in" /></filter></defs></svg><svg xmlns="http://www.w3.org/2000/svg" viewBox="0 0 0 0" width="0" height="0" focusable="false" role="none" style="visibility: hidden; position: absolute; left: -9999px; overflow: hidden;" ><defs><filter id="wp-duotone-blue-orange"><feColorMatrix color-interpolation-filters="sRGB" type="matrix" values=" .299 .587 .114 0 0 .299 .587 .114 0 0 .299 .587 .114 0 0 .299 .587 .114 0 0 " /><feComponentTransfer color-interpolation-filters="sRGB" ><feFuncR type="table" tableValues="0.098039215686275 1" /><feFuncG type="table" tableValues="0 0.66274509803922" /><feFuncB type="table" tableValues="0.84705882352941 0.41960784313725" /><feFuncA type="table" tableValues="1 1" /></feComponentTransfer><feComposite in2="SourceGraphic" operator="in" /></filter></defs></svg>
<div id="wrapper" class="hfeed">
<div id="topbar" ><div id="topbar-inner"> <div class="socials" id="sheader">
			<a  target="_blank"  href="https://www.facebook.com/ArchieComicsOfficial?ref=tn_tnmn"
			class="socialicons social-Facebook" title="Archie Comics Facebook">
				<img alt="Facebook" src="https://archiecomics.com/wp-content/themes/tempera/images/socials/Facebook.png" />
			</a>
			<a  target="_blank"  href="https://twitter.com/archiecomics"
			class="socialicons social-Twitter" title="Archie Comics Twitter">
				<img alt="Twitter" src="https://archiecomics.com/wp-content/themes/tempera/images/socials/Twitter.png" />
			</a>
			<a  target="_blank"  href="http://www.youtube.com/user/ArchieComicsOfficial"
			class="socialicons social-YouTube" title="Archie Comics YouTube Channel">
				<img alt="YouTube" src="https://archiecomics.com/wp-content/themes/tempera/images/socials/YouTube.png" />
			</a>
			<a  target="_blank"  href="https://plus.google.com/u/0/103927090213296657788/posts"
			class="socialicons social-GooglePlus" title="Archie Comics Google+">
				<img alt="GooglePlus" src="https://archiecomics.com/wp-content/themes/tempera/images/socials/GooglePlus.png" />
			</a>
			<a  target="_blank"  href="http://www.goodreads.com/user/show/8914136-archie-comics"
			class="socialicons social-GoodReads" title="Archie Comics GoodReads">
				<img alt="GoodReads" src="https://archiecomics.com/wp-content/themes/tempera/images/socials/GoodReads.png" />
			</a></div> </div></div>

<div id="header-full">
	<header id="header">
		<div id="masthead">
			<div id="branding" role="banner" >
				<img id="bg_image" alt="Archie Comics" title="Archie Comics" src="https://archiecomics.com/wp-content/uploads/2014/09/cropped-archie_comics_header.png"  />	<div id="header-container">
	<a href="https://archiecomics.com/" id="linky"></a></div>						<div id="header-widget-area">
			<ul class="yoyo">
				<li id="search-3" class="widget-container widget_search">
<form role="search" method="get" class="searchform" action="https://archiecomics.com/">
	<label>
		<span class="screen-reader-text">Search for:</span>
		<input type="search" class="s" placeholder="Search" value="" name="s" />
	</label>
	<button type="submit" class="searchsubmit"><span class="screen-reader-text">Search</span><i class="crycon-search"></i></button>
</form>
</li>			</ul>
		</div>
					<div style="clear:both;"></div>
			</div><!-- #branding -->
			<button id="nav-toggle"><span>&nbsp;</span></button>
			<nav id="access" class="jssafe" role="navigation">
					<div class="skip-link screen-reader-text"><a href="#content" title="Skip to content">
		Skip to content	</a></div>
	<div class="menu"><ul id="prime_nav" class="menu"><li id="menu-item-6" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-home menu-item-6"><a href="http://archiecomics.com/"><span>Home</span></a></li>
<li id="menu-item-939" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-939"><a href="https://archiecomics.com/news/"><span>News</span></a></li>
<li id="menu-item-27404" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-27404"><a target="_blank" rel="noopener" href="https://archiecomics.com/nft/?utm_source=ACP&#038;utm_medium=Top%20Nav&#038;utm_campaign=ACP_Top_Menu"><span>NFT</span></a></li>
<li id="menu-item-924" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-has-children menu-item-924"><a target="_blank" rel="noopener" href="https://store.archiecomics.com/?utm_source=ACP&#038;utm_medium=Menu&#038;utm_campaign=TopMenu"><span>Shop</span></a>
<ul class="sub-menu">
	<li id="menu-item-7961" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-7961"><a target="_blank" rel="noopener" href="https://store.archiecomics.com/?utm_source=ACP&#038;utm_medium=Menu&#038;utm_campaign=TopMenu"><span>Archie Comics Shop</span></a></li>
	<li id="menu-item-6625" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-6625"><a target="_blank" rel="noopener" href="https://store.archiecomics.com/series"><span>Archie Subscriptions</span></a></li>
</ul>
</li>
<li id="menu-item-51" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-has-children menu-item-51"><a href="https://archiecomics.com/characters/"><span>Characters</span></a>
<ul class="sub-menu">
	<li id="menu-item-6285" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-6285"><a href="https://archiecomics.com/characters/"><span>Traditional Archie</span></a></li>
	<li id="menu-item-6284" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-6284"><a href="https://archiecomics.com/characters/new-riverdale/"><span>New Archie</span></a></li>
	<li id="menu-item-6590" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-6590"><a href="https://archiecomics.com/characters/riverdale-on-the-cw/"><span>Riverdale on the CW</span></a></li>
</ul>
</li>
<li id="menu-item-25355" class="menu-item menu-item-type-post_type menu-item-object-post menu-item-has-children menu-item-25355"><a href="https://archiecomics.com/appnews/"><span>Digital Comics</span></a>
<ul class="sub-menu">
	<li id="menu-item-25354" class="menu-item menu-item-type-post_type menu-item-object-post menu-item-25354"><a href="https://archiecomics.com/appnews/"><span>Archie Digital</span></a></li>
</ul>
</li>
<li id="menu-item-932" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-has-children menu-item-932"><a href="https://archiecomics.com/about-us/"><span>About Us</span></a>
<ul class="sub-menu">
	<li id="menu-item-928" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-928"><a href="http://archiecomics.com/about-us/"><span>Contact</span></a></li>
	<li id="menu-item-933" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-933"><a href="https://archiecomics.com/about-us/privacy-policy/"><span>Privacy Policy</span></a></li>
</ul>
</li>
<li class='menu-main-search'> 
<form role="search" method="get" class="searchform" action="https://archiecomics.com/">
	<label>
		<span class="screen-reader-text">Search for:</span>
		<input type="search" class="s" placeholder="Search" value="" name="s" />
	</label>
	<button type="submit" class="searchsubmit"><span class="screen-reader-text">Search</span><i class="crycon-search"></i></button>
</form>
 </li></ul></div>			</nav><!-- #access -->
		</div><!-- #masthead -->
	</header><!-- #header -->
</div><!-- #header-full -->

<div style="clear:both;height:0;"> </div>

<div id="main" class="main">
		<div id="toTop"><i class="crycon-back2top"></i> </div>	<div  id="forbottom" >
		
		<div style="clear:both;"> </div>

		
		<section id="container" class="two-columns-right">
			<div id="content" role="main">
			<div class="breadcrumbs"><a href="https://archiecomics.com"><i class="crycon-homebread"></i><span class="screen-reader-text">Home</span></a><i class="crycon-angle-right"></i> <a href="https://archiecomics.com/category/free-comic/">Free Comic</a> <i class="crycon-angle-right"></i> <span class="current">New Archie Comics Releases for 7/13/22</span></div><!--breadcrumbs-->

				<div id="post-27985" class="post-27985 post type-post status-publish format-standard has-post-thumbnail hentry category-free-comic category-news category-on-sale-today tag-betty-and-veronica tag-betty-and-veronica-digest tag-betty-and-veronica-friends-forever tag-big-ethel-energy tag-first-looks tag-josie tag-jughead tag-new-releases tag-on-sale-today-2 tag-preview tag-previews tag-stacy-banks tag-summer tag-summer-surf-party tag-world-of-archie-digest tag-young-dr-masters">
					<h1 class="entry-title">New Archie Comics Releases for 7/13/22</h1>
										<div class="entry-meta">
						<span class="author vcard" ><i class="crycon-author crycon-metas" title="Author "></i>
					<a class="url fn n" rel="author" href="https://archiecomics.com/author/jpost/" title="View all posts by Jesse Post">Jesse Post</a></span><span><i class="crycon-time crycon-metas" title="Date"></i>
				<time class="onDate date published" datetime="2022-07-13T09:00:12-04:00">
					<a href="https://archiecomics.com/new-archie-comics-releases-for-7-13-22/" rel="bookmark">July 13, 2022</a>
				</time>
			   </span><time class="updated"  datetime="2022-07-07T17:48:17-04:00">July 7, 2022</time><span class="bl_categ"><i class="crycon-folder-open crycon-metas" title="Categories"></i><a href="https://archiecomics.com/category/free-comic/" rel="tag">Free Comic</a>, <a href="https://archiecomics.com/category/news/" rel="tag">News</a>, <a href="https://archiecomics.com/category/news/on-sale-today/" rel="tag">On Sale Today</a></span> 					</div><!-- .entry-meta -->

					<div class="entry-content">
						<div class="breadcrumbs"></div>
<div id="post-27113" class="post-27113 post type-post status-publish format-standard has-post-thumbnail hentry category-free-comic category-news category-on-sale-today tag-betty-veronica tag-big-ethel-energy tag-first-looks tag-on-sale-today-2 tag-preview tag-previews tag-showcase-digest">
<div class="entry-meta"><a href="https://archiecomics.com/wp-content/uploads/2022/07/BettyAndVeronicaFriendsForever_SummerSurfParty_01-13.jpg"><img class="aligncenter wp-image-27986 size-full" src="https://archiecomics.com/wp-content/uploads/2022/07/BettyAndVeronicaFriendsForever_SummerSurfParty_01-13.jpg" alt="" width="975" height="404" srcset="https://archiecomics.com/wp-content/uploads/2022/07/BettyAndVeronicaFriendsForever_SummerSurfParty_01-13.jpg 975w, https://archiecomics.com/wp-content/uploads/2022/07/BettyAndVeronicaFriendsForever_SummerSurfParty_01-13-300x124.jpg 300w, https://archiecomics.com/wp-content/uploads/2022/07/BettyAndVeronicaFriendsForever_SummerSurfParty_01-13-150x62.jpg 150w, https://archiecomics.com/wp-content/uploads/2022/07/BettyAndVeronicaFriendsForever_SummerSurfParty_01-13-768x318.jpg 768w" sizes="(max-width: 975px) 100vw, 975px" /></a></div>
<div class="entry-content">
<p>Stacy Banks makes her big debut in today&#8217;s batch of new releases! Read on for a look inside the new Archie comics hitting stores 7/13/22:</p>
<p><span id="more-27985"></span></p>
<p>To purchase Archie titles in print, visit the <span style="color: #0000ff;"><a style="color: #0000ff;" href="http://bit.ly/BuyArchie">Archie Comics Online Store</a></span> or find a comic shop near you using the <span style="color: #0000ff;"><a style="color: #0000ff;" href="http://www.comicshoplocator.com/">Comic Shop Locator service.</a></span></p>
</div>
</div>
<div id="post-27113" class="post-27113 post type-post status-publish format-standard has-post-thumbnail hentry category-free-comic category-news category-on-sale-today tag-betty-veronica tag-big-ethel-energy tag-first-looks tag-on-sale-today-2 tag-preview tag-previews tag-showcase-digest">
<div class="entry-content">
<div id="post-27113" class="post-27113 post type-post status-publish format-standard has-post-thumbnail hentry category-free-comic category-news category-on-sale-today tag-betty-veronica tag-big-ethel-energy tag-first-looks tag-on-sale-today-2 tag-preview tag-previews tag-showcase-digest">
<div class="entry-content">
<div id="gallery-2" class="gallery galleryid-27113 gallery-columns-3 gallery-size-full">
<div id="post-27113" class="post-27113 post type-post status-publish format-standard has-post-thumbnail hentry category-free-comic category-news category-on-sale-today tag-betty-veronica tag-big-ethel-energy tag-first-looks tag-on-sale-today-2 tag-preview tag-previews tag-showcase-digest">
<div class="entry-content">
<hr />
</div>
</div>
<p>&nbsp;</p>
<p><a href="https://archiecomics.com/wp-content/uploads/2022/07/BettyAndVeronicaFriendsForever_SummerSurfParty_01_CoverShultz.jpg"><img loading="lazy" class="aligncenter wp-image-27987 size-full" src="https://archiecomics.com/wp-content/uploads/2022/07/BettyAndVeronicaFriendsForever_SummerSurfParty_01_CoverShultz.jpg" alt="" width="1000" height="1537" srcset="https://archiecomics.com/wp-content/uploads/2022/07/BettyAndVeronicaFriendsForever_SummerSurfParty_01_CoverShultz.jpg 1000w, https://archiecomics.com/wp-content/uploads/2022/07/BettyAndVeronicaFriendsForever_SummerSurfParty_01_CoverShultz-195x300.jpg 195w, https://archiecomics.com/wp-content/uploads/2022/07/BettyAndVeronicaFriendsForever_SummerSurfParty_01_CoverShultz-666x1024.jpg 666w, https://archiecomics.com/wp-content/uploads/2022/07/BettyAndVeronicaFriendsForever_SummerSurfParty_01_CoverShultz-98x150.jpg 98w, https://archiecomics.com/wp-content/uploads/2022/07/BettyAndVeronicaFriendsForever_SummerSurfParty_01_CoverShultz-768x1180.jpg 768w" sizes="(max-width: 1000px) 100vw, 1000px" /></a></p>
<p>A <strong>BRAND-NEW STORY</strong> kicks off this collection of fun-in-the-sun stories about pool parties, beach bashes and more, all hosted by Betty &amp; Veronica! In &#8220;What&#8217;s the Word?&#8221; Veronica&#8217;s planning on throwing the BIGGEST pool party ever. She&#8217;s been working on it for months, and now the big day is almost here . . . but no one seems to be that interested. Everyone&#8217;s too consumed with beating each other&#8217;s streak on a brand-new app called &#8220;Wordeel.&#8221; Can Veronica get everyone into the spirit so her pool party can actually make a splash?</p>
<p>Script: Jamie L. Rotante<br />
Art: Dan Parent, Bob Smith<br />
Colors: Glenn Whitmore<br />
Letters: Jack Morelli<br />
Cover: Bill Golliher, Jeff Shultz, Rosario “Tito” Peña, Jack Morelli<br />
On Sale Date: 7/13<br />
32-page, full color comic<br />
$2.99 U.S.</p>
<h4 style="text-align: center;"><strong>GET YOUR COPY:</strong></h4>
<p style="text-align: center;"><a href="https://store.archiecomics.com/products/b-v-friends-forever-summer-surf-party-1"><span style="color: #3366ff;">Direct from the Archie Shop</span></a><br />
<span style="color: #0000ff;"><a style="color: #0000ff;" href="https://previewsworld.com/Catalog/MAY221191">Your Local Comic Shop</a></span><br />
<span style="color: #0000ff;"><a style="color: #0000ff;" href="https://www.amazon.com/Friends-Forever-Summer-Party-Veronica-ebook/dp/B0B3BNSJ38">Read it Digitally on comiXology</a><br />
<a style="color: #0000ff;" href="https://store.archiecomics.com/collections/archie-digest-subscriptions/products/betty-veronica-friends-forever">Subscribe at the Archie Shop!</a></span></p>
<h4 style="text-align: center;"><strong><br />
START READING NOW!</strong></h4>
<div id="gallery-2" class="gallery galleryid-27113 gallery-columns-3 gallery-size-full">

		<style type="text/css">
			#gallery-2 {
				margin: auto;
			}
			#gallery-2 .gallery-item {
				float: left;
				margin-top: 10px;
				text-align: center;
				width: 25%;
			}
			#gallery-2 img {
				border: 2px solid #cfcfcf;
			}
			#gallery-2 .gallery-caption {
				margin-left: 0;
			}
			/* see gallery_shortcode() in wp-includes/media.php */
		</style>
		<div id='gallery-2' class='gallery galleryid-27985 gallery-columns-4 gallery-size-full'><dl class='gallery-item'>
			<dt class='gallery-icon portrait'>
				<a href='https://archiecomics.com/wp-content/uploads/2022/07/BettyAndVeronicaFriendsForever_SummerSurfParty_01-1.jpg'><img width="1000" height="1537" src="https://archiecomics.com/wp-content/uploads/2022/07/BettyAndVeronicaFriendsForever_SummerSurfParty_01-1.jpg" class="attachment-full size-full" alt="" loading="lazy" srcset="https://archiecomics.com/wp-content/uploads/2022/07/BettyAndVeronicaFriendsForever_SummerSurfParty_01-1.jpg 1000w, https://archiecomics.com/wp-content/uploads/2022/07/BettyAndVeronicaFriendsForever_SummerSurfParty_01-1-195x300.jpg 195w, https://archiecomics.com/wp-content/uploads/2022/07/BettyAndVeronicaFriendsForever_SummerSurfParty_01-1-666x1024.jpg 666w, https://archiecomics.com/wp-content/uploads/2022/07/BettyAndVeronicaFriendsForever_SummerSurfParty_01-1-98x150.jpg 98w, https://archiecomics.com/wp-content/uploads/2022/07/BettyAndVeronicaFriendsForever_SummerSurfParty_01-1-768x1180.jpg 768w" sizes="(max-width: 1000px) 100vw, 1000px" /></a>
			</dt></dl><dl class='gallery-item'>
			<dt class='gallery-icon portrait'>
				<a href='https://archiecomics.com/wp-content/uploads/2022/07/BettyAndVeronicaFriendsForever_SummerSurfParty_01-2.jpg'><img width="1000" height="1537" src="https://archiecomics.com/wp-content/uploads/2022/07/BettyAndVeronicaFriendsForever_SummerSurfParty_01-2.jpg" class="attachment-full size-full" alt="" loading="lazy" srcset="https://archiecomics.com/wp-content/uploads/2022/07/BettyAndVeronicaFriendsForever_SummerSurfParty_01-2.jpg 1000w, https://archiecomics.com/wp-content/uploads/2022/07/BettyAndVeronicaFriendsForever_SummerSurfParty_01-2-195x300.jpg 195w, https://archiecomics.com/wp-content/uploads/2022/07/BettyAndVeronicaFriendsForever_SummerSurfParty_01-2-666x1024.jpg 666w, https://archiecomics.com/wp-content/uploads/2022/07/BettyAndVeronicaFriendsForever_SummerSurfParty_01-2-98x150.jpg 98w, https://archiecomics.com/wp-content/uploads/2022/07/BettyAndVeronicaFriendsForever_SummerSurfParty_01-2-768x1180.jpg 768w" sizes="(max-width: 1000px) 100vw, 1000px" /></a>
			</dt></dl><dl class='gallery-item'>
			<dt class='gallery-icon portrait'>
				<a href='https://archiecomics.com/wp-content/uploads/2022/07/BettyAndVeronicaFriendsForever_SummerSurfParty_01-3.jpg'><img width="1000" height="1537" src="https://archiecomics.com/wp-content/uploads/2022/07/BettyAndVeronicaFriendsForever_SummerSurfParty_01-3.jpg" class="attachment-full size-full" alt="" loading="lazy" srcset="https://archiecomics.com/wp-content/uploads/2022/07/BettyAndVeronicaFriendsForever_SummerSurfParty_01-3.jpg 1000w, https://archiecomics.com/wp-content/uploads/2022/07/BettyAndVeronicaFriendsForever_SummerSurfParty_01-3-195x300.jpg 195w, https://archiecomics.com/wp-content/uploads/2022/07/BettyAndVeronicaFriendsForever_SummerSurfParty_01-3-666x1024.jpg 666w, https://archiecomics.com/wp-content/uploads/2022/07/BettyAndVeronicaFriendsForever_SummerSurfParty_01-3-98x150.jpg 98w, https://archiecomics.com/wp-content/uploads/2022/07/BettyAndVeronicaFriendsForever_SummerSurfParty_01-3-768x1180.jpg 768w" sizes="(max-width: 1000px) 100vw, 1000px" /></a>
			</dt></dl><dl class='gallery-item'>
			<dt class='gallery-icon portrait'>
				<a href='https://archiecomics.com/wp-content/uploads/2022/07/BettyAndVeronicaFriendsForever_SummerSurfParty_01-13-1.jpg'><img width="1000" height="1537" src="https://archiecomics.com/wp-content/uploads/2022/07/BettyAndVeronicaFriendsForever_SummerSurfParty_01-13-1.jpg" class="attachment-full size-full" alt="" loading="lazy" srcset="https://archiecomics.com/wp-content/uploads/2022/07/BettyAndVeronicaFriendsForever_SummerSurfParty_01-13-1.jpg 1000w, https://archiecomics.com/wp-content/uploads/2022/07/BettyAndVeronicaFriendsForever_SummerSurfParty_01-13-1-195x300.jpg 195w, https://archiecomics.com/wp-content/uploads/2022/07/BettyAndVeronicaFriendsForever_SummerSurfParty_01-13-1-666x1024.jpg 666w, https://archiecomics.com/wp-content/uploads/2022/07/BettyAndVeronicaFriendsForever_SummerSurfParty_01-13-1-98x150.jpg 98w, https://archiecomics.com/wp-content/uploads/2022/07/BettyAndVeronicaFriendsForever_SummerSurfParty_01-13-1-768x1180.jpg 768w" sizes="(max-width: 1000px) 100vw, 1000px" /></a>
			</dt></dl><br style="clear: both" /><dl class='gallery-item'>
			<dt class='gallery-icon portrait'>
				<a href='https://archiecomics.com/wp-content/uploads/2022/07/BettyAndVeronicaFriendsForever_SummerSurfParty_01-14.jpg'><img width="1000" height="1537" src="https://archiecomics.com/wp-content/uploads/2022/07/BettyAndVeronicaFriendsForever_SummerSurfParty_01-14.jpg" class="attachment-full size-full" alt="" loading="lazy" srcset="https://archiecomics.com/wp-content/uploads/2022/07/BettyAndVeronicaFriendsForever_SummerSurfParty_01-14.jpg 1000w, https://archiecomics.com/wp-content/uploads/2022/07/BettyAndVeronicaFriendsForever_SummerSurfParty_01-14-195x300.jpg 195w, https://archiecomics.com/wp-content/uploads/2022/07/BettyAndVeronicaFriendsForever_SummerSurfParty_01-14-666x1024.jpg 666w, https://archiecomics.com/wp-content/uploads/2022/07/BettyAndVeronicaFriendsForever_SummerSurfParty_01-14-98x150.jpg 98w, https://archiecomics.com/wp-content/uploads/2022/07/BettyAndVeronicaFriendsForever_SummerSurfParty_01-14-768x1180.jpg 768w" sizes="(max-width: 1000px) 100vw, 1000px" /></a>
			</dt></dl><dl class='gallery-item'>
			<dt class='gallery-icon portrait'>
				<a href='https://archiecomics.com/wp-content/uploads/2022/07/BettyAndVeronicaFriendsForever_SummerSurfParty_01-15.jpg'><img width="1000" height="1537" src="https://archiecomics.com/wp-content/uploads/2022/07/BettyAndVeronicaFriendsForever_SummerSurfParty_01-15.jpg" class="attachment-full size-full" alt="" loading="lazy" srcset="https://archiecomics.com/wp-content/uploads/2022/07/BettyAndVeronicaFriendsForever_SummerSurfParty_01-15.jpg 1000w, https://archiecomics.com/wp-content/uploads/2022/07/BettyAndVeronicaFriendsForever_SummerSurfParty_01-15-195x300.jpg 195w, https://archiecomics.com/wp-content/uploads/2022/07/BettyAndVeronicaFriendsForever_SummerSurfParty_01-15-666x1024.jpg 666w, https://archiecomics.com/wp-content/uploads/2022/07/BettyAndVeronicaFriendsForever_SummerSurfParty_01-15-98x150.jpg 98w, https://archiecomics.com/wp-content/uploads/2022/07/BettyAndVeronicaFriendsForever_SummerSurfParty_01-15-768x1180.jpg 768w" sizes="(max-width: 1000px) 100vw, 1000px" /></a>
			</dt></dl><dl class='gallery-item'>
			<dt class='gallery-icon portrait'>
				<a href='https://archiecomics.com/wp-content/uploads/2022/07/BettyAndVeronicaFriendsForever_SummerSurfParty_01-16.jpg'><img width="1000" height="1537" src="https://archiecomics.com/wp-content/uploads/2022/07/BettyAndVeronicaFriendsForever_SummerSurfParty_01-16.jpg" class="attachment-full size-full" alt="" loading="lazy" srcset="https://archiecomics.com/wp-content/uploads/2022/07/BettyAndVeronicaFriendsForever_SummerSurfParty_01-16.jpg 1000w, https://archiecomics.com/wp-content/uploads/2022/07/BettyAndVeronicaFriendsForever_SummerSurfParty_01-16-195x300.jpg 195w, https://archiecomics.com/wp-content/uploads/2022/07/BettyAndVeronicaFriendsForever_SummerSurfParty_01-16-666x1024.jpg 666w, https://archiecomics.com/wp-content/uploads/2022/07/BettyAndVeronicaFriendsForever_SummerSurfParty_01-16-98x150.jpg 98w, https://archiecomics.com/wp-content/uploads/2022/07/BettyAndVeronicaFriendsForever_SummerSurfParty_01-16-768x1180.jpg 768w" sizes="(max-width: 1000px) 100vw, 1000px" /></a>
			</dt></dl><dl class='gallery-item'>
			<dt class='gallery-icon portrait'>
				<a href='https://archiecomics.com/wp-content/uploads/2022/07/BettyAndVeronicaFriendsForever_SummerSurfParty_01-17.jpg'><img width="1000" height="1537" src="https://archiecomics.com/wp-content/uploads/2022/07/BettyAndVeronicaFriendsForever_SummerSurfParty_01-17.jpg" class="attachment-full size-full" alt="" loading="lazy" srcset="https://archiecomics.com/wp-content/uploads/2022/07/BettyAndVeronicaFriendsForever_SummerSurfParty_01-17.jpg 1000w, https://archiecomics.com/wp-content/uploads/2022/07/BettyAndVeronicaFriendsForever_SummerSurfParty_01-17-195x300.jpg 195w, https://archiecomics.com/wp-content/uploads/2022/07/BettyAndVeronicaFriendsForever_SummerSurfParty_01-17-666x1024.jpg 666w, https://archiecomics.com/wp-content/uploads/2022/07/BettyAndVeronicaFriendsForever_SummerSurfParty_01-17-98x150.jpg 98w, https://archiecomics.com/wp-content/uploads/2022/07/BettyAndVeronicaFriendsForever_SummerSurfParty_01-17-768x1180.jpg 768w" sizes="(max-width: 1000px) 100vw, 1000px" /></a>
			</dt></dl><br style="clear: both" />
		</div>

</div>
</div>
</div>
</div>
</div>
</div>
<div id="post-27113" class="post-27113 post type-post status-publish format-standard has-post-thumbnail hentry category-free-comic category-news category-on-sale-today tag-betty-veronica tag-big-ethel-energy tag-first-looks tag-on-sale-today-2 tag-preview tag-previews tag-showcase-digest">
<div class="entry-content">
<hr />
</div>
</div>
<p>&nbsp;</p>
<div id="post-27113" class="post-27113 post type-post status-publish format-standard has-post-thumbnail hentry category-free-comic category-news category-on-sale-today tag-betty-veronica tag-big-ethel-energy tag-first-looks tag-on-sale-today-2 tag-preview tag-previews tag-showcase-digest">
<div class="entry-content">
<div id="post-27113" class="post-27113 post type-post status-publish format-standard has-post-thumbnail hentry category-free-comic category-news category-on-sale-today tag-betty-veronica tag-big-ethel-energy tag-first-looks tag-on-sale-today-2 tag-preview tag-previews tag-showcase-digest">
<div class="entry-content">
<div id="gallery-2" class="gallery galleryid-27113 gallery-columns-3 gallery-size-full">
<p><a href="https://archiecomics.com/wp-content/uploads/2022/07/WorldOfArchieJumboComicsDigest_121_Cover_Lindsey.jpg"><img loading="lazy" class="aligncenter wp-image-27996 size-full" src="https://archiecomics.com/wp-content/uploads/2022/07/WorldOfArchieJumboComicsDigest_121_Cover_Lindsey.jpg" alt="" width="1200" height="1616" srcset="https://archiecomics.com/wp-content/uploads/2022/07/WorldOfArchieJumboComicsDigest_121_Cover_Lindsey.jpg 1200w, https://archiecomics.com/wp-content/uploads/2022/07/WorldOfArchieJumboComicsDigest_121_Cover_Lindsey-223x300.jpg 223w, https://archiecomics.com/wp-content/uploads/2022/07/WorldOfArchieJumboComicsDigest_121_Cover_Lindsey-760x1024.jpg 760w, https://archiecomics.com/wp-content/uploads/2022/07/WorldOfArchieJumboComicsDigest_121_Cover_Lindsey-111x150.jpg 111w, https://archiecomics.com/wp-content/uploads/2022/07/WorldOfArchieJumboComicsDigest_121_Cover_Lindsey-768x1034.jpg 768w, https://archiecomics.com/wp-content/uploads/2022/07/WorldOfArchieJumboComicsDigest_121_Cover_Lindsey-1141x1536.jpg 1141w" sizes="(max-width: 1200px) 100vw, 1200px" /></a></p>
<p><strong>TWO BRAND NEW STORIES!</strong> First, in “Go Pound Sand!” Jughead takes his little sister Jellybean to the beach promising to help her make the best sandcastle ever. Unfortunately, one of Jellybean’s friends is there with his big sister and theirs puts the Jones’ version to shame! Archie sees what’s going on and calls in some re-enforcements—enter: Veronica Lodge! Whose sandcastle will be the most royal of them all?</p>
<p>Then, in “The Doctor is In!” When Young Dr. Masters comes to Riverdale after several years of performing medical care around the world, everyone takes notice, especially Betty and Veronica, who admittedly have a crush on him. When an intern program opens up to work with him, both girls go all out to apply!</p>
<p>Script: Bill Golliher, Dan Parent<br />
Art: Bill Golliher, Dan Parent, Jim Amash, Bob Smith<br />
Colors: Glenn Whitmore<br />
Letters: Jack Morelli<br />
Cover: Francis Bonnet, Rex Lindsey, Rosario “Tito” Peña, Jack Morelli<br />
On Sale Date: 7/13<br />
192-page, full color comic<br />
$8.99 U.S.</p>
<h4 style="text-align: center;"><strong>GET YOUR COPY:</strong></h4>
<p style="text-align: center;"><span style="color: #3366ff;">Direct from the Archie Shop</span><br />
<span style="color: #0000ff;"><a style="color: #0000ff;" href="https://previewsworld.com/Catalog/MAY221194">Your Local Comic Shop</a></span><br />
<span style="color: #0000ff;"><a style="color: #0000ff;" href="https://www.amazon.com/World-Archie-Comics-Digest-Double-ebook/dp/B0B3BL2FV6">Read it Digitally on comiXology</a><br />
<a style="color: #0000ff;" href="https://store.archiecomics.com/collections/archie-digest-subscriptions/products/world-of-archie-comics-digest-subscription">Subscribe at the Archie Shop!</a></span></p>
<h4 style="text-align: center;"><strong><br />
START READING NOW!</strong></h4>
<div id="gallery-2" class="gallery galleryid-27113 gallery-columns-3 gallery-size-full">

		<style type="text/css">
			#gallery-4 {
				margin: auto;
			}
			#gallery-4 .gallery-item {
				float: left;
				margin-top: 10px;
				text-align: center;
				width: 25%;
			}
			#gallery-4 img {
				border: 2px solid #cfcfcf;
			}
			#gallery-4 .gallery-caption {
				margin-left: 0;
			}
			/* see gallery_shortcode() in wp-includes/media.php */
		</style>
		<div id='gallery-4' class='gallery galleryid-27985 gallery-columns-4 gallery-size-full'><dl class='gallery-item'>
			<dt class='gallery-icon portrait'>
				<a href='https://archiecomics.com/wp-content/uploads/2022/07/WorldOfArchieJumboComicsDigest_121-2.jpg'><img width="1200" height="1616" src="https://archiecomics.com/wp-content/uploads/2022/07/WorldOfArchieJumboComicsDigest_121-2.jpg" class="attachment-full size-full" alt="" loading="lazy" srcset="https://archiecomics.com/wp-content/uploads/2022/07/WorldOfArchieJumboComicsDigest_121-2.jpg 1200w, https://archiecomics.com/wp-content/uploads/2022/07/WorldOfArchieJumboComicsDigest_121-2-223x300.jpg 223w, https://archiecomics.com/wp-content/uploads/2022/07/WorldOfArchieJumboComicsDigest_121-2-760x1024.jpg 760w, https://archiecomics.com/wp-content/uploads/2022/07/WorldOfArchieJumboComicsDigest_121-2-111x150.jpg 111w, https://archiecomics.com/wp-content/uploads/2022/07/WorldOfArchieJumboComicsDigest_121-2-768x1034.jpg 768w, https://archiecomics.com/wp-content/uploads/2022/07/WorldOfArchieJumboComicsDigest_121-2-1141x1536.jpg 1141w" sizes="(max-width: 1200px) 100vw, 1200px" /></a>
			</dt></dl><dl class='gallery-item'>
			<dt class='gallery-icon portrait'>
				<a href='https://archiecomics.com/wp-content/uploads/2022/07/WorldOfArchieJumboComicsDigest_121-3.jpg'><img width="1200" height="1616" src="https://archiecomics.com/wp-content/uploads/2022/07/WorldOfArchieJumboComicsDigest_121-3.jpg" class="attachment-full size-full" alt="" loading="lazy" srcset="https://archiecomics.com/wp-content/uploads/2022/07/WorldOfArchieJumboComicsDigest_121-3.jpg 1200w, https://archiecomics.com/wp-content/uploads/2022/07/WorldOfArchieJumboComicsDigest_121-3-223x300.jpg 223w, https://archiecomics.com/wp-content/uploads/2022/07/WorldOfArchieJumboComicsDigest_121-3-760x1024.jpg 760w, https://archiecomics.com/wp-content/uploads/2022/07/WorldOfArchieJumboComicsDigest_121-3-111x150.jpg 111w, https://archiecomics.com/wp-content/uploads/2022/07/WorldOfArchieJumboComicsDigest_121-3-768x1034.jpg 768w, https://archiecomics.com/wp-content/uploads/2022/07/WorldOfArchieJumboComicsDigest_121-3-1141x1536.jpg 1141w" sizes="(max-width: 1200px) 100vw, 1200px" /></a>
			</dt></dl><dl class='gallery-item'>
			<dt class='gallery-icon portrait'>
				<a href='https://archiecomics.com/wp-content/uploads/2022/07/WorldOfArchieJumboComicsDigest_121-7.jpg'><img width="1200" height="1616" src="https://archiecomics.com/wp-content/uploads/2022/07/WorldOfArchieJumboComicsDigest_121-7.jpg" class="attachment-full size-full" alt="" loading="lazy" srcset="https://archiecomics.com/wp-content/uploads/2022/07/WorldOfArchieJumboComicsDigest_121-7.jpg 1200w, https://archiecomics.com/wp-content/uploads/2022/07/WorldOfArchieJumboComicsDigest_121-7-223x300.jpg 223w, https://archiecomics.com/wp-content/uploads/2022/07/WorldOfArchieJumboComicsDigest_121-7-760x1024.jpg 760w, https://archiecomics.com/wp-content/uploads/2022/07/WorldOfArchieJumboComicsDigest_121-7-111x150.jpg 111w, https://archiecomics.com/wp-content/uploads/2022/07/WorldOfArchieJumboComicsDigest_121-7-768x1034.jpg 768w, https://archiecomics.com/wp-content/uploads/2022/07/WorldOfArchieJumboComicsDigest_121-7-1141x1536.jpg 1141w" sizes="(max-width: 1200px) 100vw, 1200px" /></a>
			</dt></dl><dl class='gallery-item'>
			<dt class='gallery-icon portrait'>
				<a href='https://archiecomics.com/wp-content/uploads/2022/07/WorldOfArchieJumboComicsDigest_121-8.jpg'><img width="1200" height="1616" src="https://archiecomics.com/wp-content/uploads/2022/07/WorldOfArchieJumboComicsDigest_121-8.jpg" class="attachment-full size-full" alt="" loading="lazy" srcset="https://archiecomics.com/wp-content/uploads/2022/07/WorldOfArchieJumboComicsDigest_121-8.jpg 1200w, https://archiecomics.com/wp-content/uploads/2022/07/WorldOfArchieJumboComicsDigest_121-8-223x300.jpg 223w, https://archiecomics.com/wp-content/uploads/2022/07/WorldOfArchieJumboComicsDigest_121-8-760x1024.jpg 760w, https://archiecomics.com/wp-content/uploads/2022/07/WorldOfArchieJumboComicsDigest_121-8-111x150.jpg 111w, https://archiecomics.com/wp-content/uploads/2022/07/WorldOfArchieJumboComicsDigest_121-8-768x1034.jpg 768w, https://archiecomics.com/wp-content/uploads/2022/07/WorldOfArchieJumboComicsDigest_121-8-1141x1536.jpg 1141w" sizes="(max-width: 1200px) 100vw, 1200px" /></a>
			</dt></dl><br style="clear: both" /><dl class='gallery-item'>
			<dt class='gallery-icon portrait'>
				<a href='https://archiecomics.com/wp-content/uploads/2022/07/WorldOfArchieJumboComicsDigest_121-73.jpg'><img width="1200" height="1616" src="https://archiecomics.com/wp-content/uploads/2022/07/WorldOfArchieJumboComicsDigest_121-73.jpg" class="attachment-full size-full" alt="" loading="lazy" srcset="https://archiecomics.com/wp-content/uploads/2022/07/WorldOfArchieJumboComicsDigest_121-73.jpg 1200w, https://archiecomics.com/wp-content/uploads/2022/07/WorldOfArchieJumboComicsDigest_121-73-223x300.jpg 223w, https://archiecomics.com/wp-content/uploads/2022/07/WorldOfArchieJumboComicsDigest_121-73-760x1024.jpg 760w, https://archiecomics.com/wp-content/uploads/2022/07/WorldOfArchieJumboComicsDigest_121-73-111x150.jpg 111w, https://archiecomics.com/wp-content/uploads/2022/07/WorldOfArchieJumboComicsDigest_121-73-768x1034.jpg 768w, https://archiecomics.com/wp-content/uploads/2022/07/WorldOfArchieJumboComicsDigest_121-73-1141x1536.jpg 1141w" sizes="(max-width: 1200px) 100vw, 1200px" /></a>
			</dt></dl><dl class='gallery-item'>
			<dt class='gallery-icon portrait'>
				<a href='https://archiecomics.com/wp-content/uploads/2022/07/WorldOfArchieJumboComicsDigest_121-74.jpg'><img width="1200" height="1616" src="https://archiecomics.com/wp-content/uploads/2022/07/WorldOfArchieJumboComicsDigest_121-74.jpg" class="attachment-full size-full" alt="" loading="lazy" srcset="https://archiecomics.com/wp-content/uploads/2022/07/WorldOfArchieJumboComicsDigest_121-74.jpg 1200w, https://archiecomics.com/wp-content/uploads/2022/07/WorldOfArchieJumboComicsDigest_121-74-223x300.jpg 223w, https://archiecomics.com/wp-content/uploads/2022/07/WorldOfArchieJumboComicsDigest_121-74-760x1024.jpg 760w, https://archiecomics.com/wp-content/uploads/2022/07/WorldOfArchieJumboComicsDigest_121-74-111x150.jpg 111w, https://archiecomics.com/wp-content/uploads/2022/07/WorldOfArchieJumboComicsDigest_121-74-768x1034.jpg 768w, https://archiecomics.com/wp-content/uploads/2022/07/WorldOfArchieJumboComicsDigest_121-74-1141x1536.jpg 1141w" sizes="(max-width: 1200px) 100vw, 1200px" /></a>
			</dt></dl><dl class='gallery-item'>
			<dt class='gallery-icon portrait'>
				<a href='https://archiecomics.com/wp-content/uploads/2022/07/WorldOfArchieJumboComicsDigest_121-75.jpg'><img width="1200" height="1616" src="https://archiecomics.com/wp-content/uploads/2022/07/WorldOfArchieJumboComicsDigest_121-75.jpg" class="attachment-full size-full" alt="" loading="lazy" srcset="https://archiecomics.com/wp-content/uploads/2022/07/WorldOfArchieJumboComicsDigest_121-75.jpg 1200w, https://archiecomics.com/wp-content/uploads/2022/07/WorldOfArchieJumboComicsDigest_121-75-223x300.jpg 223w, https://archiecomics.com/wp-content/uploads/2022/07/WorldOfArchieJumboComicsDigest_121-75-760x1024.jpg 760w, https://archiecomics.com/wp-content/uploads/2022/07/WorldOfArchieJumboComicsDigest_121-75-111x150.jpg 111w, https://archiecomics.com/wp-content/uploads/2022/07/WorldOfArchieJumboComicsDigest_121-75-768x1034.jpg 768w, https://archiecomics.com/wp-content/uploads/2022/07/WorldOfArchieJumboComicsDigest_121-75-1141x1536.jpg 1141w" sizes="(max-width: 1200px) 100vw, 1200px" /></a>
			</dt></dl><dl class='gallery-item'>
			<dt class='gallery-icon portrait'>
				<a href='https://archiecomics.com/wp-content/uploads/2022/07/WorldOfArchieJumboComicsDigest_121-76.jpg'><img width="1200" height="1616" src="https://archiecomics.com/wp-content/uploads/2022/07/WorldOfArchieJumboComicsDigest_121-76.jpg" class="attachment-full size-full" alt="" loading="lazy" srcset="https://archiecomics.com/wp-content/uploads/2022/07/WorldOfArchieJumboComicsDigest_121-76.jpg 1200w, https://archiecomics.com/wp-content/uploads/2022/07/WorldOfArchieJumboComicsDigest_121-76-223x300.jpg 223w, https://archiecomics.com/wp-content/uploads/2022/07/WorldOfArchieJumboComicsDigest_121-76-760x1024.jpg 760w, https://archiecomics.com/wp-content/uploads/2022/07/WorldOfArchieJumboComicsDigest_121-76-111x150.jpg 111w, https://archiecomics.com/wp-content/uploads/2022/07/WorldOfArchieJumboComicsDigest_121-76-768x1034.jpg 768w, https://archiecomics.com/wp-content/uploads/2022/07/WorldOfArchieJumboComicsDigest_121-76-1141x1536.jpg 1141w" sizes="(max-width: 1200px) 100vw, 1200px" /></a>
			</dt></dl><br style="clear: both" /><dl class='gallery-item'>
			<dt class='gallery-icon portrait'>
				<a href='https://archiecomics.com/wp-content/uploads/2022/07/WorldOfArchieJumboComicsDigest_121-77.jpg'><img width="1200" height="1616" src="https://archiecomics.com/wp-content/uploads/2022/07/WorldOfArchieJumboComicsDigest_121-77.jpg" class="attachment-full size-full" alt="" loading="lazy" srcset="https://archiecomics.com/wp-content/uploads/2022/07/WorldOfArchieJumboComicsDigest_121-77.jpg 1200w, https://archiecomics.com/wp-content/uploads/2022/07/WorldOfArchieJumboComicsDigest_121-77-223x300.jpg 223w, https://archiecomics.com/wp-content/uploads/2022/07/WorldOfArchieJumboComicsDigest_121-77-760x1024.jpg 760w, https://archiecomics.com/wp-content/uploads/2022/07/WorldOfArchieJumboComicsDigest_121-77-111x150.jpg 111w, https://archiecomics.com/wp-content/uploads/2022/07/WorldOfArchieJumboComicsDigest_121-77-768x1034.jpg 768w, https://archiecomics.com/wp-content/uploads/2022/07/WorldOfArchieJumboComicsDigest_121-77-1141x1536.jpg 1141w" sizes="(max-width: 1200px) 100vw, 1200px" /></a>
			</dt></dl><dl class='gallery-item'>
			<dt class='gallery-icon portrait'>
				<a href='https://archiecomics.com/wp-content/uploads/2022/07/WorldOfArchieJumboComicsDigest_121-78.jpg'><img width="1200" height="1616" src="https://archiecomics.com/wp-content/uploads/2022/07/WorldOfArchieJumboComicsDigest_121-78.jpg" class="attachment-full size-full" alt="" loading="lazy" srcset="https://archiecomics.com/wp-content/uploads/2022/07/WorldOfArchieJumboComicsDigest_121-78.jpg 1200w, https://archiecomics.com/wp-content/uploads/2022/07/WorldOfArchieJumboComicsDigest_121-78-223x300.jpg 223w, https://archiecomics.com/wp-content/uploads/2022/07/WorldOfArchieJumboComicsDigest_121-78-760x1024.jpg 760w, https://archiecomics.com/wp-content/uploads/2022/07/WorldOfArchieJumboComicsDigest_121-78-111x150.jpg 111w, https://archiecomics.com/wp-content/uploads/2022/07/WorldOfArchieJumboComicsDigest_121-78-768x1034.jpg 768w, https://archiecomics.com/wp-content/uploads/2022/07/WorldOfArchieJumboComicsDigest_121-78-1141x1536.jpg 1141w" sizes="(max-width: 1200px) 100vw, 1200px" /></a>
			</dt></dl>
			<br style='clear: both' />
		</div>

</div>
</div>
</div>
</div>
</div>
</div>
<div id="post-27113" class="post-27113 post type-post status-publish format-standard has-post-thumbnail hentry category-free-comic category-news category-on-sale-today tag-betty-veronica tag-big-ethel-energy tag-first-looks tag-on-sale-today-2 tag-preview tag-previews tag-showcase-digest">
<div class="entry-content">
<hr />
</div>
</div>
<p><a href="https://www.webtoons.com/en/drama/archie-comics-big-ethel-energy/list?title_no=3363"><img loading="lazy" class="aligncenter size-large wp-image-27349" src="https://archiecomics.com/wp-content/uploads/2022/03/BigEthelEnergy_KeyArt-853x1024.png" alt="" width="853" height="1024" srcset="https://archiecomics.com/wp-content/uploads/2022/03/BigEthelEnergy_KeyArt-853x1024.png 853w, https://archiecomics.com/wp-content/uploads/2022/03/BigEthelEnergy_KeyArt-250x300.png 250w, https://archiecomics.com/wp-content/uploads/2022/03/BigEthelEnergy_KeyArt-125x150.png 125w, https://archiecomics.com/wp-content/uploads/2022/03/BigEthelEnergy_KeyArt-768x922.png 768w, https://archiecomics.com/wp-content/uploads/2022/03/BigEthelEnergy_KeyArt.png 1000w" sizes="(max-width: 853px) 100vw, 853px" /></a></p>
<p><strong>A WEBTOON DIGITAL EXCLUSIVE!</strong> After graduating from Riverdale High, Ethel couldn’t get away from her hometown — and onto her chosen career path — fast enough. When the Mayor of Riverdale pays her handsomely to write a history of the city, she can’t wait to return to take down Archie, Jughead, Betty, Veronica, and all the other Riverdale natives who made her life hell all those years ago. The only thing she forgets to consider is . . . maybe they’ve all changed, too.</p>
<p>Script: Keryl Brown Ahmed<br />
Art: Siobhan Keenan, Maria Li, Cathy Le, Kielamel Sibal<br />
Frequency: Weekly on Tuesdays<br />
<strong><span style="color: #3366ff;"><a style="color: #3366ff;" href="https://www.webtoons.com/en/drama/archie-comics-big-ethel-energy/list?title_no=3363">Series Start Page</a></span></strong></p>
<h4 style="text-align: center;"><strong><br />
PREVIEW THIS WEEK&#8217;S EPISODE!</strong></h4>

		<style type="text/css">
			#gallery-6 {
				margin: auto;
			}
			#gallery-6 .gallery-item {
				float: left;
				margin-top: 10px;
				text-align: center;
				width: 25%;
			}
			#gallery-6 img {
				border: 2px solid #cfcfcf;
			}
			#gallery-6 .gallery-caption {
				margin-left: 0;
			}
			/* see gallery_shortcode() in wp-includes/media.php */
		</style>
		<div id='gallery-6' class='gallery galleryid-27985 gallery-columns-4 gallery-size-full'><dl class='gallery-item'>
			<dt class='gallery-icon portrait'>
				<a href='https://archiecomics.com/new-archie-comics-releases-for-7-13-22/bigethelenergy_45-1/'><img width="800" height="849" src="https://archiecomics.com/wp-content/uploads/2022/07/BigEthelEnergy_45-1.jpg" class="attachment-full size-full" alt="" loading="lazy" srcset="https://archiecomics.com/wp-content/uploads/2022/07/BigEthelEnergy_45-1.jpg 800w, https://archiecomics.com/wp-content/uploads/2022/07/BigEthelEnergy_45-1-283x300.jpg 283w, https://archiecomics.com/wp-content/uploads/2022/07/BigEthelEnergy_45-1-141x150.jpg 141w, https://archiecomics.com/wp-content/uploads/2022/07/BigEthelEnergy_45-1-768x815.jpg 768w" sizes="(max-width: 800px) 100vw, 800px" /></a>
			</dt></dl><dl class='gallery-item'>
			<dt class='gallery-icon portrait'>
				<a href='https://archiecomics.com/new-archie-comics-releases-for-7-13-22/bigethelenergy_45-2/'><img width="800" height="831" src="https://archiecomics.com/wp-content/uploads/2022/07/BigEthelEnergy_45-2.jpg" class="attachment-full size-full" alt="" loading="lazy" srcset="https://archiecomics.com/wp-content/uploads/2022/07/BigEthelEnergy_45-2.jpg 800w, https://archiecomics.com/wp-content/uploads/2022/07/BigEthelEnergy_45-2-289x300.jpg 289w, https://archiecomics.com/wp-content/uploads/2022/07/BigEthelEnergy_45-2-144x150.jpg 144w, https://archiecomics.com/wp-content/uploads/2022/07/BigEthelEnergy_45-2-768x798.jpg 768w" sizes="(max-width: 800px) 100vw, 800px" /></a>
			</dt></dl><dl class='gallery-item'>
			<dt class='gallery-icon portrait'>
				<a href='https://archiecomics.com/new-archie-comics-releases-for-7-13-22/bigethelenergy_45-3/'><img width="800" height="1035" src="https://archiecomics.com/wp-content/uploads/2022/07/BigEthelEnergy_45-3.jpg" class="attachment-full size-full" alt="" loading="lazy" srcset="https://archiecomics.com/wp-content/uploads/2022/07/BigEthelEnergy_45-3.jpg 800w, https://archiecomics.com/wp-content/uploads/2022/07/BigEthelEnergy_45-3-232x300.jpg 232w, https://archiecomics.com/wp-content/uploads/2022/07/BigEthelEnergy_45-3-791x1024.jpg 791w, https://archiecomics.com/wp-content/uploads/2022/07/BigEthelEnergy_45-3-116x150.jpg 116w, https://archiecomics.com/wp-content/uploads/2022/07/BigEthelEnergy_45-3-768x994.jpg 768w" sizes="(max-width: 800px) 100vw, 800px" /></a>
			</dt></dl><dl class='gallery-item'>
			<dt class='gallery-icon portrait'>
				<a href='https://archiecomics.com/new-archie-comics-releases-for-7-13-22/bigethelenergy_45-4/'><img width="800" height="995" src="https://archiecomics.com/wp-content/uploads/2022/07/BigEthelEnergy_45-4.jpg" class="attachment-full size-full" alt="" loading="lazy" srcset="https://archiecomics.com/wp-content/uploads/2022/07/BigEthelEnergy_45-4.jpg 800w, https://archiecomics.com/wp-content/uploads/2022/07/BigEthelEnergy_45-4-241x300.jpg 241w, https://archiecomics.com/wp-content/uploads/2022/07/BigEthelEnergy_45-4-121x150.jpg 121w, https://archiecomics.com/wp-content/uploads/2022/07/BigEthelEnergy_45-4-768x955.jpg 768w" sizes="(max-width: 800px) 100vw, 800px" /></a>
			</dt></dl><br style="clear: both" /><dl class='gallery-item'>
			<dt class='gallery-icon portrait'>
				<a href='https://archiecomics.com/new-archie-comics-releases-for-7-13-22/bigethelenergy_45-5/'><img width="800" height="861" src="https://archiecomics.com/wp-content/uploads/2022/07/BigEthelEnergy_45-5.jpg" class="attachment-full size-full" alt="" loading="lazy" srcset="https://archiecomics.com/wp-content/uploads/2022/07/BigEthelEnergy_45-5.jpg 800w, https://archiecomics.com/wp-content/uploads/2022/07/BigEthelEnergy_45-5-279x300.jpg 279w, https://archiecomics.com/wp-content/uploads/2022/07/BigEthelEnergy_45-5-139x150.jpg 139w, https://archiecomics.com/wp-content/uploads/2022/07/BigEthelEnergy_45-5-768x827.jpg 768w" sizes="(max-width: 800px) 100vw, 800px" /></a>
			</dt></dl><dl class='gallery-item'>
			<dt class='gallery-icon landscape'>
				<a href='https://archiecomics.com/new-archie-comics-releases-for-7-13-22/bigethelenergy_45-6/'><img width="800" height="785" src="https://archiecomics.com/wp-content/uploads/2022/07/BigEthelEnergy_45-6.jpg" class="attachment-full size-full" alt="" loading="lazy" srcset="https://archiecomics.com/wp-content/uploads/2022/07/BigEthelEnergy_45-6.jpg 800w, https://archiecomics.com/wp-content/uploads/2022/07/BigEthelEnergy_45-6-300x294.jpg 300w, https://archiecomics.com/wp-content/uploads/2022/07/BigEthelEnergy_45-6-150x147.jpg 150w, https://archiecomics.com/wp-content/uploads/2022/07/BigEthelEnergy_45-6-768x754.jpg 768w" sizes="(max-width: 800px) 100vw, 800px" /></a>
			</dt></dl><dl class='gallery-item'>
			<dt class='gallery-icon portrait'>
				<a href='https://archiecomics.com/new-archie-comics-releases-for-7-13-22/bigethelenergy_45-7/'><img width="800" height="853" src="https://archiecomics.com/wp-content/uploads/2022/07/BigEthelEnergy_45-7.jpg" class="attachment-full size-full" alt="" loading="lazy" srcset="https://archiecomics.com/wp-content/uploads/2022/07/BigEthelEnergy_45-7.jpg 800w, https://archiecomics.com/wp-content/uploads/2022/07/BigEthelEnergy_45-7-281x300.jpg 281w, https://archiecomics.com/wp-content/uploads/2022/07/BigEthelEnergy_45-7-141x150.jpg 141w, https://archiecomics.com/wp-content/uploads/2022/07/BigEthelEnergy_45-7-768x819.jpg 768w" sizes="(max-width: 800px) 100vw, 800px" /></a>
			</dt></dl><dl class='gallery-item'>
			<dt class='gallery-icon portrait'>
				<a href='https://archiecomics.com/new-archie-comics-releases-for-7-13-22/bigethelenergy_45-8/'><img width="800" height="1259" src="https://archiecomics.com/wp-content/uploads/2022/07/BigEthelEnergy_45-8.jpg" class="attachment-full size-full" alt="" loading="lazy" srcset="https://archiecomics.com/wp-content/uploads/2022/07/BigEthelEnergy_45-8.jpg 800w, https://archiecomics.com/wp-content/uploads/2022/07/BigEthelEnergy_45-8-191x300.jpg 191w, https://archiecomics.com/wp-content/uploads/2022/07/BigEthelEnergy_45-8-651x1024.jpg 651w, https://archiecomics.com/wp-content/uploads/2022/07/BigEthelEnergy_45-8-95x150.jpg 95w, https://archiecomics.com/wp-content/uploads/2022/07/BigEthelEnergy_45-8-768x1209.jpg 768w" sizes="(max-width: 800px) 100vw, 800px" /></a>
			</dt></dl><br style="clear: both" /><dl class='gallery-item'>
			<dt class='gallery-icon portrait'>
				<a href='https://archiecomics.com/new-archie-comics-releases-for-7-13-22/bigethelenergy_45-9/'><img width="800" height="979" src="https://archiecomics.com/wp-content/uploads/2022/07/BigEthelEnergy_45-9.jpg" class="attachment-full size-full" alt="" loading="lazy" srcset="https://archiecomics.com/wp-content/uploads/2022/07/BigEthelEnergy_45-9.jpg 800w, https://archiecomics.com/wp-content/uploads/2022/07/BigEthelEnergy_45-9-245x300.jpg 245w, https://archiecomics.com/wp-content/uploads/2022/07/BigEthelEnergy_45-9-123x150.jpg 123w, https://archiecomics.com/wp-content/uploads/2022/07/BigEthelEnergy_45-9-768x940.jpg 768w" sizes="(max-width: 800px) 100vw, 800px" /></a>
			</dt></dl><dl class='gallery-item'>
			<dt class='gallery-icon portrait'>
				<a href='https://archiecomics.com/new-archie-comics-releases-for-7-13-22/bigethelenergy_45-10/'><img width="800" height="861" src="https://archiecomics.com/wp-content/uploads/2022/07/BigEthelEnergy_45-10.jpg" class="attachment-full size-full" alt="" loading="lazy" srcset="https://archiecomics.com/wp-content/uploads/2022/07/BigEthelEnergy_45-10.jpg 800w, https://archiecomics.com/wp-content/uploads/2022/07/BigEthelEnergy_45-10-279x300.jpg 279w, https://archiecomics.com/wp-content/uploads/2022/07/BigEthelEnergy_45-10-139x150.jpg 139w, https://archiecomics.com/wp-content/uploads/2022/07/BigEthelEnergy_45-10-768x827.jpg 768w" sizes="(max-width: 800px) 100vw, 800px" /></a>
			</dt></dl><dl class='gallery-item'>
			<dt class='gallery-icon portrait'>
				<a href='https://archiecomics.com/new-archie-comics-releases-for-7-13-22/bigethelenergy_45-11/'><img width="800" height="1421" src="https://archiecomics.com/wp-content/uploads/2022/07/BigEthelEnergy_45-11.jpg" class="attachment-full size-full" alt="" loading="lazy" srcset="https://archiecomics.com/wp-content/uploads/2022/07/BigEthelEnergy_45-11.jpg 800w, https://archiecomics.com/wp-content/uploads/2022/07/BigEthelEnergy_45-11-169x300.jpg 169w, https://archiecomics.com/wp-content/uploads/2022/07/BigEthelEnergy_45-11-576x1024.jpg 576w, https://archiecomics.com/wp-content/uploads/2022/07/BigEthelEnergy_45-11-84x150.jpg 84w, https://archiecomics.com/wp-content/uploads/2022/07/BigEthelEnergy_45-11-768x1364.jpg 768w" sizes="(max-width: 800px) 100vw, 800px" /></a>
			</dt></dl>
			<br style='clear: both' />
		</div>

<hr />
<div id="post-27113" class="post-27113 post type-post status-publish format-standard has-post-thumbnail hentry category-free-comic category-news category-on-sale-today tag-betty-veronica tag-big-ethel-energy tag-first-looks tag-on-sale-today-2 tag-preview tag-previews tag-showcase-digest">
<div class="entry-content">
<h3 class="null" style="text-align: center;"><strong>NEWLY DIGITIZED CLASSIC COMICS</strong></h3>
<p style="text-align: center;">Read these on <span style="color: #0000ff;"><a style="color: #0000ff;" href="https://www.amazon.com/dp/B07JK9TR9W?binding=kindle_edition&amp;qid=1649439844&amp;sr=8-1&amp;ref=dbs_dp_rwt_sb_pc_tukn">comiXology</a></span>!</p>
<p><a href="https://www.amazon.com/Archies-Girls-Betty-Veronica-314-ebook/dp/B0B3NGYD68"><img loading="lazy" class="aligncenter wp-image-28042 size-full" src="https://archiecomics.com/wp-content/uploads/2022/07/ArchiesGirlsBettyAndVeronica_316-1.jpg" alt="" width="1000" height="1538" srcset="https://archiecomics.com/wp-content/uploads/2022/07/ArchiesGirlsBettyAndVeronica_316-1.jpg 1000w, https://archiecomics.com/wp-content/uploads/2022/07/ArchiesGirlsBettyAndVeronica_316-1-195x300.jpg 195w, https://archiecomics.com/wp-content/uploads/2022/07/ArchiesGirlsBettyAndVeronica_316-1-666x1024.jpg 666w, https://archiecomics.com/wp-content/uploads/2022/07/ArchiesGirlsBettyAndVeronica_316-1-98x150.jpg 98w, https://archiecomics.com/wp-content/uploads/2022/07/ArchiesGirlsBettyAndVeronica_316-1-768x1181.jpg 768w, https://archiecomics.com/wp-content/uploads/2022/07/ArchiesGirlsBettyAndVeronica_316-1-999x1536.jpg 999w" sizes="(max-width: 1000px) 100vw, 1000px" /></a><a href="https://www.amazon.com/Archies-Girls-Betty-Veronica-315-ebook/dp/B0B3NKNDYG"><img loading="lazy" class="aligncenter wp-image-28043 size-full" src="https://archiecomics.com/wp-content/uploads/2022/07/ArchiesGirlsBettyAndVeronica_317-1.jpg" alt="" width="1000" height="1538" srcset="https://archiecomics.com/wp-content/uploads/2022/07/ArchiesGirlsBettyAndVeronica_317-1.jpg 1000w, https://archiecomics.com/wp-content/uploads/2022/07/ArchiesGirlsBettyAndVeronica_317-1-195x300.jpg 195w, https://archiecomics.com/wp-content/uploads/2022/07/ArchiesGirlsBettyAndVeronica_317-1-666x1024.jpg 666w, https://archiecomics.com/wp-content/uploads/2022/07/ArchiesGirlsBettyAndVeronica_317-1-98x150.jpg 98w, https://archiecomics.com/wp-content/uploads/2022/07/ArchiesGirlsBettyAndVeronica_317-1-768x1181.jpg 768w, https://archiecomics.com/wp-content/uploads/2022/07/ArchiesGirlsBettyAndVeronica_317-1-999x1536.jpg 999w" sizes="(max-width: 1000px) 100vw, 1000px" /></a></p>
</div>
</div>
											</div><!-- .entry-content -->


					<footer class="entry-meta">
						<span class="footer-tags"><i class="crycon-tag crycon-metas" title="Tagged"></i>&nbsp; <a href="https://archiecomics.com/tag/betty-and-veronica/" rel="tag">betty and veronica</a>, <a href="https://archiecomics.com/tag/betty-and-veronica-digest/" rel="tag">betty and veronica digest</a>, <a href="https://archiecomics.com/tag/betty-and-veronica-friends-forever/" rel="tag">betty and veronica friends forever</a>, <a href="https://archiecomics.com/tag/big-ethel-energy/" rel="tag">big ethel energy</a>, <a href="https://archiecomics.com/tag/first-looks/" rel="tag">first looks</a>, <a href="https://archiecomics.com/tag/josie/" rel="tag">josie</a>, <a href="https://archiecomics.com/tag/jughead/" rel="tag">jughead</a>, <a href="https://archiecomics.com/tag/new-releases/" rel="tag">new releases</a>, <a href="https://archiecomics.com/tag/on-sale-today-2/" rel="tag">on sale today</a>, <a href="https://archiecomics.com/tag/preview/" rel="tag">preview</a>, <a href="https://archiecomics.com/tag/previews/" rel="tag">previews</a>, <a href="https://archiecomics.com/tag/stacy-banks/" rel="tag">Stacy Banks</a>, <a href="https://archiecomics.com/tag/summer/" rel="tag">summer</a>, <a href="https://archiecomics.com/tag/summer-surf-party/" rel="tag">summer surf party</a>, <a href="https://archiecomics.com/tag/world-of-archie-digest/" rel="tag">world of archie digest</a>, <a href="https://archiecomics.com/tag/young-dr-masters/" rel="tag">young dr. masters</a>.</span><span class="bl_bookmark"><i class="crycon-bookmark crycon-metas" title=" Bookmark the permalink"></i> <a href="https://archiecomics.com/new-archie-comics-releases-for-7-13-22/" title="Permalink to New Archie Comics Releases for 7/13/22" rel="bookmark"> Bookmark</a>.</span>											</footer><!-- .entry-meta -->
				</div><!-- #post-## -->

				<div id="nav-below" class="navigation">
					<div class="nav-previous"><a href="https://archiecomics.com/bite-sized-archie-083-love-and-hunger/" rel="prev"><i class="meta-nav-prev"></i> Bite Sized Archie #083 – Love and Hunger</a></div>
					<div class="nav-next"></div>
				</div><!-- #nav-below -->

				 <div id="comments" class="hideme"> 	<p class="nocomments">Comments are closed.</p>
	</div><!-- #comments -->


						</div><!-- #content -->
			<div id="secondary" class="widget-area sidey" role="complementary">
		
			<ul class="xoxo">
								<li id="text-8" class="widget-container widget_text">			<div class="textwidget"><!-- /26774805/ACP_SideBarTop -->
<div id='div-gpt-ad-1447338701132-1' style='height:400px; width:250px;'>
<script type='text/javascript'>
googletag.cmd.push(function() { googletag.display('div-gpt-ad-1447338701132-1'); });
</script>
</div></div>
		</li>
		<li id="recent-posts-3" class="widget-container widget_recent_entries">
		<h3 class="widget-title">Latest News</h3>
		<ul>
											<li>
					<a href="https://archiecomics.com/new-archie-comics-releases-for-7-13-22/" aria-current="page">New Archie Comics Releases for 7/13/22</a>
									</li>
											<li>
					<a href="https://archiecomics.com/bite-sized-archie-083-love-and-hunger/">Bite Sized Archie #083 – Love and Hunger</a>
									</li>
											<li>
					<a href="https://archiecomics.com/new-archie-comics-releases-for-7-6-22/">New Archie Comics Releases for 7/6/22</a>
									</li>
											<li>
					<a href="https://archiecomics.com/archie-horror-launches-a-month-of-mayhem-this-fall/">Archie Horror launches a &#8220;Month Of Mayhem&#8221; this fall!</a>
									</li>
											<li>
					<a href="https://archiecomics.com/bite-sized-archie-082-scratch-and-claw/">Bite Sized Archie #082 – Scratch and Claw</a>
									</li>
					</ul>

		</li><li id="text-5" class="widget-container widget_text">			<div class="textwidget"><p>
</p>
<!-- /26774805/ACP_SidebarBot -->
<div id='div-gpt-ad-1447338701132-0' style='height:400px; width:250px;'>
<script type='text/javascript'>
googletag.cmd.push(function() { googletag.display('div-gpt-ad-1447338701132-0'); });
</script>
</div>
<p>
</p>
<p style="text-align: center;"><a re_target="blank" target="blank" href="http://www.comicshoplocator.com/Home" rel="noopener"><img alt="" src="http://archiecomics.com/wp-content/uploads/2014/08/comiclocator.png" /></a> <a re_target="blank" target="blank" href="/Blogs/tabid/97/EntryId/463/Where-to-find-Archie-Digital-Comics.aspx" rel="noopener"></a></p></div>
		</li>			</ul>

			
		</div>
		</section><!-- #container -->

	<div style="clear:both;"></div>
	</div> <!-- #forbottom -->


	<footer id="footer" role="contentinfo">
		<div id="colophon">
		
			
			
		</div><!-- #colophon -->

		<div id="footer2">
		
			<div id="site-copyright"><table style="width: 100%">
			<tr>
				<td valign="top" style="width: 25%">
				<h2 style="color:black;font-weight:bold;font-size:14px;font-style:normal">Archie Sites</h2>
<p style="font-size:12px;font-style:normal">
<a href="https://archiecomics.com/nft/?utm_source=ACP&amp;utm_medium=Footer%20Nav&amp;utm_campaign=ACP_Bottom_Menu" target="_blank">Archieverse NFTs</a><br />				
<p style="font-size:12px;font-style:normal">
<a href="https://store.archiecomics.com/?utm_source=ACP&amp;utm_medium=Menu&amp;utm_campaign=BottomMenu" target="_blank">Archie 

Comics Shop</a><br />

				<a href="https://store.archiecomics.com/?utm_source=ACP&amp;utm_medium=Menu&amp;utm_campaign=BottomMenu" target="_blank">Archie 

Subscriptions</a><br />
	
				<a href="http://afterlifewitharchie.com" target="_blank">Afterlife With 

Archie</a><br />
				<a href="http://darkcirclecomics.com" target="_blank">Dark Circle Comics</a><br /></p></td>

				<td valign="top" style="width: 25%">
				<h2 style="color:black;font-weight:bold;font-size:14px;font-style:normal">Comics</h2>
				<p style="font-size:12px;font-style:normal">
                                <a href="../appnews/">Digital Comics</a><br />
				<a href="http://archiecomics.com/redeem/">Redeem</a><br />
<a target="blank" href="https://checkout.subscriptiongenius.com/ArchieComics.com/login.php?s=">Subscriber Login</a><br /></p></td>

				
				<td valign="top" style="width: 25%">
<h2 style="color:black;font-weight:bold;font-size:14px;font-style:normal">Company</h2>
				<p style="font-size:12px;font-style:normal">
				<a href="../about-us/">About</a><br />
				<a href="../news/">News</a><br />
				<a href="../characters/">Characters</a><br />
                                <a href="../newsletter/">Email List</a><br />
				<a href="http://archiecomics.com/about-us/privacy-policy/">Privacy Policy</a><br />
				<a href="../about-us/">Contact</a>
				</p>
				</td>
				
				<td valign="top" style="width: 25%">
<h2 style="color:black;font-weight:bold;font-size:14px;font-style:normal">Social Media</h2>
				<p style="font-size:12px;font-style:normal">
				<a target="_blank" href="https://www.facebook.com/ArchieComicsOfficial?

ref=tn_tnmn">Facebook</a><br />
				<a target="_blank" href="https://twitter.com/archiecomics">Twitter</a><br />
				<a target="_blank" href="https://plus.google.com/u/0/103927090213296657788/posts">Google+</a><br />
				<a target="_blank" href="http://www.youtube.com/user/ArchieComicsOfficial">YouTube</a><br />
		<a target="_blank" href="http://www.goodreads.com/user/show/8914136-archie-

comics">Goodreads</a><br />
		<a target="_blank" href="http://pinterest.com/archiecomics/">Pinterest</a><br />
		<a target="_blank" href="http://archiecomics.tumblr.com/">Tumblr</a><br />
		<a target="_blank" href="http://instagram.com/archiecomics">Instagram</a></p>
				</td>
			</tr>
		</table>

		<p style="color:black;font-size:12px;font-style:normal;text-align:center">Copyright © 2022 

Archie Comic Publications, Inc. All Rights Reserved.</p>
		<p style="font-size:12px;font-style:normal;text-align:center"><a href="http://www.archiecomics.com">www.ArchieComics.com</a></p></div><div class="socials" id="sfooter">
			<a  target="_blank"  href="https://www.facebook.com/ArchieComicsOfficial?ref=tn_tnmn"
			class="socialicons social-Facebook" title="Archie Comics Facebook">
				<img alt="Facebook" src="https://archiecomics.com/wp-content/themes/tempera/images/socials/Facebook.png" />
			</a>
			<a  target="_blank"  href="https://twitter.com/archiecomics"
			class="socialicons social-Twitter" title="Archie Comics Twitter">
				<img alt="Twitter" src="https://archiecomics.com/wp-content/themes/tempera/images/socials/Twitter.png" />
			</a>
			<a  target="_blank"  href="http://www.youtube.com/user/ArchieComicsOfficial"
			class="socialicons social-YouTube" title="Archie Comics YouTube Channel">
				<img alt="YouTube" src="https://archiecomics.com/wp-content/themes/tempera/images/socials/YouTube.png" />
			</a>
			<a  target="_blank"  href="https://plus.google.com/u/0/103927090213296657788/posts"
			class="socialicons social-GooglePlus" title="Archie Comics Google+">
				<img alt="GooglePlus" src="https://archiecomics.com/wp-content/themes/tempera/images/socials/GooglePlus.png" />
			</a>
			<a  target="_blank"  href="http://www.goodreads.com/user/show/8914136-archie-comics"
			class="socialicons social-GoodReads" title="Archie Comics GoodReads">
				<img alt="GoodReads" src="https://archiecomics.com/wp-content/themes/tempera/images/socials/GoodReads.png" />
			</a></div>	<div style="display:block;float:right;text-align:right;padding:5px 20px 5px;text-transform:uppercase;font-size:11px;">
		</div><!-- #site-info -->

			
		</div><!-- #footer2 -->

	</footer><!-- #footer -->

	</div><!-- #main -->
</div><!-- #wrapper -->


<noscript><img height="1" width="1" style="display: none;" src="https://www.facebook.com/tr?id=150910205450480&ev=PageView&noscript=1&cd%5Bpost_category%5D=Free+Comic%2C+News%2C+On+Sale+Today&cd%5Bpage_title%5D=New+Archie+Comics+Releases+for+7%2F13%2F22&cd%5Bpost_type%5D=post&cd%5Bpost_id%5D=27985&cd%5Bplugin%5D=PixelYourSite&cd%5Buser_role%5D=guest&cd%5Bevent_url%5D=archiecomics.com%2Fnew-archie-comics-releases-for-7-13-22%2F" alt="facebook_pixel"></noscript>
<script type='text/javascript' id='tempera-frontend-js-extra'>
/* <![CDATA[ */
var tempera_settings = {"mobile":"1","fitvids":"1","contentwidth":"900"};
/* ]]> */
</script>
<script type='text/javascript' src='https://archiecomics.com/wp-content/themes/tempera/js/frontend.js?ver=1.8.0' id='tempera-frontend-js'></script>
<script type='text/javascript' src='https://archiecomics.com/wp-includes/js/comment-reply.min.js?ver=6.0' id='comment-reply-js'></script>
<script type='text/javascript' src='https://archiecomics.com/wp-content/plugins/wp-gallery-custom-links/wp-gallery-custom-links.js?ver=1.1' id='wp-gallery-custom-links-js-js'></script>
	<script type="text/javascript">
	var cryout_global_content_width = 900;
	var cryout_toTop_offset = 1150;
				(function(i,s,o,g,r,a,m){i['GoogleAnalyticsObject']=r;i[r]=i[r]||function(){
  (i[r].q=i[r].q||[]).push(arguments)},i[r].l=1*new Date();a=s.createElement(o),
  m=s.getElementsByTagName(o)[0];a.async=1;a.src=g;m.parentNode.insertBefore(a,m)
  })(window,document,'script','//www.google-analytics.com/analytics.js','ga');

  ga('create', 'UA-45978859-4', 'auto');
  ga('send', 'pageview'); 


var googletag = googletag || {};
googletag.cmd = googletag.cmd || [];
(function() {
var gads = document.createElement('script');
gads.async = true;
gads.type = 'text/javascript';
var useSSL = 'https:' == document.location.protocol;
gads.src = (useSSL ? 'https:' : 'http:') + 
'//www.googletagservices.com/tag/js/gpt.js';
var node = document.getElementsByTagName('script')[0];
node.parentNode.insertBefore(gads, node);
})();


  googletag.cmd.push(function() {
    googletag.defineSlot('/26774805/ACP_SidebarBot', [250, 400], 'div-gpt-ad-1447338701132-0').addService(googletag.pubads());
    googletag.defineSlot('/26774805/ACP_SideBarTop', [250, 400], 'div-gpt-ad-1447338701132-1').addService(googletag.pubads());
    googletag.pubads().enableSingleRequest();
    googletag.enableServices();
  });		</script> 
</body>
</html>
